Medibuntu offline

Bug #985441 reported by Colin Mills on 2012-04-19
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Medibuntu
Fix Released
Undecided
Unassigned

Bug Description

Unable to connect to Medibuntu. When running Software Updater, I get the following error message:-

W:Failed to fetch http://packages.medibuntu.org/dists/precise/free/i18n/Translation-en Unable to connect to packages.medibuntu.org:http:
, W:Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/i18n/Translation-en Unable to connect to packages.medibuntu.org:http:
, E:Some index files failed to download. They have been ignored, or old ones used instead.

I tried 'pinging' Medibuntu and got the following message

ping -c 3 packages.medibuntu.org
PING packages.medibuntu.org (88.191.127.22) 56(84) bytes of data.

--- packages.medibuntu.org ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2014ms

I am running Ubuntu 12.04 (64 bit).

Gauvain Pocentek (gpocentek) wrote :

Everything works fine for me. The servers are up.

Please check again, and make sure that you don't have filters of some sort.

Colin Mills (cm006a5077) wrote :

Still getting the same error message.

I was able to access Medibunu, until about 24 hours ago.

I do not have any filters on (apart from the firewall, which I disabled, but still unable to connect to Medibuntu), and have made no changes to Ubuntu 12.04 since yesterday, other than to run the system updates.

Gauvain Pocentek (gpocentek) wrote :

Could you give me your IP address (here or by mail if you prefer)? I'll check on the servers if something is blocking you.

Colin Mills (cm006a5077) wrote :

May be a similar bug to the one reported in the Ubuntu forum post (http://ubuntuforums.org/showthread.php?t=1961166)

Colin Mills (cm006a5077) wrote :

Gauvain

Forgot to mention that I have emailed you my IP address.

Ian McMichael (ian-sigma-uk) wrote :

Same for me for the last couple of days from both Virgin cable and BE ADSL in the UK.

Gauvain Pocentek (gpocentek) wrote :

Looks like a routing issue. I'm afraid I can't do much about it...

Colin Mills (cm006a5077) wrote :

Could you explain what this routing error could be?

I ask because I am able to update all my other launchpad repos and have just installed a new ppa from launchpad.

 I also tried editing the file /etc/apt/sources.list.d/medibuntu.list and replacing http://packages.medibuntu.org with http://fr.packages.medibuntu.org (the french server), without success.

Ian McMichael (ian-sigma-uk) wrote :
Download full text (13.8 KiB)

I'm cannot concur with the routing issue diagnosis. Having tried multiple UK based networks, I find it unlikely. Also, I can always get ICMP traffic to packages.medibuntu.org. To me it feels like a web server (or possibly load balancer) issue on the host. Here's my evidence:

ian@custard:~$ ping packages.medibuntu.org
PING packages.medibuntu.org (88.191.127.22) 56(84) bytes of data.
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=1 ttl=56 time=14.1 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=2 ttl=56 time=14.2 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=3 ttl=56 time=14.0 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=4 ttl=56 time=14.3 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=5 ttl=56 time=14.4 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=6 ttl=56 time=13.9 ms
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=7 ttl=56 time=14.4 ms
^C
--- packages.medibuntu.org ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6007ms
rtt min/avg/max/mdev = 13.950/14.241/14.490/0.208 ms
ian@custard:~$ sudo apt-get update
[sudo] password for ian:
Hit http://packages.medibuntu.org oneiric InRelease
Ign http://dl.google.com stable InRelease
Ign http://gb.archive.ubuntu.com oneiric InRelease
Ign http://gb.archive.ubuntu.com oneiric-updates InRelease
Hit http://gb.archive.ubuntu.com oneiric Release.gpg
Get:1 http://dl.google.com stable Release.gpg [198 B]
Hit http://gb.archive.ubuntu.com oneiric-updates Release.gpg
Hit http://gb.archive.ubuntu.com oneiric Release
Hit http://packages.medibuntu.org oneiric/free Sources
Hit http://gb.archive.ubuntu.com oneiric-updates Release
Get:2 http://dl.google.com stable Release [1,347 B]
Hit http://gb.archive.ubuntu.com oneiric/main Sources
Hit http://gb.archive.ubuntu.com oneiric/restricted Sources
Hit http://gb.archive.ubuntu.com oneiric/universe Sources
Hit http://gb.archive.ubuntu.com oneiric/multiverse Sources
Hit http://gb.archive.ubuntu.com oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Hit http://gb.archive.ubuntu.com oneiric/restrict...

Colin Mills (cm006a5077) wrote :

It would appear that this problem has occurred before (see http://www.webupd8.org/2010/04/medibuntu-repository-down-what-to-do.html. This site suggests a number of alternative sites for medibuntu, and a fix for the Medibuntu offline error.

I quote
Update: there's an even easier way to fix this (thanks to defrysk). Apparently only the DNS are having issues so you can fix Medibuntu by keeping original address and pasting this in a terminal:
echo "88.191.101.8 packages.medibuntu.org" | sudo tee -a /etc/hosts

This puts the Medibuntu IP address in the hosts file.

I restarted the system, after running the command in a terminal, and I am now able to access the Medibuntu reepository.

So problem appears to be associated with DNS.

Andy Bovett (abovett) wrote :

I'm also getting this problem. Strayngely, I can get the package lists manually with wget, but apt-get update or aptitude update fails.

So, for example, this works:

wget http://packages.medibuntu.org/dists/precise/non-free/binary-i386/Packages

even though when I do apt-get update, I have this error (amongst others):

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/binary-i386/Packages
Unable to connect to packages.medibuntu.org:http:

Gauvain Pocentek (gpocentek) wrote :

Could you try with this apt configuration instead of the current one (in /etc/apt/sources.list.d/medibuntu.list):

 deb http://packages.medibuntu.org:8080 <your_version> free non-free

Only the port changes. This will use the web server directly, bypassing the load balancer to see if the problems comes from there.

Colin Mills (cm006a5077) wrote :

Replacing the apt configuration with " deb http://packages.medibuntu.org:8080 precise free non-free" fixes the problem. I can now access Medibuntu at last.

Hope this helps

Ian McMichael (ian-sigma-uk) wrote :

No joy here on port 8080 I'm afraid:

Err http://packages.medibuntu.org oneiric InRelease

Err http://packages.medibuntu.org oneiric Release.gpg
  Unable to connect to packages.medibuntu.org:8080:
Fetched 2,314 B in 2min 0s (19 B/s)
Reading package lists... Done
W: Failed to fetch http://packages.medibuntu.org:8080/dists/oneiric/InRelease

W: Failed to fetch http://packages.medibuntu.org:8080/dists/oneiric/Release.gpg Unable to connect to packages.medibuntu.org:8080:

W: Some index files failed to download. They have been ignored, or old ones used instead.

That may be because the IP address is currently unreachable via ICMP echo:

PING packages.medibuntu.org (88.191.127.22) 56(84) bytes of data.
^C
--- packages.medibuntu.org ping statistics ---
23 packets transmitted, 0 received, 100% packet loss, time 22175ms

Here's the network path from me to the repository server:

traceroute to packages.medibuntu.org (88.191.127.22), 30 hops max, 60 byte packets
 1 gatekeeper.sigma-uk.net (192.168.15.254) 0.258 ms 0.326 ms 0.413 ms
 2 * * *
 3 * * *
 4 linx-6k-1.routers.proxad.net (195.66.224.191) 9.476 ms * *
 5 bzn-crs16-1-be1102.intf.routers.proxad.net (212.27.51.185) 19.097 ms 19.453 ms 19.624 ms
 6 dedibox-2-p.intf.routers.proxad.net (212.27.50.162) 19.796 ms 19.428 ms 52.343 ms
 7 88.191.2.69 (88.191.2.69) 21.406 ms * 15.694 ms
 8 faraway.pocentek.net (88.191.127.22) 15.556 ms 15.504 ms 15.616 ms

Let me know if there's anything else I can test for you?

I'm on precise. Repository, as is, not available from three days.

This fix my problem:
echo "88.191.101.8 packages.medibuntu.org" | sudo tee -a /etc/hosts

Andy Bovett (abovett) wrote :

Using http://packages.medibuntu.org:8080 does not work for me, but adding the IP address to the hosts file appears to so far - just tried on one PC so far. I will try on the rest of my PCs and report back.

Andy Bovett (abovett) wrote :

Correction to my above comment: using http://packages.medibuntu.org:8080 *does* work for me (typo the first time I tried it), as does adding the IP address to the hosts file. I've tried this on four PCs - two running oneiric and two running precise.

Ian McMichael (ian-sigma-uk) wrote :

Something must have changed. Port 8080 is now working for me also and I've changed nothing from the post 8 hours ago. Just retried apt-get update and it connects fine. A web server re-configuration?

neclepsio (neclepsio) wrote :

apt-get still does not work for me (in Italy with Fastweb).
The web server correctly fetches the Packages file using the browser.

neclepsio (neclepsio) wrote :

ps: using 8080 port works.

Andy Bovett (abovett) wrote :

I'm now getting different problems depending on which version of Ubuntu I'm using.

oneiric: port 8080 still works

precise: port 8080 does NOT work but putting the IP address in the hosts file does

Something has changed because eariler port 8080 was working on all PCs

Andy Bovett (abovett) wrote :

Getting worse: neither using port 8080 or adding medibuntu to the hosts file work on any of my PCs now :(

Gauvain Pocentek (gpocentek) wrote :

Andy, does wget still work?

Dirk T. (dverbeek) wrote :

I had the issue from Poland and Denmark using Kubuntu 12.04 even though mtr gave a reasonable ping to both medibuntu.org and packages.medibuntu.org

The solution of hardcoding the hosts file works.

Colin Mills (cm006a5077) wrote :

For any one who has a similar problem to Andy, where neither of the two options work, there is one more option . Go to my post (#10) where I reported on the "echo "88.191.101.8 packages.medibuntu.org" | sudo tee -a /etc/hosts" tip and cllick in the website link.

The website lists alternative Medibuntu mirror sites. Websites Mirror1 and Mirror3 still support all Ubuntu versions, including Precise:-
http://mirrors.ucr.ac.cr/medibuntu
ftp://ftp.leg.uct.ac.za/pub/linux/medibuntu

Just follow the installation instructions (remember to replace "Lucid" whatever Ubuntu version you're using).

When the main repository is working you can always change it back.

Dirk T. (dverbeek) wrote :

I just noticed the IP that doesn't work for me is: 88.191.127.22

Gauvain Pocentek (gpocentek) wrote :

I still can't reproduce the problem on my side.

For reporters, could you run the update with debug options:

 apt-get update -o Debug::Acquire::Http=true

Please run this without any workaround (don't use port 8080, don't set an IP in /etc/hosts).

Thanks.

Changed in medibuntu:
status: New → Confirmed
Colin Mills (cm006a5077) wrote :

I hadto run as root i.e.
sudo apt-get update -o Debug::Acquire::Http=true

Whatever the command does, it seems to have worked. I no longer get the "Unable to connect to Medibuntu" error message.

Thanks

Hope this helps.

Ian McMichael (ian-sigma-uk) wrote :
Download full text (8.0 KiB)

Here's (medibuntu bits of) the debug trace from my system with the port 8080 removed so that I'm back through the load balancer:

GET /dists/oneiric/non-free/i18n/Translation-en_GB.gz HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /dists/oneiric/non-free/i18n/Translation-en.gz HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

HTTP/1.0 403 Forbidden
Cache-Control: no-cache
Connection: close
Content-Type: text/html

GET /dists/oneiric/non-free/i18n/Translation-en_GB.gz HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /dists/oneiric/non-free/i18n/Translation-en.gz HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

HTTP/1.1 404 Not Found
Date: Wed, 25 Apr 2012 09:17:37 GMT
Server: Apache/2.2.14 (Ubuntu)
Content-Length: 358
Keep-Alive: timeout=15, max=61
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

HTTP/1.1 404 Not Found
Date: Wed, 25 Apr 2012 09:17:37 GMT
Server: Apache/2.2.14 (Ubuntu)
Content-Length: 340
Keep-Alive: timeout=15, max=60
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

GET /dists/oneiric/free/i18n/Translation-en_GB HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /stebbins/handbrake-snapshots/ubuntu/dists/oneiric/main/i18n/Translation-en_GB HTTP/1.1
Host: ppa.launchpad.net
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /stebbins/handbrake-snapshots/ubuntu/dists/oneiric/main/i18n/Translation-en HTTP/1.1
Host: ppa.launchpad.net
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

HTTP/1.1 404 Not Found
Date: Wed, 25 Apr 2012 09:17:37 GMT
Server: Apache/2.2.14 (Ubuntu)
Content-Length: 337
Keep-Alive: timeout=15, max=59
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

GET /wfg/0ad/ubuntu/dists/oneiric/main/i18n/Translation-en_GB HTTP/1.1
Host: ppa.launchpad.net
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

HTTP/1.0 403 Forbidden
Cache-Control: no-cache
Connection: close
Content-Type: text/html

GET /dists/oneiric/non-free/i18n/Translation-en.gz HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /dists/oneiric/free/i18n/Translation-en_GB HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

GET /dists/oneiric/free/i18n/Translation-en HTTP/1.1
Host: packages.medibuntu.org
Connection: keep-alive
Cache-Control: max-age=0
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp5ubuntu13.2)

HTTP/1.1 404 Not Found
Date: Wed, 25 Apr 2012 09:17:37 GMT
Server: Apa...

Read more...

Andy Bovett (abovett) wrote :

Gauvain Pocentek (gauvainpocentek) wrote on 2012-04-23:
> Andy, does wget still work?

Sorry for the delay in replying. Yes, it does.

In fact, everything seems to be back to normal (at the moment anyway). I've removed the extra entry from my hosts file, removed the port number from the sources.list fileso I'm going through the load balancer, and everything's working on the two PCs I've tried so far (one precise, one oneiric).

Royce King (king-royce) wrote :

I have a fresh install of 12.04 and was getting this error and none of the suggestions worked. When I looked at my sources.list of all the ones that were working precise is spelled with a lower case p. So I changed the Precise to precise and all was well. no more errors.

Gauvain Pocentek (gpocentek) wrote :

Is this problem still occurring for some of you?

I've not add more reports since the 12.04 release, so I think everything works as expected.

Colin Mills (cm006a5077) wrote :

Everything is now working normally. I am able to install the Medibuntu repository without resorting to any of the 'fixes'

Thanks

Ian McMichael (ian-sigma-uk) wrote :

Yes, all fine here without any workarounds for the past few days too. Thanks.

Gauvain Pocentek (gpocentek) wrote :

Thanks for the feedback.

I'm marking the bug as fixed, feel free to reopen if it still happens.

Changed in medibuntu:
status: Confirmed → Fix Released
Johan Lee (leeinglun) wrote :

Help me,
Same problem again here,

W: Failed to fetch http://packages.medibuntu.org/dists/precise/free/i18n/Translation-en_US Unable to connect to packages.medibuntu.org:http:

W: Failed to fetch http://packages.medibuntu.org/dists/precise/free/i18n/Translation-en Unable to connect to packages.medibuntu.org:http:

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/i18n/Translation-en_US Unable to connect to packages.medibuntu.org:http:

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/i18n/Translation-en Unable to connect to packages.medibuntu.org:http:

E: Some index files failed to download. They have been ignored, or old ones used instead.

frankster (wtfrank) wrote :

I'm using squid-deb-proxy and getting this error. I can use wget to download the files listed in the debug output, but just not apt!

packages.medibuntu.org resolves as 88.191.127.22

PING packages.medibuntu.org (88.191.127.22) 56(84) bytes of data.
64 bytes from faraway.pocentek.net (88.191.127.22): icmp_req=1 ttl=45 time=22.4 ms

GET http://packages.medibuntu.org/dists/precise/InRelease HTTP/1.1^M
Host: packages.medibuntu.org^M
Cache-Control: max-age=0^M
Accept: text/*^M
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp12ubuntu10.5)^M
^M

HTTP/1.0 403 Forbidden^M
Server: squid/3.1.19^M
Mime-Version: 1.0^M
Date: Tue, 27 Nov 2012 18:17:35 GMT^M
Content-Type: text/html^M
Content-Length: 3305^M
X-Squid-Error: ERR_ACCESS_DENIED 0^M
Vary: Accept-Language^M
Content-Language: en^M
X-Cache: MISS from squid-deb-proxy^M
X-Cache-Lookup: NONE from squid-deb-proxy:8000^M
Via: 1.0 squid-deb-proxy (squid/3.1.19)^M
Connection: keep-alive^M
^M
GET http://packages.medibuntu.org/dists/precise/Release.gpg HTTP/1.1^M
Host: packages.medibuntu.org^M
Cache-Control: max-age=0^M
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp12ubuntu10.5)^M
^M

HTTP/1.0 403 Forbidden^M
Server: squid/3.1.19^M
Mime-Version: 1.0^M
Date: Tue, 27 Nov 2012 18:17:35 GMT^M
Content-Type: text/html^M
Content-Length: 3285^M
X-Squid-Error: ERR_ACCESS_DENIED 0^M
Vary: Accept-Language^M
Content-Language: en^M
X-Cache: MISS from squid-deb-proxy^M
X-Cache-Lookup: NONE from squid-deb-proxy:8000^M
Via: 1.0 squid-deb-proxy (squid/3.1.19)^M
Connection: keep-alive^M
^M
GET http://packages.medibuntu.org/dists/precise/Release HTTP/1.1^M
Host: packages.medibuntu.org^M
Cache-Control: max-age=0^M
Accept: text/*^M
User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp12ubuntu10.5)^M
^M

frankster (wtfrank) wrote :

So the solution in my case was to add entries for the medibuntu servers to /etc/squid-deb-proxy/mirror-dstdomain.acl.d

Jeff Q (jeffq) wrote :

This still seems to be a problem. I've gotten these errors frequently over the past year, and finally seem to have stopped them by switching to the Costa Rican mirror:

deb http://mirrors.ucr.ac.cr/medibuntu/ precise free non-free

Neither the :8080 port change nor the IP-address substitution above worked for me. The first gave me same "Failed to fetch" errors. The latter I didn't specifically try because browsing:

http://88.191.101.8

by itself didn't get a response. (At least the other URLs could be accessed within a browser, even though they didn't repsond to apt-get's fetches.) Besides, relying on an unchanging IP doesn't seem wise, especially since people will be looking up this info for years to come.

Changing mirrors in /etc/apt/sources.list is an acceptable workaround, but won't help less technical folks. I don't know if I should reopen this bug or create a new one, as I don't yet have the repository-fetch troubleshooting experience to analyze all the moving components discussed above, so I'll just post this here and call for better minds to consider it.

JmAbuDabi (dambldor91) on 2013-10-11
Changed in medibuntu:
assignee: nobody → JmAbuDabi (dambldor91)
assignee: JmAbuDabi (dambldor91) → nobody
Emeric Vigier (emeric-vigier) wrote :

I just switched to ubuntu-12.04 and faced this issue.
Medibuntu has gone down. So 12.04 users should remove associated ppa entries.
https://launchpad.net/medibuntu/+announcement/11951

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers