Move to -staging/remove skype packages

Bug #494564 reported by Lionel Le Folgoc on 2009-12-09
188
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Medibuntu
Fix Released
High
Lionel Le Folgoc
Hardy
Fix Released
High
Lionel Le Folgoc
Intrepid
Fix Released
High
Lionel Le Folgoc
Jaunty
Fix Released
High
Lionel Le Folgoc
Karmic
Fix Released
High
Lionel Le Folgoc
Lucid
Fix Released
High
Lionel Le Folgoc

Bug Description

It is a bit problematic to keep our skype packages, as skype-common conflicts with the package distributed on skype.com, and there's no easy way for us to avoid that (except by merging back skype-common in skype and skype-static, which is a bit painful). After some discussion on irc with a skype dev, I think the best proposition is to stop distributing them, as they are apparently going to provide i386 & amd64 & skype-static packages on skype.com.

For the moment, I'm going to move them to -staging, and after packages are released on skype.com, drop them completely.

===================================
STOP ASKING ABOUT BRINGING SKYPE BACK TO MEDIBUNTU.

Skype is proprietary closed source software so Ubuntu developers can't
modify it and don't have access to its source code.
If you want something changed about Skype then you should ask the
vendor of the Skype application, not Ubuntu.
https://support.skype.com/en/support_selection
If Skype's vendor wants to have its packages in Ubuntu then it is
their responsibility to work on that, not Ubuntu's.
Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.

Please, DO NOT ADD any more comments about bringing Skype back. The decision has been made, period.
Go ask Skype about it.

Lionel Le Folgoc (mrpouit) wrote :

Removed from lucid, moved to -staging for all supported releases.

Lionel Le Folgoc (mrpouit) wrote :

I wrote an announcement for that: https://launchpad.net/medibuntu/+announcement/4539

Arup (arup-chowdhury) wrote :

Please bring it back, it worked nicely with my Microdia camera in Jaunty x64, the version on Skype's site refuses to work with the camera, all I get is green lines and I have tried out all the tricks listed from LD_Preload to editing skype.xml file for resolution.

Elad Tsur (eladts) wrote :

I second the request to bring back the Medibuntu Skype packages. I really don't understand the rational behind removing them, as they are the only Skype packages available from repositories. Their removal will surely confuse a lot of people.

Brian the Lion (rossabri) wrote :

I was pretty happy with Skype being in Medibuntu as well. But I am oblivious to the technical issues at hand and won't complain.

If anybody still wants to install Skype using a package manager (apt et al) while it resides in -staging (not for long), here are some directions you can execute in a terminal to get it done:

Prerequisite: Add the Mediubuntu repo (see https://help.ubuntu.com/community/Medibuntu)
<code>
sudo cp /etc/apt/sources.list.d/medibuntu.list /etc/apt/sources.list.d/medibuntu-staging.list;
sudo nano /etc/apt/sources.list.d/medibuntu-staging.list; # replace all instances of "karmic" with "karmic-staging"
sudo apt-get update;
sudo apt-get install skype;
</code>

These directions should work for any recent Ubuntu release (intrepid, jaunty, karmic, lucid). Just substitute "jaunty" (or whatever) for "karmic" as necessary.

Cheers!
~br

PEIGNOT Kévin (kpeignot) wrote :

I think it shoud still be in medibuntu, because ( on my computer) the same version, install bye depositories or skype paquetage, always works better bye depositories, I don't know why.
More of that, if it begin to have to choose between this type of installations, news users will be lost ( skype by the web, others bye software center... I really think it should be better to have that on medibuntu. More of that it shoud be good, if applications from medibuntu where by defaults in the software center, in a specia category( I saw a free software category appears in lucid few days ago, maybe a 'non-free software' category will appear. And when we choose one of these applications to be installed, a warning message appears to says that medibuntu depository will be activated ( explainiing what it is).
It's just my idea. I think I will propose it in blueprints for M? version ( 10.10) if it's not in Lucid ( 10.04)

Kissounours!!!

Winniemiel

Elad Tsur (eladts) wrote :

I still don't get it what was the problem of keep the Skype Mediubuntu packages. If mantaining them is somewhat difficult, I'm sure that many people, including myself, are willing to help. For the very least, can you keep them at staging so people who want them can still install them?

Removing skype is not a good idea... So many people will be in a really hard situation when they will try to follow every guide on the internet about skype install... (every guide tell you: add medibuntu repo, update, install skype)

And in my opinion medibuntu skype is really good.

So I'm not happy at all.
I hope somebody will turn on the official skype repo

Bye

G Mc.Pherson (diggmc) wrote :

I agree that it's not a good idea to remove Skype from the Medibuntu repositories at least for the moment. The version of available from Skype.com is (currently) old and does not work well with Pulse Audio (on Karmic).

I don't disagree that we should be getting Skype directly from Skype.com, but at least wait until Skype.com is up to date and working before removing them from Medibuntu.

aidanjt (aidanjt) wrote :

Agreed with the sentiments above. Getting people into the windowsesk click monkey routine of visiting a software vendor's site (and potentially misspelling the url) to manually download and install packages creates opportunities to infect users machines with rootkits and all other kinds of nasties. And generally promoting old/stale/insecure software.

If the Skype devs would prefer users getting the software directly from them, the very least they could do is create their own properly maintained software repository. But I'm generally against that idea for the first reason I gave in the previous sentence.

YannUbuntu (yannubuntu) wrote :

hi,
for those like me who need the old packages, see http://packages.medibuntu.org/pool/non-free/s/skype/

Mathias Kende (mathias-kende) wrote :

I agree with the comments above and I don't understand what is the problem with the conflicts between the two version: people will either install skype from skype.com or from medibuntu but there is no reason for them to try both. Meanwhile, having the possibility to do the later is one of the strength of ubuntu and I believe that asking people to go to the vendor website every now and then to check for update is definitely not the ubuntu way.

WaywardGeek (waywardgeek) wrote :

I only use medibuntu for two things: w64codecs and Skype. I guess I'll keep using Medibuntu, but I have a lot less incentive now.

GoofY (goofy-dse) wrote :

I follow most of the people, plz include them again.
As said before, every guide on the net is saying, include medibuntu & your good to go...

Further on, I understand the frustration caused by the way skype is doing their thing...
On the other hand, as said above as well, people should always be able to use the update-manager to update the whole computer & not everything but skype ( & ... & ...) because that's what gonna happen in the end I'm afraid...

just my 2 cents

Thiago Bellini (hackedbellini) wrote :

Ahhhhhhhhh

put it back!!!

lopho (lopho) wrote :

i must throw in my voice as well!

please put the skype packages back in medibuntu, they were one of the main reason for me and my girlfriend to use medibuntu at all.

please reconsider.

HITMAn (hitmansoft) wrote :

I agree with comments above, in that:
1. installing a package from a repository and then having automatic updates and installed dependencies is more convenient than browsing vendor sites hoping for the updated package.

2. the conflict between repository and official packages is _not_ a major reason to discontinue a repository. We may just put a notice alerting that the official packages are not compatible with medibuntu repository. I've never had problems with that... maybe just renaming the repository packages does help?

My honest opinion is that Skype should remain in the repository until Skype guys provide a repository themselves... having just separate packages does not speak well with Ubuntu style of package management.

scorp123 (scorp123) wrote :

Please put it back!!

So the files conflict ... and so what??! If I install Skype from the Medibuntu repos then this will be the only Skype version that I will ever install. So the conflict between official Skype vs. Medibuntu's Skype doesn't really matter one little bit.

Please put it back!!

Herczeg Zsolt (zsolt94) wrote :

Please put it back!
The medibuntu version of skype always worked better than skype official packages!

Thomas (teoverton) wrote :

Skype from skype is not functioning for me either...I would like to add my voice to the chorus....PLEASE GET SKYPE BACK IN THE REPOSITORY...

Mark Cariaga (mzc) wrote :

To be more constructive in finding a solution to this bug both groups - Skype and Ubuntu developers should work out something that will make consumers/average users satisfied. (1) Skype is a "free-to-install" multiplatform software, many people use skype's commercial service on a regular basis and has been successful in GNU/Linux and other OS. (2) Ubuntu is the most popular GNU/Linux distro of all time. Hence, which came out first the chicken or the egg???? having this kind of issue affects the preference of users either change to another Call service or change to a different OS. Both skype and Ubuntu benefit from having a skype package repository (via medibuntu or not). Since skype is a commercial software, Canonical should step up in supporting it and should be the medium to support commercial software in ubuntu through agreements between commercial software developers. Although the foundations of ubuntu is purely on free software, the norm for the average user is using both free/open source and commercial/closed source software in their everday computing needs. I think most users will gladly add a package repository that offers skype and other closed source/commercial software.

Camilio (camille-gonnet-free) wrote :

Please put it back !
There are many reasons to go to linux, and the repository system is a good one for me, even for commercial softwares !

Elad Tsur (eladts) wrote :

There is a new version of Skype (2.1.0.81) at skype.com. Please, please, please package it for Medibuntu. That's what everyone who commented on the subject wants, so why insist on not doing anymore?

Elad Tsur (eladts) wrote :

Also, skype.com provides the same packages it always provided. There are no static packages, nor a usable repository. That makes the rational for removing Skype from Medibuntu irrelevant.

Elad Tsur (eladts) wrote :

The removal of Skype from Medibuntu did not fix anything, just added confusion to new users. Furthermore, there are no static or lpia packages of Skype on skype.com even after the release of version 2.1.0.81, so the whole rational behind removing these packages is invalid.

Lionel Le Folgoc (mrpouit) wrote :

Bug #511054 has already 3 duplicates, which prove that people are installing the debs from skype.com. Then our debs don't seem to be really needed. Obviously, they weren't able to do a proper package, although we reported to them some issues. So I don't care anymore, I don't intend to put back skype into Medibuntu, it's the problem of skype developers/packagers now.

Does this mean there's a rift between skype and ubuntu developers? How
is skype different from adobe reader? My point is skype needs to works
flawlessy. By definition, this is the purpose of medibuntu. Please
correct me I'm wrong.

On Jan 22, 2010, at 12:52 PM, Lionel Le Folgoc <email address hidden>
wrote:

> Bug #511054 has already 3 duplicates, which prove that people are
> installing the debs from skype.com. Then our debs don't seem to be
> really needed. Obviously, they weren't able to do a proper package,
> although we reported to them some issues. So I don't care anymore, I
> don't intend to put back skype into Medibuntu, it's the problem of
> skype
> developers/packagers now.
>
> ** Changed in: medibuntu/lucid
> Status: Confirmed => Fix Released
>
> ** Changed in: medibuntu/karmic
> Status: Confirmed => Fix Committed
>
> ** Changed in: medibuntu/jaunty
> Status: Confirmed => Fix Committed
>
> ** Changed in: medibuntu/intrepid
> Status: Confirmed => Fix Committed
>
> ** Changed in: medibuntu/hardy
> Status: Confirmed => Fix Committed
>
> --
> Move to -staging/remove skype packages
> https://bugs.launchpad.net/bugs/494564
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Medibuntu: Fix Released
> Status in Medibuntu hardy series: Fix Committed
> Status in Medibuntu intrepid series: Fix Committed
> Status in Medibuntu jaunty series: Fix Committed
> Status in Medibuntu karmic series: Fix Committed
> Status in Medibuntu lucid series: Fix Released
>
> Bug description:
> It is a bit problematic to keep our skype packages, as skype-common
> conflicts with the package distributed on skype.com, and there's no
> easy way for us to avoid that (except by merging back skype-common
> in skype and skype-static, which is a bit painful). After some
> discussion on irc with a skype dev, I think the best proposition is
> to stop distributing them, as they are apparently going to provide
> i386 & amd64 & skype-static packages on skype.com.
>
> For the moment, I'm going to move them to -staging, and after
> packages are released on skype.com, drop them completely.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/medibuntu/+bug/494564/+subscribe

Lionel Le Folgoc (mrpouit) wrote :

Ubuntu developers mostly don't care of Skype ; some Canonical employees probably (the ones that maintain Canonical's partner repository). I don't know why Skype isn't in Canonical's partner repository, you should ask them.

Mark Cariaga (mzc) wrote :

Thanks for clearing up the responsibilities and roles of canonical and
ubuntu developers. It has changed my perception of medibuntu. But the
problem is still not solved, it makes sense that commercial free
software like skype should be in canonical's repository(with
cooperation/approval of skype). Having that said canonical should make
more effort in making this happen. The point is skype has at least
10million users, and it has always been a feature in several other gnu/
linux distros. At least give ubuntu users the choice to install such
software in the most convenient way.

On Jan 22, 2010, at 1:39 PM, Lionel Le Folgoc <email address hidden>
wrote:

> Ubuntu developers mostly don't care of Skype ; some Canonical
> employees
> probably (the ones that maintain Canonical's partner repository). I
> don't know why Skype isn't in Canonical's partner repository, you
> should
> ask them.
>
> --
> Move to -staging/remove skype packages
> https://bugs.launchpad.net/bugs/494564
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Medibuntu: Fix Released
> Status in Medibuntu hardy series: Fix Released
> Status in Medibuntu intrepid series: Fix Released
> Status in Medibuntu jaunty series: Fix Released
> Status in Medibuntu karmic series: Fix Released
> Status in Medibuntu lucid series: Fix Released
>
> Bug description:
> It is a bit problematic to keep our skype packages, as skype-common
> conflicts with the package distributed on skype.com, and there's no
> easy way for us to avoid that (except by merging back skype-common
> in skype and skype-static, which is a bit painful). After some
> discussion on irc with a skype dev, I think the best proposition is
> to stop distributing them, as they are apparently going to provide
> i386 & amd64 & skype-static packages on skype.com.
>
> For the moment, I'm going to move them to -staging, and after
> packages are released on skype.com, drop them completely.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/medibuntu/+bug/494564/+subscribe

Przemek K. (azrael) wrote :

Skype is proprietary closed source software so Ubuntu developers can't
modify it and don't have access to its source code.
If you want something changed about Skype then you should ask the
vendor of the Skype application, not Ubuntu.
https://support.skype.com/en/support_selection
If Skype's vendor wants to have its packages in Ubuntu then it is
their responsibility to work on that, not Ubuntu's.
Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.

On 22 January 2010 23:30, mzc <email address hidden> wrote:
> Thanks for clearing up the responsibilities and roles of canonical and
> ubuntu developers.  It has changed my perception of medibuntu. But the
> problem is still not solved, it makes sense that commercial free
> software like skype should be in canonical's repository(with
> cooperation/approval of skype). Having that said canonical should make
> more effort in making this happen. The point is skype has at least
> 10million users, and it has always been a feature in several other gnu/
> linux distros. At least give ubuntu users the choice to install such
> software in the most convenient way.

--
## Przemysław Kulczycki <<=>> Azrael Nightwalker ##
# Jabber/XMPP/Gtalk/Tlen ID: azrael[na]jabster.pl #
# (Co to jest? Zobacz na: http://jabberfaq.info ) #
## www: http://reksio.ftj.agh.edu.pl/~azrael/ #####

Mark Cariaga (mzc) wrote :

Thanks Przemysław. I guess you're right. if skype does want to consider
ubuntu as a potential market, they should bring expand support, such as
providing an ubuntu package like adobe or hosting a repository.They
should also initiate effort in doing so.

Ubuntu users should lobby this to skype developers and not put full
responsibility to ubuntu or medibuntu.

This bug should be closed as it is not releated to development in ubuntu
or medibuntu. The solution is all skype users should request skype
developers to host a repository so that an automatic update feature is
available. I guess this is the only difference anyway....

On Sat, 2010-01-23 at 12:03 +0000, Przemysław Kulczycki wrote:
> Skype is proprietary closed source software so Ubuntu developers can't
> modify it and don't have access to its source code.
> If you want something changed about Skype then you should ask the
> vendor of the Skype application, not Ubuntu.
> https://support.skype.com/en/support_selection
> If Skype's vendor wants to have its packages in Ubuntu then it is
> their responsibility to work on that, not Ubuntu's.
> Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.
>
> On 22 January 2010 23:30, mzc <email address hidden> wrote:
> > Thanks for clearing up the responsibilities and roles of canonical and
> > ubuntu developers. It has changed my perception of medibuntu. But the
> > problem is still not solved, it makes sense that commercial free
> > software like skype should be in canonical's repository(with
> > cooperation/approval of skype). Having that said canonical should make
> > more effort in making this happen. The point is skype has at least
> > 10million users, and it has always been a feature in several other gnu/
> > linux distros. At least give ubuntu users the choice to install such
> > software in the most convenient way.
>
> --
> ## Przemysław Kulczycki <<=>> Azrael Nightwalker ##
> # Jabber/XMPP/Gtalk/Tlen ID: azrael[na]jabster.pl #
> # (Co to jest? Zobacz na: http://jabberfaq.info ) #
> ## www: http://reksio.ftj.agh.edu.pl/~azrael/ #####
>

Elad Tsur (eladts) wrote :

Actually there is a Debian repository for Skype at skype.com, which seems to work for Ubuntu too and installs the latest version.

However, it has few drawbacks:

1. It is only for i386.
2. It is not authenticated.

To use the skype.com repository you need first to remove Medibuntu's skype and skype-common packages, and then run the following commands from the shell:

echo deb http://download.skype.com/linux/repos/debian/ stable non-free >/tmp/skype.list
sudo cp /tmp/skype.list /etc/apt/sources.list.d
sudo apt-get update
sudo apt-get install skype

You need to answer 'y' when it asks you if you want to install non-authinticated package.

Zoran Nikin (nikinzoran) wrote :

Please give us back skype. We, your clients do not care about who is guilty or whose responsibility is or... We want a useful computer, with many functions including skype.

Nils Marving (marvingnils) wrote :

Please re-add Skype to medibuntu, the huge advantage for a lot of people of having Skype in a repo far far outweighs the small disadvantage of having to mark 3 bugs from people with something to learn as dups.

If numbers are important, there are much more than 3 comments regarding re-add in this thread ;)

Przemek K. (azrael) on 2010-02-02
description: updated
description: updated
Nils Marving (marvingnils) wrote :
Download full text (4.8 KiB)

It seems that you are in a much better position to ask Skype about creating
a repo, than some random user and his family...

Nils
--
The early bird gets the coffee left over from the night before

2010/2/2 Przemysław Kulczycki <email address hidden>

> ** Description changed:
>
> It is a bit problematic to keep our skype packages, as skype-common
> conflicts with the package distributed on skype.com, and there's no easy
> way for us to avoid that (except by merging back skype-common in skype
> and skype-static, which is a bit painful). After some discussion on irc
> with a skype dev, I think the best proposition is to stop distributing
> them, as they are apparently going to provide i386 & amd64 & skype-
> static packages on skype.com.
>
> For the moment, I'm going to move them to -staging, and after packages
> are released on skype.com, drop them completely.
> +
> + ===================================
> + STOP ASKING ABOUT BRINGING SKYPE BACK TO UBUNTU.
> +
> + Skype is proprietary closed source software so Ubuntu developers can't
> + modify it and don't have access to its source code.
> + If you want something changed about Skype then you should ask the
> + vendor of the Skype application, not Ubuntu.
> + https://support.skype.com/en/support_selection
> + If Skype's vendor wants to have its packages in Ubuntu then it is
> + their responsibility to work on that, not Ubuntu's.
> + Blaming Ubuntu or Medibuntu about not including Skype is just plain
> wrong.
> +
> + Please, DO NOT ADD any more comments about bringing Skype back. The
> decision has been made, period.
> + Go ask Skype about it.
>
> ** Description changed:
>
> It is a bit problematic to keep our skype packages, as skype-common
> conflicts with the package distributed on skype.com, and there's no easy
> way for us to avoid that (except by merging back skype-common in skype
> and skype-static, which is a bit painful). After some discussion on irc
> with a skype dev, I think the best proposition is to stop distributing
> them, as they are apparently going to provide i386 & amd64 & skype-
> static packages on skype.com.
>
> For the moment, I'm going to move them to -staging, and after packages
> are released on skype.com, drop them completely.
>
> ===================================
> - STOP ASKING ABOUT BRINGING SKYPE BACK TO UBUNTU.
> + STOP ASKING ABOUT BRINGING SKYPE BACK TO MEDIBUNTU.
>
> Skype is proprietary closed source software so Ubuntu developers can't
> modify it and don't have access to its source code.
> If you want something changed about Skype then you should ask the
> vendor of the Skype application, not Ubuntu.
> https://support.skype.com/en/support_selection
> If Skype's vendor wants to have its packages in Ubuntu then it is
> their responsibility to work on that, not Ubuntu's.
> Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.
>
> Please, DO NOT ADD any more comments about bringing Skype back. The
> decision has been made, period.
> Go ask Skype about it.
>
> --
> Move to -staging/remove skype packages
> https://bugs.launchpad.net/bugs/494564
> You received this bug notification because you are a direct...

Read more...

Nils Marving (marvingnils) wrote :

Seems we have to do it ourselves *sigh*. Anyway, thank you medibuntu guys, for having done the work for a while, I'm sorry you stopped...

David N. Welton (davidnwelton) wrote :

Maybe it's time to do skybuntu.org ... ?

Scott Robbins (scottro11) wrote :

Sigh. As was said, people don't care whose fault it is. This just adds to Ubuntu bug number one. Linux (and Ubuntu) need Skype far more than Skype needs Ubuntu.

"Use Ubuntu".
"Sure, can it run it my applications?"
"Of course."
"What about Skype, I need it for work and personal use?"
"Oh, well, you see the Skype developers make it proprietary and..."
"Wait a minute. I really don't care. Does Skype work or not?"
"Well, um, you see, you can install it, but..."
"Later. Sorry, I know you're into computers and free software and all that stuff, but some of us need our computers for work."

Nicely done. If Ubuntu is a distribution aimed at hobbyists, it's fine. If it's supposed to be a viable alternative to MS and Apple, then this was an extremely poor decision.

Mark Cariaga (mzc) wrote :

it's a bit double standard because canonical also hosts adobe reader
which is not entirely free. I hope that with the changes canonical is
shaping the software center, skype and other free to install/use -
proprietary software will be hosted.

On Sun, 2010-03-14 at 01:35 +0000, Scott Robibns wrote:
> Sigh. As was said, people don't care whose fault it is. This just adds
> to Ubuntu bug number one. Linux (and Ubuntu) need Skype far more than
> Skype needs Ubuntu.
>
> "Use Ubuntu".
> "Sure, can it run it my applications?"
> "Of course."
> "What about Skype, I need it for work and personal use?"
> "Oh, well, you see the Skype developers make it proprietary and..."
> "Wait a minute. I really don't care. Does Skype work or not?"
> "Well, um, you see, you can install it, but..."
> "Later. Sorry, I know you're into computers and free software and all that stuff, but some of us need our computers for work."
>
> Nicely done. If Ubuntu is a distribution aimed at hobbyists, it's
> fine. If it's supposed to be a viable alternative to MS and Apple, then
> this was an extremely poor decision.
>

aidanjt (aidanjt) wrote :

> It is a bit problematic to keep our skype packages, as skype-common conflicts with the package distributed on skype.com.
How is this a problem? Why would someone add medibuntu, then install skype from the medibuntu repo, then download and install skype from the skype website?

> and there's no easy way for us to avoid that (except by merging back skype-common in skype and skype-static, which is a bit painful). After some discussion on irc with a skype dev, I think the best proposition is to stop distributing them, as they are apparently going to provide i386 & amd64 & skype-static packages on skype.com.
I have crazy notion, why not get the skype devs to use /opt like they're suppose to? Conflict resolved, and sane people get to have a maintained software installation, and less mess on their vfs.

> STOP ASKING ABOUT BRINGING SKYPE BACK TO MEDIBUNTU.
Why? Practically everyone wants it back.

> Skype is proprietary closed source software so Ubuntu developers can't
> modify it and don't have access to its source code.
> If you want something changed about Skype then you should ask the
> vendor of the Skype application, not Ubuntu.
> https://support.skype.com/en/support_selection
> If Skype's vendor wants to have its packages in Ubuntu then it is
> their responsibility to work on that, not Ubuntu's.
> Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.
Oh, well, in that case, you better remove the following closed source packages as well:
alsa-firmware
gizmo5? (seems to have been eaten by google anyway)
googleearth-data
googleearth
realplayer
w32codecs
w64codecs

Oh wait, there goes the entire point of medibuntu. :roll:

> Please, DO NOT ADD any more comments about bringing Skype back. The decision has been made, period.
The decision was in error.

Lionel Le Folgoc (mrpouit) wrote :

> How is this a problem? Why would someone add medibuntu, then install skype
> from the medibuntu repo, then download and install skype from the skype
> website?

I agree. Why on earth would they do that? But users are always surprising: the majority of bug reports we had for skype were about such issues...

>> STOP ASKING ABOUT BRINGING SKYPE BACK TO MEDIBUNTU.
> Why? Practically everyone wants it back.

*You* want it back, not *everyone*. Skype has never been the most downloaded package on Medibuntu, many people were downloading it directly from the official website.

> [...]
> Oh wait, there goes the entire point of medibuntu. :roll:

Or not. You're forgetting the 'free' component of the repository. Libdvdcss2 is probably the most installed package from Medibuntu.

> The decision was in error.

You're free to think that.

Dear Lionel I don't agree with removing skype from medubuntu repo, but the repo is not mine and "vox admin vox dei".

I don't want to complain anymore, the decision is made. period.

Only a little question.

Could you tell me a repository when I can install skype from apt or synaptic without download it from skype.com and install by double-clicking on it?
Now I have skype installed from this way, but I should periodically go to the skype.com website to look for updates...

I could see there is a debian repository that works with ubuntu too, but (if I am *not* wrong) it works only for x32 skype and not for the amd64 version...

aidanjt (aidanjt) wrote :

> the majority of bug reports we had for skype were about such issues...
As I already pointed out, the proper solution would be to point upstream towards using /opt, as they should have done in the first place. Instead you brushed the problem under the carpet, and now nobody will have maintained software. Good going.

If you couldn't be bothered maintaining a package, you should have thrown out a feeler for someone else to take up the mantle, instead of dishing out an 'I don't like this, so tough luck' bug.

> *You* want it back, not *everyone*. Skype has never been the most downloaded package on Medibuntu, many people were downloading it directly from the official website.
I'm sorry, let me clarify my statement. The overwhelming majority of posts on this bug is comments from people who want Skype back in Medibuntu. Nor is 'many people' exactly a definitive breakdown of Skype distribution.

> Or not. You're forgetting the 'free' component of the repository. Libdvdcss2 is probably the most installed package from Medibuntu.
I thought Medibuntu stood for "Multimedia, Entertainment & Distractions In Ubuntu". At what point did it become 'Multimedia In Ubuntu'? Besides, there's already a script for installing libdvdcss in libdvdread, so if Medibuntu only exists for libdvdcss (a ridiculously tiny binary), then it's useless. Again, 'probably the most installed' isn't a definitive figure of anything.

Mark Cariaga (mzc) wrote :

Sounds like a bug#1 regression to me:(

On Apr 22, 2010 5:56 AM, "aidanjt" <email address hidden> wrote:

> the majority of bug reports we had for skype were about such issues...
As I already pointed out, the proper solution would be to point upstream
towards using /opt, as they should have done in the first place. Instead
you brushed the problem under the carpet, and now nobody will have
maintained software. Good going.

If you couldn't be bothered maintaining a package, you should have
thrown out a feeler for someone else to take up the mantle, instead of
dishing out an 'I don't like this, so tough luck' bug.

> *You* want it back, not *everyone*. Skype has never been the most
downloaded package on Medibuntu...
I'm sorry, let me clarify my statement. The overwhelming majority of posts
on this bug is comments from people who want Skype back in Medibuntu. Nor
is 'many people' exactly a definitive breakdown of Skype distribution.

> Or not. You're forgetting the 'free' component of the repository.
Libdvdcss2 is probably the most...
I thought Medibuntu stood for "Multimedia, Entertainment & Distractions In
Ubuntu". At what point did it become 'Multimedia In Ubuntu'? Besides,
there's already a script for installing libdvdcss in libdvdread, so if
Medibuntu only exists for libdvdcss (a ridiculously tiny binary), then it's
useless. Again, 'probably the most installed' isn't a definitive figure of
anything.

--
Move to -staging/remove skype packages
https://bugs.launchpad.net/bugs/494564
You received this...

Lionel Le Folgoc (mrpouit) wrote :

@LocutusOfBorg:

Not that I am aware of.

@aidanjt

> Instead you brushed the problem under the carpet, and now nobody will
> have maintained software. Good going.

I asked them to add a conflict with our skype-common package, to avoid the common bug explained above. They never added it...

> If you couldn't be bothered maintaining a package, you should
> have thrown out a feeler for someone else to take up the mantle,
> instead of dishing out an 'I don't like this, so tough luck' bug.

Anyone can recreate a skype package, file a bug report and propose it for inclusion. But the usual behavior (even in Ubuntu) is rather: "a person works for its inclusion and then vanishes". That's why I'm more inclined to drop this kind of packages.

Since nobody proposed for four months (it was removed in december), I think that everyone is happy with the package on the official website (or whatever package one can find).

> I thought Medibuntu stood for "Multimedia, Entertainment & Distractions In
> Ubuntu".

Well, actually, Medibuntu was "invented" first, and then we thought it could be great if it were an acronym, and we tried to find a word matching each letter (I'm not actually very proud of the result :p).

> [...] there's already a script for installing libdvdcss in libdvdread

It downloads the package from our repository. If it fails, it downloads the source code and builds the library.

@mzc

> Sounds like a bug#1 regression to me:(

You should ask Canonical to include Skype in the "partner" repository. This is what happened for Adobe Reader, and we removed it from Medibuntu, and everyone is happy now.

Mark Cariaga (mzc) wrote :

@lionel
True. We have talked about this in the past posts. But actually skype can
also do a better job on this just like what Google did for the chrome
browser(not chromium)

On Apr 22, 2010 8:15 AM, "Lionel Le Folgoc" <email address hidden> wrote:

@LocutusOfBorg:

Not that I am aware of.

@aidanjt

> Instead you brushed the problem under the carpet, and now nobody will
> have maintained software....
I asked them to add a conflict with our skype-common package, to avoid
the common bug explained above. They never added it...

> If you couldn't be bothered maintaining a package, you should
> have thrown out a feeler for some...
Anyone can recreate a skype package, file a bug report and propose it
for inclusion. But the usual behavior (even in Ubuntu) is rather: "a
person works for its inclusion and then vanishes". That's why I'm more
inclined to drop this kind of packages.

Since nobody proposed for four months (it was removed in december), I
think that everyone is happy with the package on the official website
(or whatever package one can find).

> I thought Medibuntu stood for "Multimedia, Entertainment & Distractions In
> Ubuntu".
Well, actually, Medibuntu was "invented" first, and then we thought it
could be great if it were an acronym, and we tried to find a word
matching each letter (I'm not actually very proud of the result :p).

> [...] there's already a script for installing libdvdcss in libdvdread

It downloads the package from our repository. If it fails, it downloads
the source code and builds the library.

@mzc

> Sounds like a bug#1 regression to me:(
You should ask Canonical to include Skype in the "partner" repository.
This is what happened for Adobe Reader, and we removed it from
Medibuntu, and everyone is happy now.

--
Move to -staging/remove skype packages
https://bugs.launchpad.net/bugs/494564

You received this bug notification because you are a direct subscriber
of the bug.

Status in Medibu...

"Since nobody proposed for four months (it was removed in december), I think that everyone is happy with the package on the official website (or whatever package one can find)."

I only noticed now, because my skype stopped working, and discovered to my surprise that it was no longer on Medibuntu. When I first tried Ubuntu some years back, I was used the windoze download wizard and press next multiple times, so tried that at first. Of course it takes time to get people used to the new way of doing things. But IMO this is a retrograde step.

I understand that the decision was made for reasons that must be very valid, although I don't pretend to understand them. And that medibuntu is autonomous. But it seems to me, that it would be helpful to at least give people an alternative?

In any event, the "four months" argument is not valid - in my case (and I would bet many other cases), the user does not keep up with what is and is not in the repository. Especially if the application is working.

To my untrained eye, the arguments of aidanjt (eg post #44) make more sense. Perhaps you'd be willing to share your reasoning in a way that non-specialists can comprehend, in the spirit of linux for human beings, and even the spirit of ubuntu!

BTW, I did try to convert my family to open-source voice over IP about a year ago, but I couldn't even get it working between two Ubuntu computers that I own, so I didn't dare take it further. I suppose it's improved since then, but for a non-geek who has a full time job, I really gave it a bona fide attempt.

Panayiotis Karabassis (panayk) wrote :

Sorry because I did not read all of the posts above. I would just like to add that although I am not an Ubuntu user (I run Debian Squeeze) I had video problems with the official package that don't affect the Medibuntu package. Video works PERFECTLY. So you must be doing something right. Please consider continuing to maintain this package and thank you for your work.

Wolfgang (wt-lists) wrote :

Skype is now part of the official Ubuntu "partner" repository!

To install skype in 10.04 add the following line in /etc/apt/sources.list
deb http://archive.canonical.com/ubuntu lucid partner

then do:
sudo aptitude update && sudo aptitude install skype

Mark Cariaga (mzc) wrote :

That's great news, now it's time to close this bug and move on...lol

On May 24, 2010 11:51 AM, "Wolfgang" <email address hidden> wrote:

Skype is now part of the official Ubuntu "partner" repository!

To install skype in 10.04 add the following line in /etc/apt/sources.list
deb http://archive.canonical.com/ubuntu lucid partner

then do:
sudo aptitude update && sudo aptitude install skype

--
Move to -staging/remove skype packages
https://bugs.launchpad.net/bugs/494564
You received this bug notification because you are a direct subscriber
of the bug.

Status in Medibuntu: Fix Released
Status in Medibuntu hardy series: Fix Released
Status in Medibuntu intrepid series: Fix Released
Status in Medibuntu jaunty series: Fix Released
Status in Medibuntu karmic series: Fix Released
Status in Medibuntu lucid series: Fix Released

Bug description:
It is a bit problematic to keep our skype packages, as skype-common
conflicts with the package distributed on skype.com, and there's no easy way
for us to avoid that (except by merging back skype-common in skype and
skype-static, which is a bit painful). After some discussion on irc with a
skype dev, I think the best proposition is to stop distributing them, as
they are apparently going to provide i386 & amd64 & skype-static packages on
skype.com.

For the moment, I'm going to move them to -staging, and after packages are
released on skype.com, drop them completely.

===================================
STOP ASKING ABOUT BRINGING SKYPE BACK TO MEDIBUNTU.

Skype is proprietary closed source software so Ubuntu developers can't
modify it and don't have access to its source code.
If you want something changed about Skype then you should ask the
vendor of the Skype application, not Ubuntu.
https://support.skype.com/en/support_selection
If Skype's vendor wants to have its packages in Ubuntu then it is
their responsibility to work on that, not Ubuntu's.
Blaming Ubuntu or Medibuntu about not including Skype is just plain wrong.

Please, DO NOT ADD any more comments about bringing Skype back. The decision
has been made, period.
Go ask Skype about it.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/medibuntu/+bug/494564/+subscribe

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions