googleearth 5 displays placemarks at wrong position

Bug #402787 reported by Roland Hieber on 2009-07-21
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Medibuntu
Fix Released
Low
Lionel Le Folgoc
Jaunty
Won't Fix
Low
Unassigned
Karmic
Fix Released
Low
Unassigned
Lucid
Fix Released
Low
Lionel Le Folgoc

Bug Description

After an update from 4.x to googleearth-5.0.11337.1968-0medibuntu10, my placemarks are displayed at the wrong positions. If I double-click on the placemark in the "My Places" tab, Google Earth jumps at the right position of the placemark, but the yellow pin is shown at a different point whose coordinates are only the degree part of the coordinates of the placemark -- the minute and second part of the placemark's coordinate are ignored. This wrong coordinate is also displayed in the "Properties" dialogue of the placemark.

I found out that Google Earth writes bogus coordinates to myplaces.kml (it uses commas instead of points for decimal separators) when the locale is set to de_DE.UTF8, which is the case for me.

I found a workaround on the Google Earth issue tracker [1], which suggests to use LC_NUMERIC=en_US.UTF8. Maybe the startup script or the application starter could be changed accordingly.

[1] http://code.google.com/p/earth-issues/issues/detail?id=330&q=locale&colspec=ID%20Type%20Summary%20Status%20Owner%20Stars

I can confirm this bug. In my case all gpx files I try to import have bogus coordinates.

My default locale (LC_NUMERIC) setting is nl_NL.UTF-8
When I manually set this in a terminal to 'en_US.UTF-8' and use that to start googleearth it works good.

Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report.
I'll try to add the workaround in the next package upload;

VPablo (villumar) wrote :

Is this workarond applied to the last package?

VPablo (villumar) wrote :

Also affects 5.1.3509.4636 (beta) on Karmic.

Jarl (jarl-dk) wrote :

There is a fix/patch for this problem in bug 485730

Jarl

Jarl (jarl-dk) wrote :

I add the patch here.

Jarl (jarl-dk) wrote :

The patch is against the latest package therefore I consider the bug complete. I highly encourage you to triage this bug, and release a fix.

VPablo (villumar) wrote :

The patch works for me (said in the other bug).

Jarl (jarl-dk) on 2009-11-26
Changed in medibuntu:
status: Incomplete → New
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

New upstream release of googleearth available in karmic-staging. I added the patch in it.

Roland Hieber (rohieb) wrote :

Since updating to 5.1.3509.4636-0medibuntu1, the fix with LC_NUMERIC not longer works, I have to explicitly set LC_ALL to some english locale (for example en_GB.UTF-8). Someone other with this behaviour, or am I the only one?

VPablo (villumar) wrote :

I have no problem with 4636 version from medibuntu.

clauder357 (clauder357-gmail) wrote :

errr for the rest of us .... if there is still a problem, what should we do ? Is there a way to get the fix somewhere?

Jarl (jarl-dk) wrote :

@clauder357: Are you sure it does not work. Note that the patch/update will not fix your destroyed placemarks (they will be lost forever), but the fix should ensure that new placemarks are not destroyed after closing GE and starting it up again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers