reordering channels doesn't work

Bug #769574 reported by lianergoist
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Me TV
Medium
Christian

Bug Description

The Channel editor doesn't change the order of channels. Using drag and drop seems to work, but changes are not applied after clicking the OK button.

Me-tv 2.0.1
Ubuntu 11.04
Compiled from source without errors.

Related branches

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Yeah, I seemed to have missed that feature in the migration to 2.0. At the moment you can get around it by ordering your channels.conf file before the import.

Changed in me-tv:
assignee: nobody → Michael Lamothe (lamothe)
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Frédéric Côté (frederic-cote) wrote :

I have restart the development of me-tv with the version 1.4 (from the code base of 2.0.1) and I found out why it isn't working.

I'll fix that soon (before next year :))

no longer affects: me-tv/2.0
Changed in me-tv:
importance: Low → Medium
Revision history for this message
Thomas Raschbacher (lordvan-lordvan) wrote :

I really need this feature ;)

You said you found the problem. Can i help?

Revision history for this message
Frédéric Côté (frederic-cote) wrote : Re: [Bug 769574] Re: reordering channels doesn't work

Hi Thomas,

Basically, me-tv server talk with me-tv client thru XML. When the client
send the new channels.list it forgot about the channels ordering. The work
needed to be done is to add a string for the channel ordering when the
client send the channels.list to the server and the server must read this
string and populate the DB accordingly.

I hope I explain it well enough. I'll try to find time to send you more
specific stuff.

Cheers,
Frederic

On Sun, Oct 21, 2012 at 11:54 AM, Thomas Raschbacher <
<email address hidden>> wrote:

> I really need this feature ;)
>
> You said you found the problem. Can i help?
>
> --
> You received this bug notification because you are subscribed to Me TV.
> https://bugs.launchpad.net/bugs/769574
>
> Title:
> reordering channels doesn't work
>
> Status in Me TV, it's TV for me computer:
> In Progress
>
> Bug description:
> The Channel editor doesn't change the order of channels. Using drag
> and drop seems to work, but changes are not applied after clicking the
> OK button.
>
> Me-tv 2.0.1
> Ubuntu 11.04
> Compiled from source without errors.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/me-tv/+bug/769574/+subscriptions
>

--
"In a world without walls, who really needs Windows"
"Nothing is foolproof because fools are so ingenious"

Revision history for this message
Binnette (binnette) wrote :

I'm looking in source 1.4 and I found the problem. In file request_handler.cc, function RequestHandler::handle_connection
There is no code for request "set_channel_order"

line 263 :
  else if (command == "set_channel_order")
  {

  }

I gonna look in previous versions if this feature was already implemented.

Revision history for this message
Russel Winder (russel) wrote :

Did you ever find the resolution for this, or is it still an open issue?

Revision history for this message
Frédéric Côté (frederic-cote) wrote :

On v1.3 it work OK but the code is missing for v1.4. If you look at the
code that produce the XML between the client and the server, you will see
the blank fonction.
On Mar 5, 2014 2:25 PM, "Russel Winder" <email address hidden> wrote:

> Did you ever find the resolution for this, or is it still an open issue?
>
> --
> You received this bug notification because you are subscribed to Me TV.
> https://bugs.launchpad.net/bugs/769574
>
> Title:
> reordering channels doesn't work
>
> Status in Me TV, it's TV for me computer:
> In Progress
>
> Bug description:
> The Channel editor doesn't change the order of channels. Using drag
> and drop seems to work, but changes are not applied after clicking the
> OK button.
>
> Me-tv 2.0.1
> Ubuntu 11.04
> Compiled from source without errors.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/me-tv/+bug/769574/+subscriptions
>

Revision history for this message
mark bower (mjbower) wrote :

I am going to start my posts here, and someone can redirect me if appropriate. Not a bug report, but how to get MeTv working.

Using Ubuntu 12.04, I have tried many ways to install Me-Tv and get it to consistently work on my HP g6 laptop. I did get it to work once(not sure of the ver but maybe 1.3.6, so I know it will work on the laptop. But things went amiss and I have not been successful since trying many different versions.

So for starters, what specifically is the latest .deb version I should be using and where do I download it from. I will clean me-tv entries, install the deb, then return for help as needed. I like the simplicity of MeTv and do not want to have to mess with MythTV.

[I obtained me-tv_1.4.0-0~49~precise(from somewhere) and have it currently installed. It will not autoscan and only goes to Scan Wizard(Import a channels.conf option only)in foreground and Channels Editor locates behind it. ]

Christian (chk2k2)
Changed in me-tv:
assignee: nobody → Christian (chk2k2)
status: In Progress → Fix Committed
Christian (chk2k2)
Changed in me-tv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers