Switching audio stream (Arte channel) stops sound output

Bug #506855 reported by Mahendra Tallur
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Me TV
Fix Released
High
Unassigned

Bug Description

Hi !

He's a bug that occurs each time on my setup (Ubuntu 9.10 karmic, i386 and amd64), with the Arte channel (French / German channel)

When selecting the 2nd audio stream, the sound output ceases to work. When switching back to the 1st audio stream, the sound output doesn't resume : I actually have to quit / relaunch me-tv.

I checked with VLC, and both audio streams do work.

Please tell me whether I may help by providing debug logs, etc :-)
Thanks for reading this !

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

What version of Me TV are you using? Me TV 1.0.0?

Can you please try it in xine? The verbose logs might help.

Changed in me-tv:
status: New → Incomplete
Revision history for this message
Mahendra Tallur (mahen) wrote :

The behaviour in xine is a little different : the 2nd audio stream doesn't work (no sound), as in me-tv (and contrary to vlc).
But when switching back to the 1st audio stream resumes the sound output (contrary to me-tv).

Here's the verbose output :
http://pastebin.com/m3c27414f

Thanks for your reply,
cheers !

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Something that doesn't make sense is that verbose output says that there's only 1 audio stream. Am I seeing that right?

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Ohhhh, xine does not trim the audio stream list based on the currently played media, right? It could be that xine has not recognised the second audio stream at all. In fact, based on what your attachment is saying it seems like it.

Can you please attach the verbose output from Me TV?

Revision history for this message
Mahendra Tallur (mahen) wrote :

Thanks for your reply ! Here's the log you asked for !

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Ok, can you please record one of those channels and tell me what happens when xine tries to play it? Can you get both audio streams? Do both audio streams work in VLC on the recorded file?

Revision history for this message
Mahendra Tallur (mahen) wrote :

Sorry for my late answer !

Hmm, actually BOTH audio streams work with BOTH xine and vlc, after recording a few seconds with me-tv.

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Can you please try the latest and see if it still happens?

Revision history for this message
Mahendra Tallur (mahen) wrote :

Well, this already occurs with me-tv 1.1.3.
Maybe you are refering to some daily builds ?

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

Sorry, I can see that in the log file. Are you able to get onto #me-tv on FreeNode to talk this through in real-time?

Revision history for this message
Michael Lamothe (lamothe-deactivatedaccount-deactivatedaccount) wrote :

It appears as if sending XK_Shift causes some issues, switching over to XK_Control to see if that's better.

Changed in me-tv:
status: Incomplete → In Progress
Changed in me-tv:
status: In Progress → Fix Committed
importance: Undecided → High
Changed in me-tv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers