Me TV, it's TV for me computer

Starting me-tv causes error "Duplicate object id 'hbox1' on line 1220 (previously on line 535)"

Reported by Christof Löwe on 2009-08-31
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Me TV
High
Unassigned
1.1
High
Unassigned
me-tv (Debian)
Fix Released
Unknown
me-tv (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: me-tv

In Karmic Alpha 4 amd64 since today's (August 31 2009) updates i get the error message "Duplicate object id 'hbox1' on line 1220 (previously on line 535)" when i start me-tv. It happens in a Ubuntu-Installation and in a independent Kubuntu-Installation as well. Until yesterday - and before the updates - it worked.

Related branches

Bob Hazard (junkbit) wrote :

Happens to me as well.

Also get a similar message when I try to run gnome-appearance-properties, but with different line numbers

Changed in me-tv (Ubuntu):
status: New → Confirmed
blackart (sam-black) wrote :

yup me too~

Hmm... this was recently synced from Debian... I had the version I managed to get into karmic (me-tv 1.0.0-0ubuntu1) So what is the version do you currently have installed? is is 1.0.0-0ubuntu1 or 1.0.0-1 (check via synaptic as me-tv --version will only report 1.0.0!)

This may involve a little messing around, but if you have the version from Debian installed, can you please remove and try the package I built, and see if you still get the same errors? as what I'm attempting to establish is the recently synced package the issue or has something else changed for one of the depending packages...

https://edge.launchpad.net/~vk7hse/+archive/ppa (this is my ppa on LP)

Scott

Changed in me-tv (Ubuntu):
status: Confirmed → Incomplete
blackart (sam-black) wrote :

well i installed 1.0 worked fine. Best TV app.. ever..
now error. ( i had set koala to auto update..).. I looked at version was then 1.0.0.1 .. removed. tried. older deb packages.. no luck same error now.

I've sent an email to Michael, I'm hoping he may be able to shed some
light... I'll set up a karmic install tomorrow (02/09/2009) and do some
testing myself (I'm still on Jaunty!)

my guess is that a dependency has broken not Me TV ! but some more
research will hopefully prove otherwise...

could I ask that you paste the verbose output just to provide some
additional info as I know Michael will no doubt ask for this!

just run (from a terminal) me-tv --verbose and paste what is reported
back....

Thanks

--
Scott Evans <email address hidden>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Christof Löwe (christof-loewe) wrote :

Here we are:

l3onidas@ragnar2:~$ me-tv --verbose
Me TV 1.0.0
01.09.2009 15:17:38: Creating directory '/home/l3onidas/.me-tv'
01.09.2009 15:17:38: Scanning DVB devices ...
01.09.2009 15:17:38: Opening frontend device: /dev/dvb/adapter0/frontend0
01.09.2009 15:17:38: Closing frontend device: /dev/dvb/adapter0/frontend0
01.09.2009 15:17:38: Database 'does not exist'
01.09.2009 15:17:38: Opening database file '/home/l3onidas/.me-tv/me-tv.db'
01.09.2009 15:17:38: Application constructor
01.09.2009 15:17:38: sqlite3_threadsafe() = 1
01.09.2009 15:17:38: Loading GtkBuilder file '/usr/share/me-tv/glade/me-tv.ui' ...
01.09.2009 15:17:39: Error message: 'Doppelte Objektkennung »hbox1« in Zeile 1220 (zuvor in Zeile 535)'
01.09.2009 15:18:23: Me TV terminated

Thanks... I'll be in touch ASAP! :)

On Tue, 2009-09-01 at 13:20 +0000, Christof Löwe wrote:

> Here we are:
>
> l3onidas@ragnar2:~$ me-tv --verbose
> Me TV 1.0.0
> 01.09.2009 15:17:38: Creating directory '/home/l3onidas/.me-tv'
> 01.09.2009 15:17:38: Scanning DVB devices ...
> 01.09.2009 15:17:38: Opening frontend device: /dev/dvb/adapter0/frontend0
> 01.09.2009 15:17:38: Closing frontend device: /dev/dvb/adapter0/frontend0
> 01.09.2009 15:17:38: Database 'does not exist'
> 01.09.2009 15:17:38: Opening database file '/home/l3onidas/.me-tv/me-tv.db'
> 01.09.2009 15:17:38: Application constructor
> 01.09.2009 15:17:38: sqlite3_threadsafe() = 1
> 01.09.2009 15:17:38: Loading GtkBuilder file '/usr/share/me-tv/glade/me-tv.ui' ...
> 01.09.2009 15:17:39: Error message: 'Doppelte Objektkennung »hbox1« in Zeile 1220 (zuvor in Zeile 535)'
> 01.09.2009 15:18:23: Me TV terminated

--
Scott Evans <email address hidden>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Martin Pitt (pitti) wrote :

This was a recent change in GTK. Instead of just throwing a warning, it exists the program now. It's not yet clear to me whether this is just something to ease debugging with the development version of GTK, or whether this is permanent. But either way, it's a straightforward bug in me-tv's GtkBuilder *.ui file which needs to be fixed.

Changed in me-tv (Ubuntu):
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

Ah, how convenient, me-tv uses Launchpad as bug tracker.

Michael, this is easy to fix, I'll attach a patch.

Changed in me-tv (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Changed in me-tv:
status: New → Confirmed

Thanks for the explanation! I'll let Michael know...

On Tue, 2009-09-01 at 14:15 +0000, Martin Pitt wrote:

> This was a recent change in GTK. Instead of just throwing a warning, it
> exists the program now. It's not yet clear to me whether this is just
> something to ease debugging with the development version of GTK, or
> whether this is permanent. But either way, it's a straightforward bug in
> me-tv's GtkBuilder *.ui file which needs to be fixed.
>
> ** Changed in: me-tv (Ubuntu)
> Status: Incomplete => Triaged

--
Scott Evans <email address hidden>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Martin Pitt (pitti) wrote :

So, hbox1 and vbox2 were duplicates. With this patch, it works again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package me-tv - 1.0.0-1ubuntu1

---------------
me-tv (1.0.0-1ubuntu1) karmic; urgency=low

  * src/me-tv.ui: Fix duplicate IDs. (LP: #422126)

 -- Martin Pitt <email address hidden> Tue, 01 Sep 2009 16:23:22 +0200

Changed in me-tv (Ubuntu):
status: In Progress → Fix Released

As the stable bzr branch has be changed ownership back to Michael, I'm unable to update that branch. However, I do have a branch of my own that I have included this fix into... Thank you Martin for your assistance with this issue...

my bzr branch is ... https://code.edge.launchpad.net/~vk7hse/me-tv/test

I've just built this locally and all works fine...

Works again here!

Thank you so much.

blackart (sam-black) wrote :

thanks:)

Wow, help from "the great" Martin Pitt, thanks! I'll apply this fix in the next release of Me TV. For what it's worth, I can also confirm that it works again. Karmic is awesome!

Cheers,

Michael

On Wed, 2009-09-02 at 11:03 +0000, Michael Lamothe wrote:

> Wow, help from "the great" Martin Pitt, thanks! I'll apply this fix in
> the next release of Me TV. For what it's worth, I can also confirm that
> it works again. Karmic is awesome!
>
> Cheers,
>
> Michael
>

--
Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 437E00F9

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Changed in me-tv:
importance: Undecided → Unknown
status: Confirmed → Unknown
importance: Unknown → Undecided
status: Unknown → New
status: New → Confirmed
Changed in me-tv (Debian):
status: Unknown → New
Changed in me-tv:
assignee: nobody → Michael Lamothe (lamothe)
importance: Undecided → High
Changed in me-tv:
status: Confirmed → In Progress

Applied to the lp:~lamothe/me-tv/me-tv-1.1.0 branch.

Changed in me-tv:
status: In Progress → Fix Committed
TheInstantretard (becomming) wrote :

In case you diden't notice, it looks like the fix was not pushed to the repo.

Done now.

Thanks,

The not so instant Retard :)

Changed in me-tv (Debian):
status: New → Fix Released

Released in Me TV 1.0.1

dna-gene (csm-walkabout) on 2010-02-09
Changed in me-tv:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.