maya-calendar crashed with SIGSEGV in g_date_time_to_timezone()

Bug #1388515 reported by George Chalkitis on 2014-11-02
216
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Maya
Confirmed
Undecided
Unassigned

Bug Description

Maya crashes after adding Coogle Calendar.

ProblemType: Crash
DistroRelease: elementary OS 0.3
Package: maya-calendar 0.3~r676+pkg64~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CrashDB: maya_calendar
CurrentDesktop: Pantheon
Date: Sun Nov 2 09:01:47 2014
ExecutablePath: /usr/bin/maya-calendar
GSettings:

InstallationDate: Installed on 2014-10-19 (13 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
ProcCmdline: maya-calendar
SegvAnalysis:
 Segfault happened at: 0x7f39ced9fbd4: mov 0x10(%rdi),%esi
 PC (0x7f39ced9fbd4) ok
 source "0x10(%rdi)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: maya-calendar
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_date_time_to_timezone () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 maya_util_event_date_ranges () from /usr/lib/x86_64-linux-gnu/libmaya-calendar.so.0
 maya_view_grid_add_event ()
 ?? ()
Title: maya-calendar crashed with SIGSEGV in g_date_time_to_timezone()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors:
 gnome-session[1411]: WARNING: Error while executing session-migration: Failed to execute child process "session-migration" (No such file or directory)
 (gnome-settings-daemon:1770): media-keys-plugin-WARNING **: Grab failed for some keys, another application may already have access the them.
 (gnome-settings-daemon:1770): keyboard-plugin-WARNING **: Failed to contact localed: Error calling StartServiceByName for org.freedesktop.locale1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
 (gala:2131): GLib-GObject-WARNING **: g_object_set_valist: object class 'ClutterSettings' has no property named 'window-scaling-factor'
 (process:2207): Indicator-Power-WARNING **: Fail to query backlight devices.

George Chalkitis (chalkitisge) wrote :
information type: Private → Public
humunculus (3-clemens) wrote :

... tried to open yakuake (F11) when maya crashed the first time

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in maya:
status: New → Invalid
Download full text (5.9 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for gcc-4.8-base
libsystemd-login0 version 204-5ubuntu20.7 required, but 204-5ubuntu20.8 is available
libudev1 version 204-5ubuntu20.7 required, but 204-5ubuntu20.8 is available
no debug symbol package found for libv4l-0
outdated debug symbol package for apt: package version 1.0.1ubuntu2.5 dbgsym version 1.0.1ubuntu2.6
maya-calendar-common version 0.3~r676+pkg64~ubuntu0.3.1 required, but 0.3~r696+pkg66~ubuntu0.3.1 is available
maya-calendar-plugin-google version 0.3~r676+pkg64~ubuntu0.3.1 required, but 0.3~r696+pkg66~ubuntu0.3.1 is available
systemd-services version 204-5ubuntu20.7 required, but 204-5ubuntu20.8 is available
outdated debug symbol package for libapt-pkg4.12: package version 1.0.1ubuntu2.5 dbgsym version 1.0.1ubuntu2.6
libgl1-mesa-glx version 10.1.3-0ubuntu0.1 required, but 10.1.3-0ubuntu0.2 is available
no debug symbol package found for klibc-utils
libcamel-1.2-45 version 3.10.4-0ubuntu1.3 required, but 3.10.4-0ubuntu1.5 is available
libmaya-calendar0 version 0.3~r676+pkg64~ubuntu0.3.1 required, but 0.3~r696+pkg66~ubuntu0.3.1 is available
libebackend-1.2-7 version 3.10.4-0ubuntu1.3 required, but 3.10.4-0ubuntu1.5 is available
no debug symbol package found for libpython3-stdlib
libecal-1.2-16 version 3.10.4-0ubuntu1.3 required, but 3.10.4-0ubuntu1.5 is available
libmount1 version 2.20.1-5.1ubuntu20.2 required, but 2.20.1-5.1ubuntu20.3 is available
no debug symbol package found for libbz2-1.0
no debug symbol package found for libklibc
no debug symbol package found for libv4lconvert0
libcurl3-gnutls version 7.35.0-1ubuntu2.1 required, but 7.35.0-1ubuntu2.2 is available
outdated debug symbol package for libpangoft2-1.0-0: package version 1.36.3-1ubuntu1.1 dbgsym version 1.36.3-1ubuntu1
outdated debug symbol package for apt-utils: package version 1.0.1ubuntu2.5 dbgsym version 1.0.1ubuntu2.6
libegl1-mesa version 10.1.3-0ubuntu0.1 required, but 10.1.3-0ubuntu0.2 is available
libuuid1 version 2.20.1-5.1ubuntu20.2 required, but 2.20.1-5.1ubuntu20.3 is available
no debug symbol package found for libjbig0
libglapi-mesa version 10.1.3-0ubuntu0.1 required, but 10.1.3-0ubuntu0.2 is available
no debug symbol package found for cpio
util-linux version 2.20.1-5.1ubuntu20.2 required, but 2.20.1-5.1ubuntu20.3 is available
no debug symbol package found for sed
no debug symbol package found for gir1.2-glib-2.0
mount version 2.20.1-5.1ubuntu20.2 required, but 2.20.1-5.1ubuntu20.3 is available
libpam-systemd version 204-5ubuntu20.7 required, but 204-5ubuntu20.8 is available
libwayland-egl1-mesa version 10.1.3-0ubuntu0.1 required, but 10.1.3-0ubuntu0.2 is available
libgbm1 version 10.1.3-0ubuntu0.1 required, but 10.1.3-0ubuntu0.2 is available
no debug symbol package found for iproute2
libblkid1 version 2.20.1-5.1ubuntu20.2 required, but 2.20.1-5.1ubuntu20.3 is available
no debug symbol package found for python3-minimal
outdated debug symbol packag...

Read more...

tags: removed: need-amd64-retrace
Stef (stef-oostveen) wrote :

I encountered this bug when I tried to add a CalDAV calendar from Google Calendar. The calendar was being populated, but crashed shortly afterwards. It now keeps crashing every time I open Maya.

Changed in maya:
status: Invalid → Confirmed
Nicolò Balzarotti (anothersms) wrote :

Same as @Stef here. I cannot use it any more

humunculus (3-clemens) wrote :

can't use it too :(

zeeeeee (miesogeno) wrote :

I tried to file a report on this issue with an updated system, but it was marked invalid for the same reason mentioned here in Shnatsel's comment.

The temporary workaround for the crashing issue, is to delete the CalDav file in /home/.config/evolution/sorces , but you're still unable to add caldav calendars. Only the default google calendar works (ie. the one associated with your personal email).

Download full text (3.3 KiB)

@zeeeee cool, now maya start. However, i cannot use Google (as soon as I
write the password, maya crashes and return in the "non working" state).

2015-02-26 14:13 GMT+01:00 zeeeeee <email address hidden>:

> I tried to file a report on this issue with an updated system, but it
> was marked invalid for the same reason mentioned here in Shnatsel's
> comment.
>
> The temporary workaround for the crashing issue, is to delete the CalDav
> file in /home/.config/evolution/sorces , but you're still unable to add
> caldav calendars. Only the default google calendar works (ie. the one
> associated with your personal email).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1388515
>
> Title:
> maya-calendar crashed with SIGSEGV in g_date_time_to_timezone()
>
> Status in Maya (Calendar):
> Confirmed
>
> Bug description:
> Maya crashes after adding Coogle Calendar.
>
> ProblemType: Crash
> DistroRelease: elementary OS 0.3
> Package: maya-calendar 0.3~r676+pkg64~ubuntu0.3.1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> Uname: Linux 3.13.0-37-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> CrashDB: maya_calendar
> CurrentDesktop: Pantheon
> Date: Sun Nov 2 09:01:47 2014
> ExecutablePath: /usr/bin/maya-calendar
> GSettings:
>
> InstallationDate: Installed on 2014-10-19 (13 days ago)
> InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
> ProcCmdline: maya-calendar
> SegvAnalysis:
> Segfault happened at: 0x7f39ced9fbd4: mov 0x10(%rdi),%esi
> PC (0x7f39ced9fbd4) ok
> source "0x10(%rdi)" (0x00000010) not located in a known VMA region
> (needed readable region)!
> destination "%esi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: maya-calendar
> StacktraceTop:
> ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> g_date_time_to_timezone () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> maya_util_event_date_ranges () from
> /usr/lib/x86_64-linux-gnu/libmaya-calendar.so.0
> maya_view_grid_add_event ()
> ?? ()
> Title: maya-calendar crashed with SIGSEGV in g_date_time_to_timezone()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> XsessionErrors:
> gnome-session[1411]: WARNING: Error while executing session-migration:
> Failed to execute child process "session-migration" (No such file or
> directory)
> (gnome-settings-daemon:1770): media-keys-plugin-WARNING **: Grab failed
> for some keys, another application may already have access the them.
> (gnome-settings-daemon:1770): keyboard-plugin-WARNING **: Failed to
> contact localed: Error calling StartServiceByName for
> org.freedesktop.locale1:
> GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper
> exited with unknown return code 1
> (gala:2131): GLib-GObject-WARNING **: g_object_set_valist: object class
> 'ClutterSettings' has no property named 'window-scaling-factor'
> (process:2207): I...

Read more...

zeeeeee (miesogeno) wrote :

Ok, so I think I found a way to import all google calendars and a clue on the crash issue.

First of all, the default (personal) Google calendar always worked for me, in calendar type you chose "Google", then its just your username (you don't even have to put the "@gmail.com" part), and after you finish it, it will ask you for your password. Standard stuff.

Now to import any other Google calendar (shared calendars, for instance):
1 - you have to find the CalDAV ID, go here https://www.google.com/calendar/render#j , then select the calendar you want, and you'll find something like this "<email address hidden>"
2 - then in Maya, add a new calendar, select calendar type "CalDAV", and give it the name you want.
3 - in the URL write "https://www.google.com/calendar<email address hidden>/events" , and check "Use a secure connection"
4 - NOW THIS IS IMPORTANT: in the previous point, the url bar in Maya already has "http://" written, YOU HAVE TO INSERT AN "S" so its "https://, and this is the reason it crashes, I think.
5 - from here on its straight forward, your username, your email, your password, and your good to go, I hope.

You have to do this for every single calendar. Mine are working flawless.
I also hope this helps developers fix this issue.

Download full text (4.3 KiB)

Ok this is really strange. Adding the calendar using Google ->
<email address hidden> cause a crash. Using myname (without @gmail.com) *does*
work.

2015-02-27 18:23 GMT+01:00 zeeeeee <email address hidden>:

> Ok, so I think I found a way to import all google calendars and a clue
> on the crash issue.
>
> First of all, the default (personal) Google calendar always worked for
> me, in calendar type you chose "Google", then its just your username
> (you don't even have to put the "@gmail.com" part), and after you finish
> it, it will ask you for your password. Standard stuff.
>
> Now to import any other Google calendar (shared calendars, for instance):
> 1 - you have to find the CalDAV ID, go here
> https://www.google.com/calendar/render#j , then select the calendar you
> want, and you'll find something like this "
> <email address hidden>"
> 2 - then in Maya, add a new calendar, select calendar type "CalDAV", and
> give it the name you want.
> 3 - in the URL write "
> https://www.google.com/calendar<email address hidden>/events"
> , and check "Use a secure connection"
> 4 - NOW THIS IS IMPORTANT: in the previous point, the url bar in Maya
> already has "http://" written, YOU HAVE TO INSERT AN "S" so its "https://,
> and this is the reason it crashes, I think.
> 5 - from here on its straight forward, your username, your email, your
> password, and your good to go, I hope.
>
> You have to do this for every single calendar. Mine are working flawless.
> I also hope this helps developers fix this issue.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1388515
>
> Title:
> maya-calendar crashed with SIGSEGV in g_date_time_to_timezone()
>
> Status in Maya (Calendar):
> Confirmed
>
> Bug description:
> Maya crashes after adding Coogle Calendar.
>
> ProblemType: Crash
> DistroRelease: elementary OS 0.3
> Package: maya-calendar 0.3~r676+pkg64~ubuntu0.3.1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> Uname: Linux 3.13.0-37-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> CrashDB: maya_calendar
> CurrentDesktop: Pantheon
> Date: Sun Nov 2 09:01:47 2014
> ExecutablePath: /usr/bin/maya-calendar
> GSettings:
>
> InstallationDate: Installed on 2014-10-19 (13 days ago)
> InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
> ProcCmdline: maya-calendar
> SegvAnalysis:
> Segfault happened at: 0x7f39ced9fbd4: mov 0x10(%rdi),%esi
> PC (0x7f39ced9fbd4) ok
> source "0x10(%rdi)" (0x00000010) not located in a known VMA region
> (needed readable region)!
> destination "%esi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: maya-calendar
> StacktraceTop:
> ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> g_date_time_to_timezone () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> maya_util_event_date_ranges () from
> /usr/lib/x86_64-linux-gnu/libmaya-calendar.so.0
> maya_view_grid_add_event ...

Read more...

Georg Peters (georgpeters) wrote :

This error still exists with owncloud server 8.0 & freya beta2

maya-calendar
(maya-calendar:11979): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:744:29: '1px' is not a valid color name
[_LOG_LEVEL_INFO 21:39:13.690377] Application.vala:155: Kalender version: 0.3
[_LOG_LEVEL_INFO 21:39:13.690586] Application.vala:157: Kernel version: 3.13.0-45-generic
[_LOG_LEVEL_FATAL 21:39:14.391699] maya_util_is_the_all_day: assertion 'dtend != NULL' failed
[_LOG_LEVEL_FATAL 21:39:14.391782] Kalender will not function properly.
[_LOG_LEVEL_FATAL 21:39:14.391880] [GLib] g_date_time_format: assertion 'datetime != NULL' failed
[_LOG_LEVEL_FATAL 21:39:14.391938] Kalender will not function properly.
Segmentation fault (core dumped)

The events are shown for a short period when first adding the calendar to maya, then it just crashes with above message.
URL I used: https://url.to.owncloud/remote.php/caldav/calendars/georg/pers%C3%B6nlich

humunculus (3-clemens) wrote :

thank you Nicolò Balzarotti (anothersms) for this hint!
Now I can use maya :)
Thank you so much!!

I've try adding google calendar using only my username (without @gmail.com), but maya still crash

zeeeeee (miesogeno) wrote :

Mohamad Putra Maghribi, look at my comment in #11, delete everything inside folder /home/.config/evolution/sorces

Hi zeeeeee, i have deleted all files inside that folder (only one file existed there)

zeeeeee (miesogeno) wrote :

Mohamad Putra Maghribi, after doing that, you have to add goggle calendar following my post #13

Ameur1482 (ameur-sfaxi) wrote :

Hi guys,
I have the same issue on elementary os freya, following zeeeee posts (#11 and #13) does not help. I'm using Frensh localization, Any ideas.

maya-calendar

** (maya-calendar:3943): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-30XHDwMWDc: Connection refused
[_LOG_LEVEL_INFO 16:59:48.951252] Application.vala:155: Calendrier version: 0.3.1
[_LOG_LEVEL_INFO 16:59:48.951378] Application.vala:157: Kernel version: 3.16.0-34-generic
[_LOG_LEVEL_FATAL 16:59:49.263071] maya_util_is_the_all_day: assertion 'dtend != NULL' failed
[_LOG_LEVEL_FATAL 16:59:49.263143] Calendrier will not function properly.
[_LOG_LEVEL_FATAL 16:59:49.263256] [GLib] g_date_time_format: assertion 'datetime != NULL' failed
[_LOG_LEVEL_FATAL 16:59:49.263330] Calendrier will not function properly.

nado (nado+comptes) wrote :

I am on gentoo with maya-calendar latest version from the repository. With 0.3.1.0 it crashed and made the whole program unusable and segfault at startup. With 0.3.1.1 import only fails without making the whole app segfault.
My locales are on en_US-utf8 but the ics was in european french/belgian format.

% maya-calendar file.ics
[_LOG_LEVEL_INFO 14:07:41.535510] Application.vala:155: Maya version: 0.3.1.1
[_LOG_LEVEL_INFO 14:07:41.535581] Application.vala:157: Kernel version: 4.0.0
[_LOG_LEVEL_FATAL 14:07:41.767455] CalendarModel.vala:149: No calendar client was found
[_LOG_LEVEL_FATAL 14:07:41.767515] Maya will not function properly.
[_LOG_LEVEL_FATAL 14:07:44.245088] string_to_string: assertion 'self != NULL' failed
[_LOG_LEVEL_FATAL 14:07:44.245159] Maya will not function properly.
[_LOG_LEVEL_FATAL 14:07:44.245250] [libecal] e_cal_client_create_object: assertion 'icalcomp != NULL' failed
[_LOG_LEVEL_FATAL 14:07:44.245300] Maya will not function properly.

Or Schiro (orschiro) wrote :

@nado

Even with the latest installed version 0.3.1.1+r798+pkg70~daily~ubuntu0.3.1, Maya crashes for me on launch if I use it in conjunction with a Google Calendar.

SB (sir-beafy) wrote :

is it related or even duplicate of/to https://bugs.launchpad.net/maya/+bug/1420431 ?

Eric Göpel (capstan) wrote :

I'm having the exact same problem, but just with one of my subcalendars. I'ts the only calendar I have shared to other persons, may this be a problem?
(Although calendars shared from others to me are working....)
The rest is the same between all of them...

I'm on Loki.

miguel20 (miguel20) wrote :

The #13 can't work for mi at Loki 64 bits fresh instalation, also in Freya can't use it, I upgrade the version for try solve this but the same bug appears. I tried all the steps but google denied somtimes or the app said caan't exist the direction. If I launch on terminal:
(maya-calendar:5868): Gtk-WARNING **: Theme parsing error: apps.css:287:22: '' is not a valid color name
[INFO 11:16:23.553037] Application.vala:155: Calendario version: 0.4.0.2
[INFO 11:16:23.553160] Application.vala:157: Kernel version: 4.4.0-59-generic
[FATAL 11:16:24.480255] string_to_string: assertion 'self != NULL' failed
[FATAL 11:16:24.508960] maya_util_is_all_day: assertion 'dtend != NULL' failed
[FATAL 11:16:24.509123] [GLib] g_date_time_format: assertion 'datetime != NULL' failed
Violación de segmento (`core' generado)

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers