make "close window" infinite size; hard to close with a notebook's touchpad

Bug #388205 reported by Justin Verduyn on 2009-06-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Maximus
Undecided
Unassigned
maximus (Ubuntu)
Undecided
Unassigned

Bug Description

very hard to close a window in ubuntu netbook remix
user has to move mouse to top, middle of screen and hit very small button

the os is beautiful, but closing a window is stressful
what do we do more: close window or select date?
obviously close window
let's optimize for that action by moving it to the top, right of the screen

suggest moving the date and other icons to the left of the title bar
move the orange button to the top right
make the orange button bigger, so it can be clicked by an exaggerated movement to the top, right of the screen

ShawnJGoff (shawn-goff) wrote :

Can middle click be used to close the tab? That's the standard behavior everywhere else and it's what I usually do if I'm using the mouse.

Textureglitch (textureglitch) wrote :

I think the placement of the close button is fine where it is, it just needs to be bigger.
You expect the expandable date panel to be where it usually is.

In response to ShawnJGoff, Middle clicking is really not an option on netbooks running this distro.

Ubuntu Netbook Remix is designed to shine on netbooks[1], specifically the Dell Mini 9 and its replacement, the Mini 10v[2]. These netbooks have a two-button touchpad. This limits the fidelity of user input, particularly in mobile situations such as balancing the netbook on your lap.

Massive telemetry data has influenced UI design to follow Fitts' Law, which is rather accommodating to the loss of input fidelity by using the corners of the screen to give an effective button size of infinity [3].

"The Start Button in Windows is seemingly located in an ideal place for fast acquisition, and in recent versions of Windows that's certainly true. Prior to Windows 2000, however, the Start button had a single 'dead' pixel along the left and bottom sides of it in which clicking didn't open the Start menu. The result: slower acquisition times and a startling number of missed clicks."

Button size of the graphic can be unchanged, but the "hit area" can be increased ala Office 2007 orb in the upper-left corner.
"Although the button itself is round, the hit target for it actually extends on a maximized window all the way to the upper-left edge of the screen. As a result, accessing [most common functions] is ultra efficient."

Not that we follow what MS did blindly, but these are the results of their analysis of 1.3 billion Office 2003 user sessions [5]. That's a lot of user data, and we can benefit from their research. Let's eliminate the "dead pixels" if we can; I'm up for letting our users be "ultra efficient."

1. http://www.canonical.com/netbooks
2. https://lists.ubuntu.com/archives/ubuntu-cy/2009-April/000234.html
3. http://www.dell.com/home/netbooks
4. http://blogs.msdn.com/jensenh/archive/2006/08/22/711808.aspx
5. http://blogs.msdn.com/jensenh/archive/2006/04/05/568947.aspx

shows the round Office 2007 button with a hit area extending all the way to the upper-left edge of the screen

http://blogs.msdn.com/jensenh/archive/2006/08/22/711808.aspx

Could an applet be created that provides window controls for the in-focus window at all times?

i.e. keep the window picker applet as is, but provide a 2nd one to reside in the top-right with the close, maximize/restore, and minimize buttons.

I would imagine it being added to right end the panel, shifting the Fast User Switch Applet to the left.

Seems a bit complicated, in my opinion, but because Go-Home and Window-Picker are already separate applets, it strikes me as acceptable.

Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

This bug report requires more attention than the papercut project and the fixes required are not minor, Hence not a papercut.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

@Justin Verduyn : You have made a compelling points , and your proposal is thorough , But needs more consideration from the design team.
An apt place to get more attention of the UNR team is > http://lists.ubuntu.com/mailman/listinfo/ubuntu-mobile , subscribe to this list and propose your solution in the mailing list.
Do feel free to bring to our notice any other such usability issues which can be done to improve Ubuntu desktop/UNR.
While this is not a papercut ,I'm assigning it to the Netbook-remix project for their consideration.

@Sam Briesemeister : I'm not aware of which applet you are mentioning , If you are talking about writing/adding a new applet to a default, then it is definitely not a papercut. If you know of an applet which exists in the default install but is not used, Kindly re-validate the papercut.

Changed in hundredpapercuts:
status: New → Invalid
affects: hundredpapercuts → netbook-remix
Changed in netbook-remix:
status: Invalid → New
summary: - move "close window" to top, right corner of screen in ubuntu netbook
- remix
+ make "close window" infinite size; hard to close with a notebook's
+ touchpad
Jonathan Austin (mailforwho) wrote :

This is less a fix and more a workaround for those that come here looking for a solution. An applet would be ideal because then you could right click and get further options such as logout or options for that window (always on top, for example)

I use wmctrl (sudo apt-get install wmctrl), a script and a launcher button in the top right hand corner of my panel to create a universal close button (always closes the top window). It also logs out the current user if the desktop is the only active window.

It is one of the first scripts I've ever written, so please improve as required :)

@mac_v: My recommendation does not relate to an existing applet, at least not one I'm aware of.

@Who: that sounds like the idea I had in mind.

koda (vitto-giova) wrote :

couldn't the solution be simply move the close button on the left?

when i close an application i have a high possibility to want to switch to one of the background application -- since right now the close button is on the right i have to move the mouse on the top right (with a chance to miss and hit date & time) and then move the mouse completely on the left to change applications.

From a usability point of view if the close button was on the left we would have important benefits because
a - we'd get a reduced access time to the other application as there's no need to move the mouse from the opposite side of the desktop
b - we could rarely miss (and open other apps or menus) because if the close button were on the left, on the right side of it there would be the window title and on the left side of it there would be the window icon

I'd really prefer to keep the topright corner reserved for shutdown&co

Leo (leorolla) wrote :

I confirm this bug.

affects: netbook-remix → window-picker-applet
Changed in window-picker-applet:
status: New → Confirmed
affects: window-picker-applet → maximus
affects: netbook-launcher (Ubuntu) → maximus (Ubuntu)
Changed in maximus (Ubuntu):
status: New → Confirmed
Leo (leorolla) wrote :

It totally changes the user's life to have corner buttons to click at.

The go-home-applet is not on the corner for nothing ;-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers