Please backport gdm and language-selector to Lucid and Maverick

Bug #719815 reported by Gunnar Hjalmarsson on 2011-02-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lucid Backports
Wishlist
Unassigned
maverick-backports
Fix Released
Wishlist
Unassigned

Bug Description

Ever since the Ubuntu language support feature was changed to distinguish between language for message translation and non-language locales such as date formats, it has not played well with GDM's language chooser. Example: People who want date formats, default paper sizes etc. match their current geographical location, while using some other locale for controlling message translation, have encountered confusing, unexpected behavior.

Detailed descriptions and discussion can be found at bug 553162, and fixes have been released in Natty. The four branches, to which I have linked below, contain equivalent fixes for Lucid and Maverick, and I suggest that those branches are used to build packages for lucid-backports and maverick-backports. The branches were uploaded to my PPA, and the resulting builds have been tested successfully.
https://launchpad.net/~gunnarhj/+archive/lang-backports
Hence I give this bug the status "Confirmed".

I was about to nominate the fixes for SRUs, but was told that they include too much of changed behavior to qualify. Nevertheless, the rationale and discussion on regression risk at the top of the description of bug 553162 apply to this backports request as well.

Please let me know if there is anything else I can do to help process this request.

Changed in lucid-backports:
status: New → Confirmed
Changed in maverick-backports:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Natty's language-selector won't work in lucid/maverick, as this was moved from pygtk2 to python gobject-introspection. This needs a custom upload then.

natty's gdm should work fine on lucid/maverick (I haven't tested it, though).

I don't think that this is a feature which is very important to have on a stable release; people who have used those for a long time already will have learned how to deal with the situation, and it actually brings some intrusive changes (for example, LC_MESSAGES will be exported through ssh and cause a lot of locale problems on remote sites). But that shouldn't preclude a backport, of course.

Gunnar Hjalmarsson (gunnarhj) wrote :

Custom uploads is what I'm suggesting; the four branches contain the equivalent to certain revisions as specified on respective branch.

As regards the importance, my concern is primarily those who start using Ubuntu with the latest LTS or latest stable release.

Gunnar Hjalmarsson (gunnarhj) wrote :

From #ubuntu-desktop yesterday, for the record:

gunnarhj 2011-02-22 17:20:18
pitti: Hi Martin, I submitted the backports bug 719815 the other day. Do you have time to think it over and (hopefully) triage it?

pitti 2011-02-22 17:20:38
GunnarHj: I'm not in ~ubuntu-backporters
GunnarHj: we can't just backport the natty l-s package as it is, as this was switched to pygi
which doesn't yet work on lucid/maverick
gdm should work fine, though

gunnarhj 2011-02-22 17:21:29
pitti: I know, but Scott asked for an opinion.
pitti: The bransches don't include the pygi stuff.

pitti 2011-02-22 17:23:54
bug updated
GunnarHj: ah, there are branches already? usually backports require that you can build and use the natty package unmodified
as custom modifications need to be kept in sync and thus require a much larger amount of maintenance

gunnarhj 2011-02-22 17:27:27
pitti: I realised that that wouldn't suffice in this case. Thanks for the bug comment.

Gunnar Hjalmarsson (gunnarhj) wrote :

Scott,
The proportions of the LC_MESSAGES issue, that Martin mentioned, have just been considerably reduced (in Natty, that is).
https://launchpad.net/ubuntu/+source/gdm/2.32.0-0ubuntu9

Maybe I'd need a lesson on how backports work. The four linked branches were prepared bearing SRU nominations in mind, so they contain only changes that I consider to be bug fixes. Now, when that's not a restriction, I'd probably include also other Natty changes. Besides, I suppose it would be an advantage if identical packages could be uploaded to Lucid and Maverick.

I'd appreciate if we could talk about it.

Scott Kitterman (kitterman) wrote :

As discussed on IRC, because this is more of an update to Lucid/Maverick than a traditional backport, I want someone from ubuntu-desktop to bless this.

Changed in lucid-backports:
status: Confirmed → Incomplete
Changed in maverick-backports:
status: Confirmed → Incomplete
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

The branches have been updated, and include now the latest improvements of the bug 553162 fixes as well as Natty changes that address other bug reports on managing the language environment. The updated branches were uploaded to my PPA (https://launchpad.net/~gunnarhj/+archive/lang-backports), and the resulting packages have been installed and tested successfully.

As regards the GDM branches, the changes compared to the latest Lucid respective Natty release simply consist of three of the new Natty patches, so possible maintenance need shouldn't be very hard to handle.

Gunnar Hjalmarsson (gunnarhj) wrote :

Sure, Scott, comment #6 was intended for Martin. ;-)

Martin Pitt (pitti) wrote :

FWIW, I don't think that this is an urgent feature to have, but the patches look reasonable, and have been tested a while in Natty now. After the recent $LC_MESSAGES fix they work fine now, and I think they are good to go for backports.

Changed in maverick-backports:
status: Incomplete → New
Changed in lucid-backports:
status: Incomplete → New
Scott Kitterman (kitterman) wrote :

Ack. Approved by ubuntu-backporters for Lucid and Maverick.

Changed in lucid-backports:
importance: Undecided → Wishlist
status: New → In Progress
Changed in maverick-backports:
status: New → In Progress
importance: Undecided → Wishlist
Scott Kitterman (kitterman) wrote :

You need someone with upload rights for gdm to upload to lucid/maverick-backports now.

Martin Pitt (pitti) wrote :

All four packages uploaded. I reverted the "3.0 (quilt)" source change for lucid's gdm.

Martin Pitt (pitti) wrote :

All accepted from the queue

Martin Pitt (pitti) on 2011-03-07
Changed in maverick-backports:
status: In Progress → Fix Released
Changed in lucid-backports:
status: In Progress → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Scott, Martin: Thanks!

On 2011-03-07 12:33, Martin Pitt wrote:
> I reverted the "3.0 (quilt)" source change for lucid's gdm.

Wasn't aware that unversioned changes were included when pushing. Yet another lesson...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers