Selected text illegible

Bug #901790 reported by Satchit Bhogle on 2011-12-08
58
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Marlin
Medium
Unassigned

Bug Description

OS: Ubuntu 11.10 Oneiric stable 32-bit
Application: Marlin 0.1 daily

See attached image.
When you select text, it becomes almost illegible as it is white-on-light-grey. Nautilus 3's method is better, where selected and unselected text is both black, and so legible. Alternately, Nautilus 2's orange (for Ambiance) highlights can be used, which make text more legible than the grey.

Satchit Bhogle (satchitb) wrote :
ammonkey (am-monkeyd) wrote :

marlin at the opposite of nautilus respect your gtk theme.
So blame the theme ;)

For ambiance you can change the color in gtk-3.0/gtk-widgets.css.
You ll find a line with GtkIconView.view.cell (line +/- 800)

just comment the section replace with this:

.view {
        background-color: @base_color;
}

.view:selected {
        background-color: @selected_bg_color
}

and u ll got a nice orange background. I am no expert in theming so i can't really say more.

Changed in marlin:
status: New → Invalid
ammonkey (am-monkeyd) wrote :

ouch sorry u're right. After checking again it appears that Ambiance already got the good settings.

Changed in marlin:
status: Invalid → Confirmed
importance: Undecided → Medium
ammonkey (am-monkeyd) wrote :

ok so after some test i can say that nautilus & marlin works fine, u can try them with adwaita the default gnome theme or zukini. Ambiance is just incomplete.

At the start of gtk-3.0/gtk-widgets.css you'll find the different states, most of them are empty on Ambiance which is why we got an awfull visual on nautilus or marlin, we even got selections dissapearing after a right click menu or once our widow lost focus.

You can complete ambiance themes by replacing the section containing the states with:

-----------------------
*:active {
 background-color: shade (@bg_color, 0.915);
}

*:active:hover:insensitive {
}

*:active:insensitive {
}

*:hover {
 background-color: shade (@bg_color, 1.02);
}

*:hover:insensitive {
}

*:selected {
 background-color: @selected_bg_color;
 color: @selected_fg_color;
}

*:selected:focused {
 background-color: @selected_bg_color;
 color: @selected_fg_color;
}

--------------------------
you can theme specifically the views by using .view.cell:STATE where STATE is selected/hover/focused etc...
you can specifically theme marlin icon views by using ExoIconView.view.Cell:STATE

Hope it helps.
This bug is officially invalid.

Changed in marlin:
status: Confirmed → Incomplete
status: Incomplete → Invalid
Satchit Bhogle (satchitb) wrote :

To clarify, these are hexadecimal colour codes that have to be inserted?

Satchit Bhogle (satchitb) wrote :

Ack! Sorry, didn't read those values properly. Ignore the previous comment.

Satchit Bhogle (satchitb) wrote :

The proposed workaround does not work. The file has been edited, and marlin restarted.

ammonkey (am-monkeyd) wrote :

works fine here, u can try my changes to Ambiance here: http://ubuntuone.com/1CfuBxAcobyzbzL7Au22lE
or try zukitini from gnome-look.org

(btw it's not a workaround, just gtk3 theming.)

ammonkey (am-monkeyd) wrote :

Zukini*

ammonkey (am-monkeyd) on 2012-06-11
Changed in marlin:
status: Invalid → Confirmed
ammonkey (am-monkeyd) wrote :

I am reopening this bug since Marlin is now unuseable without a proper theme: the selected cells in the icon view are totally unreadable. This is normally a gtk theme bug and not a Marlin's one.

Apparently when u define a new background-color for a cell like in Ambiance

.cell {
    background-color: @base_color;
   ...
}

the previous background color defined via
*:selected,
*:selected:focused {
....
}
are overiden.

This what is happening now with the light-themes and all the themes derived from them.

Since i am not going to contact and beg for each theme maintainers to commit the fixs (i already done it for the light-themes twice), i am just just going to override them. Marlin now got an auto-theme option which is enabled by default and finally make our application usable with most of the recalcitrant themes. U can disable this fonctionnality via dconf-editor /apps/marlin/preferences auto-theme.

Changed in marlin:
status: Confirmed → Fix Committed
ammonkey (am-monkeyd) wrote :

I just pushed a proper fix for this bug. My previous commit was just a workarround. We don't need to overide the themes anymore to get the proper cells colors. While the auto-theme option is still handy to theme some widgets Marlin use, it cannot be default as it override the theme. So the option stay but is not activated by default. It may find its way in the Preferences. Any thoughs?

ammonkey (am-monkeyd) wrote :

 status fixreleased

Changed in marlin:
status: Fix Committed → Fix Released

Latest version of Marlin + latest Zukiwi theme are unreadable as on screenschot:
http://i.imgur.com/ndAmyw2.jpg

Marlin with Zukiwi theme on Mint 13 Mate (mate 1.6)

ammonkey (am-monkeyd) wrote :

@eMcE you can turn off the auto-theme option from Marlin it should be more readable, open dconf-editor
org.gnome.marlin.preferences auto-theme
unfortunately themes come with their own color naming, use different engines. It s quite a mess and there's nothing an application developer can really do about it. I tried the auto-theme option but as u see it doesn't work with every theme ;)
And it s not like there would be any standardization anytime soon.

@ammonkey.. I use gconf and mate-conf and in both does not have an entry "marlin".
I think this theme is buggy, because when I use Mint Update tool colors are ok, but
when using Gdebi the colors are so messed up that you can not see nothing at all.
The same thing happens for example in Ubuntu Tweak - white font on a light gray background etc.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers