Compilation broken with upcoming vala-0.18

Reported by nwt on 2012-06-27
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Marlin
Undecided
Unassigned

Bug Description

With the recent vala 0.17.2 the compilation of marlin (varka still succeeds) not just prints more warnings, but to fails at 85%.

Console output:

[ 85%] Building C object src/CMakeFiles/marlin.dir/View/Window.c.o
src/View/Window.c: In function ‘marlin_view_window_colorize_current_tab_selection’:
src/View/Window.c:1181:117: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
src/View/Window.c:1181:117: note: each undeclared identifier is reported only once for each function it appears in
src/View/Window.c: In function ‘marlin_view_window_change_tab’:
src/View/Window.c:1302:106: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
src/View/Window.c: In function ‘marlin_view_window_action_show_hide_contextview’:
src/View/Window.c:2039:103: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
src/View/Window.c: In function ‘marlin_view_window_action_zoom_in_callback’:
src/View/Window.c:2168:107: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
src/View/Window.c: In function ‘marlin_view_window_action_zoom_out_callback’:
src/View/Window.c:2197:108: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
src/View/Window.c: In function ‘marlin_view_window_action_zoom_normal_callback’:
src/View/Window.c:2266:111: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
make[2]: *** [src/CMakeFiles/marlin.dir/View/Window.c.o] Error 1
make[1]: *** [src/CMakeFiles/marlin.dir/all] Error 2

nwt (nwt) on 2012-07-01
description: updated
Mario Guerriero (mefrio-g) wrote :

here is the fix suggested by ricotz: http://paste.debian.net/plain/193721

nwt (nwt) wrote :

Unfortunately the paste has been deleted.

Julián Unrrein (junrrein) wrote :

Wow this is bad. Especially since elementary OS updates replaced vala 0.16 with vala 0.18 automatically.

Changed in pantheon-files:
status: New → Confirmed
Julián Unrrein (junrrein) wrote :

A correction: It's not elementary OS's repositories which updated vala, but the Vala PPA.

Cody Garver (codygarver) wrote :

The pantheon-files bug for this has moved to bug #1118846.

no longer affects: pantheon-files
Joshua Robison (hoshi411) wrote :

I'm having the same problem :

https://answers.launchpad.net/marlin/+question/226335#

Any fix?

Joshua Robison (hoshi411) wrote :

so I switched over to valac 16
sudo update-alternatives config --valac

and still get the same error
[ 51%] Building C object src/CMakeFiles/marlin.dir/View/Window.c.o
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_colorize_current_tab_selection’:
/opt/marlin/build/src/View/Window.c:1187:40: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
/opt/marlin/build/src/View/Window.c:1187:40: note: each undeclared identifier is reported only once for each function it appears in
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_change_tab’:
/opt/marlin/build/src/View/Window.c:1326:28: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_action_show_hide_contextview’:
/opt/marlin/build/src/View/Window.c:2095:26: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_action_zoom_in_callback’:
/opt/marlin/build/src/View/Window.c:2224:30: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_action_zoom_out_callback’:
/opt/marlin/build/src/View/Window.c:2253:31: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
/opt/marlin/build/src/View/Window.c: In function ‘marlin_view_window_action_zoom_normal_callback’:
/opt/marlin/build/src/View/Window.c:2322:34: error: ‘FM_DIRECTORY_TYPE_VIEW’ undeclared (first use in this function)
make[2]: *** [src/CMakeFiles/marlin.dir/View/Window.c.o] Error 1
make[1]: *** [src/CMakeFiles/marlin.dir/all] Error 2
make: *** [all] Error 2

Valac 18 actually got me to 85%

i wonder ... does putting the source in /opt/marlin have something to do with it?

TIA

Joshua Robison (hoshi411) wrote :

Dont know if it was the trying to build from the /opt directory or the using valac 18 that was holding me back but

I switched valac update alternatives to valac 16 and moved the source to my home directory and deleted all the files in the marlin/build directory just to clean it out and ... it built perfectly with no errors.

I think cleaning out the build folder helped as well.

thanks

Joshua Robison (hoshi411) wrote :

Also want to mention that libmarlincore.so.0 and libmarlinwidgets.so.0 were installed in /usr/local/lib/ only
And marlin would not run until I ln -s them into /usr/lib/

ammonkey (am-monkeyd) on 2013-04-15
Changed in marlin:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers