marionnet window does not show up

Bug #1085055 reported by Lucas Nussbaum on 2012-11-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
marionnet
Undecided
Unassigned

Bug Description

Hi,

My end goal is to package marionnet for Debian. Therefore, I'm trying to build it from source, to better understand the build process.

Building using marionnet_from_scratch works, and I can successfully start marionnet.

When building manually, the compilation succeeds as well as "make install", but when I start marionnet.byte, I get (after setting MARIONNET_DEBUG to true):
[0]: Loading module switch.ml
[0]: Loading module world_bridge.ml
[0]: Loading module world_gateway.ml
[0]: Loading module gui/gui_toolbar_COMPONENTS.ml
[0]: Loading module version.ml
[0]: Loading module gui/gui_dialog_A_PROPOS.ml
[0]: Loading module gui/talking.ml
[0]: Loading module gui/gui_menubar_MARIONNET.ml
[0]: Loading module gui/gui_toolbar_DOT_TUNING.ml
[0]: Loading module motherboard_builder.ml
[0]: Loading module gui/gui_window_MARIONNET.ml
[0]: Loading module splash.ml
[0]: Loading module marionnet.ml
and then nothing, it seems marionnet just hangs.

Any ideas ?

marionnet-daemon stats successfully.

Download full text (3.4 KiB)

Hi Lucas,

unfortunately the last release (0.90.6) must be compiled only with
OCaml 3.11, not with the newer versions (in order to prevent
compile-time and/or run-time errors as you have observed). On the other
hand, the trunk (which will become the new release as soon as possible
;-)) must be compiled with OCaml 3.12 (I haven't still tested with the
new OCaml 4.0).
So, my question is: are you using OCaml 3.12 to compile the release
0.90.6 ?
J.V.

On Fri, 30 Nov 2012 14:30:20 -0000, Lucas Nussbaum wrote:
> Public bug reported:
>
> Hi,
>
> My end goal is to package marionnet for Debian. Therefore, I'm trying
> to
> build it from source, to better understand the build process.
>
> Building using marionnet_from_scratch works, and I can successfully
> start marionnet.
>
> When building manually, the compilation succeeds as well as "make
> install", but when I start marionnet.byte, I get (after setting
> MARIONNET_DEBUG to true):
> [0]: Loading module switch.ml
> [0]: Loading module world_bridge.ml
> [0]: Loading module world_gateway.ml
> [0]: Loading module gui/gui_toolbar_COMPONENTS.ml
> [0]: Loading module version.ml
> [0]: Loading module gui/gui_dialog_A_PROPOS.ml
> [0]: Loading module gui/talking.ml
> [0]: Loading module gui/gui_menubar_MARIONNET.ml
> [0]: Loading module gui/gui_toolbar_DOT_TUNING.ml
> [0]: Loading module motherboard_builder.ml
> [0]: Loading module gui/gui_window_MARIONNET.ml
> [0]: Loading module splash.ml
> [0]: Loading module marionnet.ml
> and then nothing, it seems marionnet just hangs.
>
> Any ideas ?
>
> marionnet-daemon stats successfully.
>
> ** Affects: marionnet
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of
> marionnet-dev, which is subscribed to marionnet.
> https://bugs.launchpad.net/bugs/1085055
>
> Title:
> marionnet window does not show up
>
> Status in Marionnet - A virtual network laboratory:
> New
>
> Bug description:
> Hi,
>
> My end goal is to package marionnet for Debian. Therefore, I'm
> trying
> to build it from source, to better understand the build process.
>
> Building using marionnet_from_scratch works, and I can successfully
> start marionnet.
>
> When building manually, the compilation succeeds as well as "make
> install", but when I start marionnet.byte, I get (after setting
> MARIONNET_DEBUG to true):
> [0]: Loading module switch.ml
> [0]: Loading module world_bridge.ml
> [0]: Loading module world_gateway.ml
> [0]: Loading module gui/gui_toolbar_COMPONENTS.ml
> [0]: Loading module version.ml
> [0]: Loading module gui/gui_dialog_A_PROPOS.ml
> [0]: Loading module gui/talking.ml
> [0]: Loading module gui/gui_menubar_MARIONNET.ml
> [0]: Loading module gui/gui_toolbar_DOT_TUNING.ml
> [0]: Loading module motherboard_builder.ml
> [0]: Loading module gui/gui_window_MARIONNET.ml
> [0]: Loading module splash.ml
> [0]: Loading module marionnet.ml
> and then nothing, it seems marionnet just hangs.
>
> Any ideas ?
>
> marionnet-daemon stats successfully.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/marionnet/+bug/1085055/+subscriptions
>
> _...

Read more...

Lucas Nussbaum (lucas) wrote :

Hi,

Indeed, I was using ocaml 3.12. It works fine with trunk.

How stable is the trunk? What are your plans for a release? Should I aim at packaging trunk, or just forget about this for now?

Thanks,

Lucas

On Sat, 01 Dec 2012 08:24:23 -0000, Lucas Nussbaum wrote:
> Hi,
>
> Indeed, I was using ocaml 3.12. It works fine with trunk.
>
> How stable is the trunk? What are your plans for a release? Should I
> aim
> at packaging trunk, or just forget about this for now?

The trunk is stable and I plan to release a version in december, in
about fifteen days, probably in the week of 17-23.
Mainly, I still need to include a mechanism to help contributors to
provide new filesystems (with their kernels) suitable for Marionnet.
So, it's a good idea to package the trunk. The best solution could be
to integrate the packaging scripts into the trunk itself. Is it possible
and suitable, in your opinion, with your experience as debian packager?
Thanks,
Jean-Vincent

> --
> You received this bug notification because you are a member of
> Marionnet
> drivers, which is subscribed to marionnet.
> https://bugs.launchpad.net/bugs/1085055
>
> Title:
> marionnet window does not show up
>
> Status in Marionnet - A virtual network laboratory:
> New
>
> Bug description:
> Hi,
>
> My end goal is to package marionnet for Debian. Therefore, I'm
> trying
> to build it from source, to better understand the build process.
>
> Building using marionnet_from_scratch works, and I can successfully
> start marionnet.
>
> When building manually, the compilation succeeds as well as "make
> install", but when I start marionnet.byte, I get (after setting
> MARIONNET_DEBUG to true):
> [0]: Loading module switch.ml
> [0]: Loading module world_bridge.ml
> [0]: Loading module world_gateway.ml
> [0]: Loading module gui/gui_toolbar_COMPONENTS.ml
> [0]: Loading module version.ml
> [0]: Loading module gui/gui_dialog_A_PROPOS.ml
> [0]: Loading module gui/talking.ml
> [0]: Loading module gui/gui_menubar_MARIONNET.ml
> [0]: Loading module gui/gui_toolbar_DOT_TUNING.ml
> [0]: Loading module motherboard_builder.ml
> [0]: Loading module gui/gui_window_MARIONNET.ml
> [0]: Loading module splash.ml
> [0]: Loading module marionnet.ml
> and then nothing, it seems marionnet just hangs.
>
> Any ideas ?
>
> marionnet-daemon stats successfully.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/marionnet/+bug/1085055/+subscriptions

On 01/12/12 at 11:31 -0000, Jean-Vincent Loddo wrote:
> So, it's a good idea to package the trunk. The best solution could be
> to integrate the packaging scripts into the trunk itself. Is it possible
> and suitable, in your opinion, with your experience as debian packager?

There are two things:
- provide official packages in Debian and Ubuntu
- provide unofficial packages

For official packages, the recommended practice is to use a separate
repository to handle all the packaging work. Debian is organized in
teams, and I already got in touch with the pkg-ocaml team, so I would
just re-use their infrastructure and packaging practices.

The main reason for keeping a separate repository for the packaging work
is that it makes it possible to update the package without doing a new
software release (imagine a bug that only affects Debian).

Then, if official packages are available in Debian and Ubuntu, I'm not
sure if unofficial packages are still needed. If they are, it's easier
for Debian if you don't put the packaging scripts in the same
repository.

Lucas

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers