Wrong use_count reported by the range optimizer

Bug #933117 reported by Igor Babaev on 2012-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MariaDB
Fix Released
Medium
Igor Babaev

Bug Description

The bug #58731 from bugs.mysql.com is reproducible in mariadb-5.2.

When executing the following simple test case

create table t1 (a int, b int, c int, key idx (a,c,b));
insert into t1 values (0,0,0), (0,0,0);
select 1 from t1 force index (idx) where a >=1 and b <= 1 and a=c and c > 1;

the debug build of the mariadb-5.2 server reports:

[Note] Use_count: Wrong count for key at 0x2279948, 0 should be 1.

Changed in maria:
milestone: none → 5.2
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Igor Babaev (igorb-seattle)
Igor Babaev (igorb-seattle) wrote :

The same bug is reproducible for the latest debug versions of mysql-5.1 and mysql-5.5.

The bug is not reproducible in mariadb-5.3 and mariadb-5.5 due to the changes in the function
key_and() made in the patch for bug #800184.

Changed in maria:
status: Confirmed → In Progress
Changed in maria:
status: In Progress → Fix Committed
Elena Stepanova (elenst) wrote :

Fix released in 5.2.11

Changed in maria:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers