PASSWORD_QUESTION doesn't hide passwords in Release builds

Bug #907894 reported by Elena Stepanova on 2011-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MariaDB
Fix Released
High
Sergei Golubchik

Bug Description

I build the 5.5 version as
cmake -DCMAKE_BUILD_TYPE=Release
(no additional parameters)

Then I install the plugin 'two_questions' and create a user identified via it.
When I attempt to connect as this user using MySQL client, I get the prompt 'Password, please'. When I type in the password, it's displayed as a usual entry string.

It doesn't happen if I build with CMAKE_BUILD_TYPE=Debug -- the password gets hidden as usual.

It seems to be only the matter of the MySQL client binary -- with the same server and plugins, I get the expected behavior if I use the client binary from the debug build, and erroneous with the client binary from the release build.

Same problem happens on buildbot builds, tried on two different machines, both openSUSE.

Previous releases, e.g. 5.3, seem to work all right (tried the official release build and a buildbot build).

bzr version-info
revision-id: <email address hidden>
date: 2011-12-21 23:40:26 +0100
build-date: 2011-12-22 21:44:25 +0400
revno: 3187
branch-nick: maria-5.5

Elena Stepanova (elenst) wrote :

With default CMAKE_BUILD_TYPE (RelWithDebInfo) the behavior is the same as with Release.

Elena Stepanova (elenst) on 2012-01-12
Changed in maria:
assignee: serg (serg) → Sergei (sergii)
Changed in maria:
milestone: 5.5 → 5.2
milestone: 5.2 → 5.5
Changed in maria:
importance: Undecided → High
status: New → Fix Committed
Elena Stepanova (elenst) wrote :

Fix released with 5.5.20.

Changed in maria:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers