Sporadic failure of tests innodb_mysql and partition_innodb_semi_consistent

Bug #687320 reported by Kristian Nielsen on 2010-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MariaDB
Fix Released
High
Kristian Nielsen

Bug Description

innodb.innodb_mysql w2 [ fail ] timeout after 2700 seconds
        Test ended at 2010-10-23 13:29:10

Test case timeout after 2700 seconds

== /var/lib/buildbot/maria-slave/debian5-i386-fulltest/build/mysql-test/var/2/log/innodb_mysql.log ==
INSERT INTO t1 VALUES (1,'init');
CREATE PROCEDURE p1()
BEGIN
UPDATE t1 SET b = CONCAT(b, '+con2') WHERE a = 1;
INSERT INTO t2 VALUES ();
END|
BEGIN;
UPDATE t1 SET b = CONCAT(b, '+con1') WHERE a = 1;
affected rows: 1
info: Rows matched: 1 Changed: 1 Warnings: 0
SELECT * FROM t1;
a b
1 init+con1
# Switch to connection con2
CALL p1;;
# Switch to connection con1
SELECT * FROM t1;
a b
1 init+con1
COMMIT;

The failure is quite rare. Here are links to the failure history in Buildbot:

http://buildbot.askmonty.org/buildbot/reports/cross_reference#branch=&revision=&platform=&dt=&bbnum=&typ=&info=&fail_name=partition_innodb_semi_consistent&fail_variant=&fail_info_short=&fail_info_full=test+case+timeout&limit=100

http://buildbot.askmonty.org/buildbot/reports/cross_reference#branch=&revision=&platform=&dt=&bbnum=&typ=&info=&fail_name=innodb_mysql&fail_variant=&fail_info_short=&fail_info_full=test+case+timeout&limit=100

The problem is a race condition in the test case, will commit a patch.

Related branches

Changed in maria:
milestone: none → 5.1
assignee: nobody → Kristian Nielsen (knielsen)
importance: Undecided → High
status: New → Fix Committed
Kristian Nielsen (knielsen) wrote :

Fix will be in MariaDB 5.1.54 and 5.2.5

Changed in maria:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers