merge_debug test fails in Windows debug compilation

Bug #686184 reported by Vladislav Vaintroub on 2010-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MariaDB
Fix Released
Undecided
Vladislav Vaintroub

Bug Description

perl mysql-test-run.pl --suite=main merge_debug

<skip>
worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
main.merge_debug [ fail ]
        Test ended at 2010-12-06 22:26:26

CURRENT_TEST: main.merge_debug
mysqltest: At line 35: query 'INSERT INTO t4 VALUES (39)' succeeded - should hav
e failed with errno 1100...

The result from queries just before the failure was:
set global storage_engine=myisam;
set session storage_engine=myisam;
drop table if exists crashed,t2,t3,t4;
SET @orig_debug=@@debug;
CREATE TABLE crashed (c1 INT);
CREATE TABLE t2 (c1 INT);
CREATE TABLE t3 (c1 INT);
CREATE TABLE t4 (c1 INT) ENGINE=MRG_MYISAM UNION=(crashed,t2,t3) INSERT_METHOD=L
AST;
INSERT INTO crashed VALUES (10);
INSERT INTO t2 VALUES (20);
INSERT INTO t3 VALUES (30);
LOCK TABLES t3 WRITE, t2 WRITE, t4 WRITE, crashed WRITE;
SET GLOBAL debug="+d,*,myisam_pretend_crashed_table_on_open";
CREATE TRIGGER t1_ai AFTER INSERT ON crashed FOR EACH ROW INSERT INTO t2 VALUES(
29);
SET GLOBAL debug=@orig_debug;

 - saving 'H:/bzr/5.1/mysql-test/var/log/main.merge_debug/' to 'H:/bzr/5.1/mysql
-test/var/log/main.merge_debug/'
------------------------------------------------------------
The servers were restarted 0 times
Spent 0.000 of 6 seconds executing testcases

Related branches

Changed in maria:
assignee: nobody → Vladislav Vaintroub (wlad-montyprogram)
status: New → Confirmed
Changed in maria:
status: Confirmed → Fix Committed
Changed in maria:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers