mysql_client_test fail on windows x64

Reported by Oleksandr "Sanja" Byelkin on 2009-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Maria
Fix Released
High
Vladislav Vaintroub

Bug Description

The test fails with attempt to access memory 0xcccccccccccccccc in output_l called from fprintf, TERMINATE, mysql_print_status() (519).

Changed in maria:
importance: Undecided → High
assignee: nobody → Oleksandr "Sanja" Byelkin (sanja-byelkin)

The memory which is corrupted was allocated between two ha_initialize_handlerton() calls, so probably it is also ha_initialize_handlerton() call:
hton= (handlerton *)my_malloc(sizeof(handlerton),
                                MYF(MY_WME | MY_ZEROFILL));
So the bug can be related to archive engine failures (also casued by memorry overrun)

Changed in maria:
status: New → In Progress

but can be reproduced by just COM_DEBUG (mysqladmin debug).

tags: added: 5.1 windows
Sergey Petrunia (sergefp) wrote :

The problem is not repeatable on 32-bit Windows.

Henrik Ingo (hingo) wrote :

Btw: We can release 5.1 final without Win64 support, so strictly speaking the 5.1 tag can be removed for this bug.

Just removed the "5.1" tag.

tags: removed: 5.1
Sergei (sergii) on 2010-07-27
Changed in maria:
milestone: none → 5.1
Changed in maria:
status: In Progress → Confirmed
Changed in maria:
assignee: Oleksandr "Sanja" Byelkin (sanja-byelkin) → Vladislav Vaintroub (wlad-montyprogram)
Changed in maria:
status: Confirmed → Fix Committed
Changed in maria:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers