Image with name 'manila-service-image' was not found or is not in 'active' state.

Bug #1741425 reported by junboli on 2018-01-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Manila
Medium
sapd

Bug Description

When create a share, it occured "Image with name 'manila-service-image' was not found or is not in 'active' state.", the reason behind is that when create a share it uses novaclient to get image list, but novaclient can only get 25 images due to pagination of glance server.

junboli (junboli) wrote :
Changed in manila:
assignee: nobody → junboli (junboli)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/531638

Changed in manila:
status: Confirmed → In Progress
Changed in manila:
milestone: none → queens-rc1

Reviewed: https://review.openstack.org/531638
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=51dd510636c817d2f7b5cb0b3c967fb604de87bb
Submitter: Zuul
Branch: master

commit 51dd510636c817d2f7b5cb0b3c967fb604de87bb
Author: junboli <email address hidden>
Date: Mon Jan 8 11:02:11 2018 +0800

    Fix NFS/CIFS share creation failure issue

    When the image count is over 25, there might not get
    manila-service-image, because current manila shares
    creation is using novaclient to get image info, but
    novaclient can only get 25 images due to pagination
    of glance server, So this change is to switch to use
    glanceclient instead of novaclient to get image info,
    because glanceclient can iter all image info, while
    novaclient is rarely maintained with stuff of image
    API.

    Change-Id: Id905d47600bda9923cebae617749c8286552ec94
    Closes-Bug: #1741425

Changed in manila:
status: In Progress → Fix Released
Ben Swartzlander (bswartz) wrote :

We had to revert the fix for this bug because it broke the generic driver. This bug will remain open until a correct fix is merged.

Changed in manila:
status: Fix Released → In Progress
importance: Undecided → Medium
milestone: queens-rc1 → rocky-1

This issue was fixed in the openstack/manila 6.0.0.0rc1 release candidate.

junboli (junboli) on 2018-02-09
Changed in manila:
assignee: junboli (junboli) → nobody
Tom Barron (tpb) on 2018-06-19
tags: added: driver generic

Fix proposed to branch: master
Review: https://review.openstack.org/610875

Changed in manila:
assignee: nobody → sapd (saphi070)
Tom Barron (tpb) on 2018-10-16
Changed in manila:
milestone: rocky-1 → stein-1
Tom Barron (tpb) on 2019-03-17
Changed in manila:
milestone: stein-1 → none

Change abandoned by Manuel Rodriguez (<email address hidden>) on branch: stable/rocky
Review: https://review.opendev.org/661129
Reason: cherry picking from stein

Change abandoned by Manuel Rodriguez (<email address hidden>) on branch: stable/stein
Review: https://review.opendev.org/661130
Reason: Tom, I didn't remove the release notes, I cherry picked the whole patch. So I'm not sure how it happened, I'll abandon this and try once again.

Change abandoned by Manuel Rodriguez (<email address hidden>) on branch: stable/stein
Review: https://review.opendev.org/661130
Reason: I just realized this patch was reverted in commit b70b85386ab6380a80e8a8dd30a9b273481f11e5, even if I apply it, it didn't work, the work around was to increase the default 25 images returned by glance in the glance config with: limit_param_default

Jason Grosso (jgrosso) wrote :

Hey sapd anyone update on this bug it looks like we have had some abandoned on stein? Do you need any help getting this fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers