isilon driver needs ability to handle access zones

Bug #1740844 reported by cfey on 2018-01-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Manila
Undecided
Shaun Edwards

Bug Description

If you have configured multiple access zones[1] in the isilon system manila-share needs the ability to "context switch" into this access zone.

Manila-share connects to the isilon cluster management interface which resides in the default access zone named "System". It then tries to e.g. list available shares but does not find anything since it only searches in the "System" access zone.

There should be a config parameter that makes manila aware of the access zone of the specific share server (which leads to the fact, that the API calls in "isilon_api.py" need to query the right access zone).

Steps to reproduce:

Create an additional groupnet on the isilon system and put it into a second access zone. Manila will then not be able to manage anything in this access zone.

Proposed solution:

See attached patch files.

[1] http://doc.isilon.com/onefs/8.0.1/help/en-us/#ifs_c_access_zones_overview.html

cfey (christian-fey) wrote :
cfey (christian-fey) wrote :
cfey (christian-fey) wrote :
Mario De Rosa (lordcasco70) wrote :

I've tried to apply that patches, but it didn't work.
I made a little change in isilon_api.py adding the following line in the initialization in order to define the parameter 'zone'. Without that i got error message stating that the object IsilonApi doesn't have the parameter 'zone':
def __init__(self, api_url, auth, verify_ssl_cert=True, zone='System'):
   self.host_url = api_url
   self.session = requests.session()
   self.session.auth = auth
   self.verify_ssl_cert = verify_ssl_cert
   self.zone = zone <<<<<<<<<<<<<<<<<<<<<<<--------------- added line

Mario De Rosa (lordcasco70) wrote :

I forgot, I changed also isilon.py file at line 385 with the following in order to read from manila.conf file the zone name

self._zone = emc_share_driver.configuration.safe_get(
            "emc_isi_zone")

Will try to use multiple zones

cfey (christian-fey) wrote :

Hi, thanks for your help. We have this working "hacked" into ROSP10, but with an far older Version. Maybe we missed sth. during patch generation.

If it works, would be nice to bring the enhancement upstream.

Tom Barron (tpb) on 2018-04-09
tags: added: dell-emc drivers
Tom Barron (tpb) on 2018-06-19
tags: added: driver isilon
removed: drivers
Jason Grosso (jgrosso) wrote :

Is this still issue still happening?

Jason Grosso (jgrosso) wrote :

Has anyone had the time to see if this is still occurring?

Tom Barron (tpb) wrote :

Helen, please route this one within EMC as appropriate. Someone needs to make a call whether the issue is still valid and if so whether there are plans to fix it.

Changed in manila:
assignee: nobody → Helen Walsh (walshh2)
cfey (christian-fey) wrote :

As far as I can see, the access zone is still not upstream. We worked around the issue and modified the following three files (until now we did not create new patches/pull requests).

This works with Redhat OpenStack Platform 13 and also includes the access-zone parameter (emc_isi_zone) in manila.conf.

It also fixes this API issue:

https://www.dell.com/community/Isilon/API-Auth-Changes-with-Recent-Security-Patches-anti-CSRF-token/m-p/7170613

Helen Walsh (walshh2) wrote :

Please assign to Shaun Edwards. Thank you

Changed in manila:
assignee: Helen Walsh (walshh2) → nobody
Tom Barron (tpb) on 2019-05-03
Changed in manila:
assignee: nobody → Shaun Edwards (shaun-edwards)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers