Manila exposes host/pool details to non-admin tenants

Bug #1664370 reported by Ben Swartzlander on 2017-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Manila
Critical
Ben Swartzlander
manila-ui
Low
Tom Barron

Bug Description

In Cinder, the host/pool information for volumes is only visible to admins. Manila should be the same way because admins typically expect hostnames and pool names (defined in config files or on storage controllers) to be hidden from end users.

Changed in manila:
importance: Undecided → Critical
milestone: none → ocara-rc2
status: New → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/433716

Changed in manila:
assignee: nobody → Ben Swartzlander (bswartz)
status: Triaged → In Progress
Changed in manila:
assignee: Ben Swartzlander (bswartz) → Valeriy Ponomaryov (vponomaryov)
Changed in manila:
assignee: Valeriy Ponomaryov (vponomaryov) → Ben Swartzlander (bswartz)
Changed in manila:
assignee: Ben Swartzlander (bswartz) → Goutham Pacha Ravi (gouthamr)
Changed in manila:
assignee: Goutham Pacha Ravi (gouthamr) → nobody
assignee: nobody → Ben Swartzlander (bswartz)
Changed in manila:
assignee: Ben Swartzlander (bswartz) → Goutham Pacha Ravi (gouthamr)
Changed in manila:
assignee: Goutham Pacha Ravi (gouthamr) → Ben Swartzlander (bswartz)

Reviewed: https://review.openstack.org/433716
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=15b27e8fbe252328ed6c105942e915c76af23fb4
Submitter: Jenkins
Branch: master

commit 15b27e8fbe252328ed6c105942e915c76af23fb4
Author: Ben Swartzlander <email address hidden>
Date: Mon Feb 13 22:31:18 2017 -0500

    Only return share host for admins using shares API

    Also, allow filtering by host based on policy 'list_by_host' that
    defaults to 'admin only'.

    Do not bump API, because it is not considered as expected behavior,
    hence should not be kept for old microversions.

    Co-Authored-By: Valeriy Ponomaryov <email address hidden>
    APIImpact
    Change-Id: I799bb7378927b6c3ee0f9fe88fd9876a03dd85b5
    Closes bug: 1664370

Changed in manila:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/435182
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=6f6a31d595eec9d5c2735d91317c4d4742b920d7
Submitter: Jenkins
Branch: stable/ocata

commit 6f6a31d595eec9d5c2735d91317c4d4742b920d7
Author: Ben Swartzlander <email address hidden>
Date: Mon Feb 13 22:31:18 2017 -0500

    Only return share host for admins using shares API

    Also, allow filtering by host based on policy 'list_by_host' that
    defaults to 'admin only'.

    Do not bump API, because it is not considered as expected behavior,
    hence should not be kept for old microversions.

    Co-Authored-By: Valeriy Ponomaryov <email address hidden>
    APIImpact
    Change-Id: I799bb7378927b6c3ee0f9fe88fd9876a03dd85b5
    Closes bug: 1664370
    (cherry picked from commit 15b27e8fbe252328ed6c105942e915c76af23fb4)

tags: added: in-stable-ocata

This issue was fixed in the openstack/manila 4.0.0.0rc2 release candidate.

This issue was fixed in the openstack/manila 5.0.0.0b1 development milestone.

Goutham Pacha Ravi (gouthamr) wrote :

manila-ui currently shows "Host" as a field on selecting a share and viewing its detail attributes. The value of this field is empty; so it might confuse users. However, 'host' is entirely meaningless to non-admin users, so we should remove this field altogether; marking the bug low priority.

Changed in manila-ui:
status: New → Confirmed
importance: Undecided → Low
Goutham Pacha Ravi (gouthamr) wrote :

Tagging this bug as a low-hanging-fruit for the remaining manila-ui implementation.

tags: added: low-hanging-fruit
Changed in manila-ui:
assignee: nobody → Tom Barron (tpb)
status: Confirmed → In Progress
Changed in manila-ui:
milestone: none → train-1

This issue was fixed in the openstack/manila-ui 2.18.0 release.

Reviewed: https://review.openstack.org/650129
Committed: https://git.openstack.org/cgit/openstack/manila-ui/commit/?id=97441440e098d06166299e811504fe26eb3b16aa
Submitter: Zuul
Branch: stable/rocky

commit 97441440e098d06166299e811504fe26eb3b16aa
Author: Tom Barron <email address hidden>
Date: Tue Aug 14 12:15:47 2018 -0400

    Don't show host field in project tables

    We already suppress this information in non-admin contexts in
    manila itself [1] so drop the field from the project view
    tables.

    Closes-Bug: #1664370
    [1] I799bb7378927b6c3ee0f9fe88fd9876a03dd85b5

    Change-Id: I00b99b082a4188e0e95c7a055da0fa28c5541338
    (cherry picked from commit ad27411eb416202468cd3f937d02a0e68f4ffeb5)

tags: added: in-stable-rocky

Reviewed: https://review.openstack.org/651539
Committed: https://git.openstack.org/cgit/openstack/manila-ui/commit/?id=fdbbe8cc9a34faede4416ab9d92a014d1fbb6b44
Submitter: Zuul
Branch: stable/queens

commit fdbbe8cc9a34faede4416ab9d92a014d1fbb6b44
Author: Tom Barron <email address hidden>
Date: Tue Aug 14 12:15:47 2018 -0400

    Don't show host field in project tables

    We already suppress this information in non-admin contexts in
    manila itself [1] so drop the field from the project view
    tables.

    Closes-Bug: #1664370
    [1] I799bb7378927b6c3ee0f9fe88fd9876a03dd85b5

    Change-Id: I00b99b082a4188e0e95c7a055da0fa28c5541338
    (cherry picked from commit ad27411eb416202468cd3f937d02a0e68f4ffeb5)
    (cherry picked from commit 97441440e098d06166299e811504fe26eb3b16aa)

tags: added: in-stable-queens

This issue was fixed in the openstack/manila-ui 2.13.1 release.

This issue was fixed in the openstack/manila-ui 2.16.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers