Concurrency issues with bulk access rule updates

Bug #1626249 reported by Goutham Pacha Ravi on 2016-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Manila
High
Goutham Pacha Ravi

Bug Description

This bug is spawned from https://bugs.launchpad.net/manila/+bug/1609841 to be targeted for the Ocata release, since the previous bug was reported when Newton release was under development.

Please see the discussion on https://bugs.launchpad.net/manila/+bug/1609841 for more detail.

Steps to reproduce:

When adding several rules by using a script like:

for i in `seq 1 100`; do manila access-allow share ip 10.0.0.$i; done

Eventually, the share instance access-rules-status gets changed to "updating multiple" on the API after the manager has already checked if the status is "updating multiple". Due to this error, the allow/deny APIs get stuck for this share instacce.

Tags: api Edit Tag help
Goutham Pacha Ravi (gouthamr) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/369668

Changed in manila:
status: Confirmed → In Progress

Changed in manila:
importance: Undecided → High
assignee: nobody → Goutham Pacha Ravi (gouthamr)
milestone: none → ocata-1
tags: added: api
Changed in manila:
status: New → In Progress
Changed in manila:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers