Manila debug logging should be enhanced for share instances

Bug #1496010 reported by Andrew Kerr on 2015-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Manila
Wishlist
Jason Grosso

Bug Description

With the introduction of share instances the ability to trace requests through log files has become more difficult.

Specifically for this issue, if a share create request fails in tempest it can be near impossible to find out why because the tempest test only knows and logs the share_id, as does the m-api.log file, but the m-sch.log and m-shr.log files are both logging the share_instance_id.

There should at the very least be a debug line added wherever the share_instance_id is determined to link the share_id to the share_instance_id. Something like "Share <id> mapped to share instance <id>." This would allow the request to be properly traced through the various log files more easily.

Changed in manila:
assignee: nobody → ashok chandran (ashok-chandran3)

Fix proposed to branch: master
Review: https://review.openstack.org/237527

Changed in manila:
status: New → In Progress

I have amended the fix as per your comments. Please review. https://review.openstack.org/#/c/238113/

Change abandoned by ashok chandran (<email address hidden>) on branch: master
Review: https://review.openstack.org/237527
Reason: abandoning this fix as it was not correct

Changed in manila:
importance: Undecided → Wishlist
milestone: none → newton-1
importance: Wishlist → Medium

Change abandoned by Goutham Pacha Ravi (<email address hidden>) on branch: master
Review: https://review.openstack.org/238245
Reason: No update for over an year. Feel free to Restore if you want to fix this bug.

Tom Barron (tpb) on 2018-06-19
tags: added: logging
Changed in manila:
status: In Progress → Confirmed
assignee: ashok chandran (ashok-chandran3) → nobody
milestone: newton-1 → none
Jason Grosso (jgrosso) wrote :

Does anyone have an update about this bug, looks like the changes have been abandoned?

Jason Grosso (jgrosso) on 2019-03-21
Changed in manila:
assignee: nobody → Jason Grosso (jgrosso)
Jason Grosso (jgrosso) wrote :

closing defect please re-open if still occurring

Changed in manila:
status: Confirmed → Won't Fix
Jason Grosso (jgrosso) on 2019-05-07
Changed in manila:
importance: Medium → Wishlist
status: Won't Fix → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers