Failed to allow-access for native_glusterfs

Bug #1417352 reported by li,chen on 2015-02-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Shared File Systems Service (Manila)
Medium
Csaba Henk

Bug Description

I'm trying to enable native_glusterfs in my environment.

I'm basically following:
     http://dcshetty.blogspot.in/2015/01/using-glusterfs-native-driver-in.html
with some difference:
1. my OS for gluser is ubuntu 14.04 (with glusterfs-server 3.5.3 from ppa:gluster/glusterfs-3.5 )
2. my OS for manila is ubuntu 14.10 (with glusterfs-client 3.4.2)

After I run command:
manila access-allow $my_share_name cert client.example.com

I get error in share.log:
http://paste.openstack.org/show/165894/

li,chen (chen-li) on 2015-02-03
description: updated
Deepak C Shetty (dpkshetty) wrote :

@Li Chen,

For Manila Native driver, the minimum version of GlusterFS is 3.6, which has the SSL support.
Since you are using 3.5.x its failing with that error.

Looking at your comment above, it seems you are using Ubuntu, check https://launchpad.net/~semiosis/+archive/ubuntu/ppa to see if he has 3.6 deb packages. At the moment I don't have the direct link to the 3.6 ppa but googling should help.

If you still don't get the 3.6 deb packages, pls mail gluster-users list to get right link.

HTH,

thanx,
deepak

P.S. Pls don't use latest glusterfs or night build (as said in my blog) since there are recent changes to glusterfs SSL that causes the native driver to break. Its recomemended to use 3.6 series only

Csaba Henk (chenk) wrote :

So, basically the problem you experience seems to occur due to using non-supported versions of certain software components, which is not a bug as such.

However, we see two ways to improve the situation:

- You should get an early and clear error message that clarifies incompatibility
- The exception you have in your logs should have the template variables substituted in its message.

Thank you for letting us

Csaba Henk (chenk) wrote :

... know of those issues.

Csaba Henk (chenk) wrote :

Adding a copy of the stack trace published at http://paste.openstack.org/raw/165894/ to have it stored in the context of the bug report.

Csaba Henk (chenk) on 2015-04-01
Changed in manila:
assignee: nobody → Csaba Henk (chenk)
Changed in manila:
milestone: none → kilo-rc1
importance: Undecided → Medium
status: New → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/171302

Changed in manila:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/171302
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=7e75c380a67cd270082402149b6007f1c8fc50a9
Submitter: Jenkins
Branch: master

commit 7e75c380a67cd270082402149b6007f1c8fc50a9
Author: Csaba Henk <email address hidden>
Date: Tue Apr 7 18:39:49 2015 +0200

    glusterfs, glusterfs_native: perform version checks

    - add gluster_version method to GlusterManager class
    - gluster: check if version of the GlusterFS server is at least 3.5
    - gluster_native: check if version of the GlusterFS server is at least 3.6
    - gluster_native: on snaphot creation failure, interpret errno only
      for GlusterFS strictly later than 3.6

    Change-Id: I242ea83c3a31670eb6a13c11e39d0c2228170c50
    Closes-Bug: #1417352

Changed in manila:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-04-13
Changed in manila:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in manila:
milestone: kilo-rc1 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments