"Mute" is a toggle, making volume slider confusing

Bug #1124005 reported by Mika Meskanen
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
manhattan
Invalid
Medium
Lars Karlitski
indicator-sound (Ubuntu)
Triaged
Wishlist
Lars Karlitski

Bug Description

When sound is muted, the volume slider is still available in the sound menu, but currently does nothing.

<https://wiki.ubuntu.com/Sound#Mute>: "The Mute action should idempotently set the volume to zero for the primary sound output. That is, if you Mute and then Mute again, sound should still be muted. And if you Mute then make the volume Louder, it should end up just above zero."

<https://wiki.ubuntu.com/Sound#A.2BIBw-Mute.2BIB0->: "Choosing ['Mute' in the menu] should trigger the Mute action."

Bill Filler (bfiller)
Changed in manhattan:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in manhattan:
assignee: Renato Araujo Oliveira Filho (renatofilho) → Lars Uebernickel (larsu)
Revision history for this message
Lars Karlitski (larsu) wrote :

Where is this coming from? The design spec for the sound menu doesn't mention this ("Volume Changes" is marked as TBD) [1]. Please open a design-bug against indicator-sound if you still think it should behave in that way.

[1] https://wiki.ubuntu.com/Sound#Phone

Changed in manhattan:
status: Confirmed → Invalid
Oren Horev (oreneeshy)
information type: Proprietary → Public
Oren Horev (oreneeshy)
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

This is not relevant to the phone or tablet, because it does not have a Mute function. (It has, or should have, Silent Mode instead.)

However, it is relevant to the PC. Currently if you Mute, the volume slider remains usable. This lets you specify what the volume will be once you unmute, which may be handy if you used Mute as a quick fix for blaring music. However, it is confusing in that it may not be crystal clear why the volume slider isn't doing anything.

Possible solutions:

a. Hide the volume slider when in Mute mode.
    - Pro: Eliminates the confusion.
    - Cons: Can't prepare volume for unmuting. Not clear what hardware volume keys would do.

b. Disable the volume slider when in Mute mode.
    - Pro: Eliminates the confusion.
    - Cons: Can't prepare volume for unmuting. Not clear what hardware volume keys would do.

c. Eliminate the Mute function altogether.
    - Pros: Eliminates the confusion. Simplifies the menu.
    - Con: Makes the slider slower to use, since you need to work harder to keep the pointer away from the titles of other menus above it (see also bug 1281617).

d. Make "Mute" just a shortcut for setting the volume to zero.
    - Pros: Eliminates the confusion. Reduces modality.
    - Con: More difficult to restore sound to its previous volume.

affects: ubuntu-ux → indicator-sound (Ubuntu)
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

A complication is that many keyboards have Mute, Quieter, and Louder keys. So even if we (a/b) made the volume slider inaccessible during mute, the Quieter and Louder keys would still need defined behavior; and if we (c) removed "Mute" from the menu, the Mute key would still need defined behavior.

Changed in indicator-sound (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Ok, I've gone with option (d): Mute should always set the volume to zero, even if it was already zero. Specification updated. <https://wiki.ubuntu.com/Sound?action=diff&rev2=106&rev1=105>

This means that the slider is still effective and useful when sound is muted, so this bug report is Invalid. (This is another example of how bug reports with "should" in their title are likely to be Invalid.)

Changed in indicator-sound (Ubuntu):
status: In Progress → Invalid
summary: - [indicators] Sound menu: Volume slider should disappear when Mute is
- toggled on
+ "Mute" is a toggle, making volume slider confusing
description: updated
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Reopening with revised description.

Changed in indicator-sound (Ubuntu):
status: Invalid → Triaged
assignee: Matthew Paul Thomas (mpt) → Lars Uebernickel (larsu)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers