no mic on EEE pc 1005ha 9.10

Bug #465497 reported by Hearthole on 2009-10-30
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
alsa-driver (Debian)
Fix Released
Unknown
linux (Mandriva)
Confirmed
Medium
linux (Ubuntu)
Undecided
Unassigned
linux-backports-modules-2.6.31 (Ubuntu)
Undecided
Unassigned

Bug Description

 I just installed 9.10 NBR and it is working wonderful on my EEE pc with the exception of the internal mic. I expected the mic to work out of the box, but when I tried recording with it, only static records.

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mike 1726 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 14
   Simple ctrls : 9
CheckboxCommand: alsa_record_playback
CheckboxDescription:
 Open the volume control application by right-clicking on the speaker icon in the panel and selecting "Sound Preferences". Select the "Input" tab and choose any alternate (non-default) device(s). Select the "Output" tab and choose any alternate (non-default) device(s). When you are done, click the Test button, then speak into the microphone. After a few seconds, your speech will be played back to you.

 Did you hear your speech played back?
CheckboxTest: alsa_record_playback_alternates
Date: Fri Oct 30 13:23:26 2009
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: alsa-driver
Tags: ubuntu-unr checkbox-bug
Uname: Linux 2.6.31-14-generic i686

Revision history for this message
Hearthole (michael4change) wrote :
Revision history for this message
Daniel T Chen (crimsun) wrote : Re: [Bug 465497] Re: no mic on EEE pc 1005ha 9.10

Please install linux-backports-modules-alsa-karmic and reboot.

Revision history for this message
Hearthole (michael4change) wrote :

@Daniel I did install the backports, now the mic works with everything with the exception of skype (beta). The fix did get my mic to work with pulseaudio though. Thanks!

Revision history for this message
Daniel T Chen (crimsun) wrote :

Thanks for the feedback.

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
Revision history for this message
Jim Klein (jklein) wrote :

This is not fixed. Mic works in nothing except gnome-sound-recorder with the backports installed. The only way to get the mic to work is to uninstall pulseaudio, which has all sorts of ramifications. You can get the mic to work in some apps by running the Front Mic Boost and Capture sliders to max, but recording is full of static (with or without pulseaudio). Opening the gnome-volume-control-applet and touching the Input slider kills the mic again. No options to select mic any more, and no digital input slider.

Revision history for this message
Vivien (martin-vivien) wrote :

I made it works on mine by installing alsa backports and set left or right value for capture to 0 in alsamixer. The problem is that each time you want to change the volume of the mic, you have to change it in alsamixer. I posted the complete procedure in the forum of the french ubuntu community:
http://forum.ubuntu-fr.org/viewtopic.php?pid=3197986#p3197986
Then it works with all the application including skype

Gary M (garym) on 2010-11-02
tags: added: hw-specific
Changed in linux (Mandriva):
status: Unknown → Confirmed
Changed in alsa-driver (Debian):
status: Unknown → New
Changed in alsa-driver (Debian):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Mandriva):
importance: Unknown → Medium
Changed in alsa-driver (Debian):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.