No sound with Intel HDA ICH8 (chip SigmaTel ID 7698) in Hardy

Bug #207068 reported by Dimitris Kalamaras on 2008-03-26
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Mandriva)
Unknown
Medium
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Dimitris Kalamaras

Bug Description

Binary package hint: alsa-base

Hi,

I've just installed Hardy beta and apt-get upgraded to the latest updates.
Everything seems ok (3D, webcam, etc), but there is no sound output.
The mixer applet seems to be working. All sound and video applications report no problem and work flawlessly, nevertheless I don't hear anything. I checked alsamixer, Master and PCM volumes are maxed, not muted. Also, I tried changing device by the relevant menu on mixer applet. It gives me the following choices:
HDA intel (alsa mixer),
SigmaTel ID 7698 (OSS Mixer) and
Playback: ALSA PCM on front:0 (HDA Generic) via DMA (PulseAudio).

None of the above worked.

I had the same problem on Gutsy. I know there is a similar bug report (#131133), with a link to http://tinyurl.com/35kbbn containing some advices, but none of them worked for me before.

My laptop is of a local brand in Greece.

Alsamixer reports this Chip: SigmaTel ID 7698 on Card: HDA Intel

lsb_release -rd
Description: Ubuntu hardy (development branch)

apt-cache policy alsa-base
alsa-base:
  Installed: 1.0.16-0ubuntu4

forgot the lspci -nn output:

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b (rev 03)]

Jan-Erik (janerikmg) wrote :

I have the same problem, with my Turbo X laptop. If i find something i will let you know.

Nothing here yet.

xLekOx (mail-xlekox) wrote :

Posible solution on Mandriva's bugzilla: https://qa.mandriva.com/show_bug.cgi?id=41385

Not work here :(

Jan-Erik (janerikmg) wrote :

Dimitris,
Did you try the solution posted by xLekOx ?
--Jan-Erik

sorry, Jan-Erik, can' t be of any help any more. :(
I gave away that laptop a month ago.

Changed in alsa-driver:
status: Unknown → In Progress
logari81 (logari81) wrote :

As I hadn't found this bug report before, I opened a new one:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/269859

it should be reported now as duplicate

I ll also try the mandriva-solution.

In the Mandriva bug report,

https://qa.mandriva.com/show_bug.cgi?id=41385

Tomasz Kobiela reports that a kernel upgrade solved his sound problem. I presume he mean 2.6.27. Can anybody confirm?

Mackenzie Morgan (maco.m) wrote :

Marking against linux since it seems the default kernel driver is in use, not the alsa-source package.

William F Pearson (wfpearson) wrote :

I might be affected by this same bug. I don't have sound through the laptop speakers, but the headphone jack works fine.

logari81 (logari81) wrote :

If you are not sure about your hw, you could run:

wget http://hg.alsa-project.org/alsa/raw-file/tip/alsa-info.sh -O alsa-info.sh

followed by:

bash alsa-info.sh

and post here the link you will get after running the program started by the last command.

Daniel T Chen (crimsun) on 2008-12-05
Changed in linux:
status: New → Incomplete

Since Dimitris, the original bug reporter no longer has the hardware to test, I'm closing this report. If anyone is still experiencing issues, please test the latest pre-release of Jaunty and if the issue still exists open a new bug report - https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks.

Changed in linux:
status: Incomplete → Won't Fix
Changed in alsa-driver:
status: In Progress → Fix Released
Changed in alsa-driver:
status: Fix Released → Confirmed
simran (smarwa) wrote :

Hi guys
I dont know if this is the right post. I have the same problem as was mentioned above. I get sound through my headphone jack but not speakers. My alsa-info is below. please help.

http://www.alsa-project.org/db/?f=0405d0351aeb457a3a2d3b13ff5e45918b432a6e

Please file your own bug. Do not pile on to other people's kernel bugs.

Changed in alsa-driver (Mandriva):
importance: Unknown → Medium
Changed in alsa-driver (Mandriva):
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.