ijs_server_epsonepl not found

Bug #34647 reported by nissan
This bug affects 3 people
Affects Status Importance Assigned to Milestone
foomatic-db (Ubuntu)
Fix Released
Nominated for Lucid by Savvas Radevic

Bug Description

When i configured epson epl 6200l as printer and trying to print test page, ijs_server_epsonepl not found
I found it in Kubuntu Flight 4

Revision history for this message
Matthias Klose (doko) wrote :

please could you recheck this with a current dapper live CD (daily/daily live current)? See http://cdimages.ubuntu.com/

Changed in cupsys:
assignee: nobody → doko
status: Unconfirmed → Needs Info
Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

ijs_server_epsonepl was still not installed after I dist-upgraded to dapper.

What package contains it?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

I could not find any package with the ijs_server_epsonepl.

The file can be compiled from the Epson EPL-5x00L/EPL-6x00L Printer driver package

The cupsys PPD file calls gs with the -sIjsServer argument set to ijs_server_epsonepl but no package installs it.

Revision history for this message
Ali Afshar (aafshar) wrote :

I can confirm that compiling http://sourceforge.net/projects/epsonepl/ and copying the resulting executable ijs_server_epsonepl to /usr/bin makes everything work perfectly.

Should this package be in Ubuntu somewhere?

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote :

What's blocking from including ijs_server_epsonepl from http://sourceforge.net/projects/epsonepl/ ?

Right now it's very annoying because the epsonepl printers are listed as supported but are not at all due to that missing executable file.
Most users won't know why it's not working. Either remove the printers from the list or add the required file for them to work.

Changed in cupsys:
status: Needs Info → Confirmed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I highly recommend to add this driver.

Recommendations to fix the general consistence between foomatic-db and the actually available drivers.

In general, note that foomatic-db contains only information about how to use drivers and PPD files generated with foomatic-db are also only information about how to use drivers. They are not the drivers itself.

If a driver XML file of foomatic-db (in /usr/share/foomatic/db/source/driver/) contains

<ghostscript />

then the corresponding driver is built into GhostScript. To get all of these drivers, ESP GhostScript (package gs-esp) must be built with the option "--with-drivers=ALL,opvp' in the "./configure" command line.

If the driver XML contains

<filter />

an external filter is needed. This means that the software downloadable from the URL mentioned in the <url> line of the same driver XML file needs to be installed.

I HIHGLY RECOMMAND to install all these drivers to assure that every printer/driver combination exposed by the gnome-cups-manager really works.

If for some reason you do not want to ship a certain printer driver with Ubuntu, please remove the corresponding driver XML file from the foomatic-db package. This way entries related to this driver in the gnome-cups-manager disappear. But note that then perhaps some printers will not be supported by Ubuntu.

If the driver XML contains

<uniprint />

you only need an appropriate .upp file in the /usr/share/ghostscript/<version>/lib/ directory. Follow the <url> in the driver XML file if the .upp file is not yet shipped with Ubuntu (most are already in ESP GhostScript). Also here you can remove driver XML files if you do not want to ship the appropriate .upp file.

In any case if you have removed driver XMLs. you must clean up the recommended drivers in the printer entries. To get this done automatically, run the command lines (requires foomatic-db-engine to be installed):

FOOMATICDB=`pwd` /usr/sbin//foomatic-cleanupdrivers
FOOMATICDB=`pwd` /usr/sbin/foomatic-preferred-driver

during the build process of foomatic-db, right after deleting the unwished driver XMLs and before "make install".

Matthias Klose (doko)
Changed in foomatic-db:
assignee: doko → nobody
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

I have packaged the epsoneplijs driver now and submitted it for inclusion in Ubuntu Linux. Here are the files for testing on Feisty:


Changed in foomatic-db:
status: Confirmed → Fix Committed
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

As the Epson EPL "L" driver ships the PPDs by itself I have removed the information for generating PPDs from foomatic-db. So the driver will not appear in the list of available printer/driver combos when it is not installed.

Changed in foomatic-db:
status: Fix Committed → Fix Released
Revision history for this message
Till Kamppeter (till-kamppeter) wrote :

Unfortunately, on the Epson EPL "L" there are some license problems which have to be solved with the upstream author. Therefore the package is not yet added to Ubuntu. It is possible that it will only go into Multiverse.

Changed in epsoneplijs:
status: Fix Committed → In Progress
Revision history for this message
NIthaiah (marcello-gorla+lunchpad) wrote :

@Till: can you check the link you posted? files are not avaliable right now

Can anyone make a .deb file for this drivers for Ubuntu 7.10?

Revision history for this message
Khashayar Naderehvandi (khashayar) wrote :

I am in dire need of this driver as well. Would anyone care to build a deb?

Revision history for this message
Ali Afshar (aafshar) wrote :

This has stopped working for me in Gutsy, see https://bugs.edge.launchpad.net/ubuntu/+source/epsoneplijs/+bug/34647/comments/4 (where it used to work). I would recommend anyone with this printer to throw it away.

Revision history for this message
Macke (macke-meteli) wrote :

Check out my solution for Hardy here:

It's a hack, but it works

Revision history for this message
Nocchy (giannipetino) wrote :

"ijs_server_epsonepl" not found in karmic distro

Changed in epsoneplijs (Ubuntu):
status: In Progress → Confirmed
Revision history for this message
Savvas Radevic (medigeek) wrote :

I've set it back to confirmed, because "on progress" did not show any progress after 2 years.
I'll test this bug one of these days to see if it can be fixed somehow.

Revision history for this message
Savvas Radevic (medigeek) wrote :

by the way, has anyone tried to install the package openprinting-ppds ?

Curtis Hovey (sinzui)
affects: epsoneplijs (Ubuntu) → mandriva
Revision history for this message
Mart Sõmermaa (mart-somermaa) wrote :

Instructions for getting the following Epson printer models working:

Epson EPL-5700L
Epson EPL-5800L
Epson EPL-5900L
Epson EPL-6100L
Epson EPL-6200L

(Based on http://ubuntuforums.org/showthread.php?t=1558950 )

1. Download http://sourceforge.net/projects/epsonepl/files/epsonepl/0.4.1/epsoneplijs-0.4.1.tgz/download

2. Assure that you have build tools installed

sudo apt-get install build-essential

3. Extract the driver source and build it

mkdir /tmp/build-epson-driver
cd /tmp/build-epson-driver
tar zxvf [DOWNLOAD LOCATION]/epsoneplijs-0.4.1.tgz

sudo make install

4. Make missing target directories

sudo mkdir -p /usr/share/cups/model/foomatic-ppds/Epson/
sudo mkdir -p /usr/share/foomatic/db/source/{driver,opt,printer}

5. Copy driver files to required locations

sudo cp -v foomatic_PPDs/Epson-EPL-*-cups.ppd.gz /usr/share/cups/model/foomatic-ppds/Epson/
sudo cp -v foomatic/driver/epl*.xml /usr/share/foomatic/db/source/driver/
sudo cp -v foomatic/opt/epsonepl-*.xml /usr/share/foomatic/db/source/opt/
sudo cp -v foomatic/printer/Epson-EPL-*.xml /usr/share/foomatic/db/source/printer

6. Copy the IJS server to the system-wide executable directory

sudo cp -v ijs_server_epsonepl /usr/bin/

7. Restart CUPS

sudo restart cups


My 5900L works well in Precise Pangolin after that.

Revision history for this message
Mart Sõmermaa (mart-somermaa) wrote :

Updated instructions for Trusty / 14.04 in addition to comment #18:

1. Download http://epsonepl.cvs.sourceforge.net/viewvc/epsonepl/epsoneplijs/?view=tar

2-6. as in comment #18 above

7. Restart CUPS (I missed 'service' in #18)

sudo service cups restart


My 5900L works in 14.04 after that.

Revision history for this message
Agent24 (tda7000) wrote :

This worked in 16.04 as well, but does not seem to function in 18.04.

The process seems to work as it did on 16.04 but when plugging in the printer, Ubuntu says it cannot find a driver for it.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.