REST access to preferences

Bug #821438 reported by benste on 2011-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Barry Warsaw
GNU Mailman REST Client
Undecided
Unassigned
MailmanwebGSoC2011
Wishlist
Unassigned

Bug Description

Using the Python bindings the following things are available at the moment:
self_link: u'http://localhost:8001/3.0/members/2'
role: u'member'
user: u'http://localhost:8001/3.0/users/2'
address': <email address hidden>'
fqdn_listname': <email address hidden>'

For better user management the following options should be seen as wishlist:

acknowledge_posts
hide_address
receive_list_copy
receive_own_postings
delivery_mode
delivery_status

in addition i requested _User.get_lists which is in https://bugs.launchpad.net/mailmanwebgsoc2011/+bug/821069

+ what about users password ? users e-mails ...

benste (benste) on 2011-08-05
Changed in mailman.client:
status: New → Confirmed
tags: added: mailman3
Changed in mailmanwebgsoc2011:
status: New → Triaged
importance: Undecided → Wishlist
Barry Warsaw (barry) on 2011-09-07
Changed in mailman:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
milestone: none → 3.0.0a8
Barry Warsaw (barry) wrote :

Actually, these are going to be interesting, because individual IMember preferences are stored in multiple places, and there's a _lookup() method that returns the first non-None value. This would probably be fine for read-only access, but if you want to write changes, where do you write them? I think that if you POST or PATCH any of the attributes, it changes them on the member directly (i.e. overriding any other value).

Barry Warsaw (barry) on 2011-09-18
summary: - REST and Client are missing membership_settings options
+ REST access to preferences
Barry Warsaw (barry) on 2011-09-23
Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-09-25
Changed in mailman:
status: Fix Committed → Fix Released
Changed in mailman.client:
status: Confirmed → Fix Committed
milestone: none → 1.0.0a1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers