Response to email approval of held message is misleading

Bug #889968 reported by Mark Sapiro on 2011-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro

Bug Description

(From a recent post to <email address hidden>)

I usually use the web interface for approving messages. But I
occasionally do it via Email. When I do, I get a response back that looks
like this:

The results of your email command are provided below. Attached is your
original message.

- Results:
     Confirmation succeeded

- Unprocessed:
     Approved: <admin password>

- Done.

---- CUT HERE -----------------------

To me at least, this suggests that the message has been rejected, not
approved, as the text says that the approval command was not processed.
I know this isn't the case because I see the message posted to the list,
but when I initially saw it, I had a panic as I thought I'd lost a message
for the list.

Is it possible to fix this so that the message is more clear about what
has happened? The "Confirmation succeeded" message is not very
explanatory, and seen in isolation doesn't really tell you anythying about
whether the message was approved or rejected.

Mark Sapiro (msapiro) wrote :

Fixed by appending (Approve) or (Discard) as appropriate to the Confirmation succeeded line and removing any Approve(d): line from the Unprocessed: list.

Changed in mailman:
status: Confirmed → Fix Committed
Mark Sapiro (msapiro) on 2012-06-15
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers