KeyError: u'outgoing' in runner

Bug #872391 reported by Stephen A. Goss
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Barry Warsaw

Bug Description

Found this in my mailman.log. It may have happened around the time I was attempting to send a message through a mailing list and the SMTP receiver (fakemail.py in this case) died, so there were some failures to deliver.

    Oct 07 16:14:47 2011 (12057) Uncaught runner exception: u'outgoing'
    Oct 07 16:14:47 2011 (12057) Traceback (most recent call last):
      File "/home/phoenix/mailman_clone/src/mailman/core/runner.py", line 138, in _one_iteration
        self._process_one_file(msg, msgdata)
      File "/home/phoenix/mailman_clone/src/mailman/core/runner.py", line 220, in _process_one_file
        keepqueued = self._dispose(mlist, msg, msgdata)
      File "/home/phoenix/mailman_clone/src/mailman/runners/retry.py", line 40, in _dispose
        config.switchboards['outgoing'].enqueue(msg, msgdata)
    KeyError: u'outgoing'

Related branches

Revision history for this message
Barry Warsaw (barry) wrote :

Thanks for the report. I think for now I'll mark this Incomplete until we get more information or a reproducible test case.

Changed in mailman:
status: New → Incomplete
Revision history for this message
Stephen A. Goss (postfuturist) wrote :

From mailman.cfg:

    [runner.out]
    class: mailman.runners.outgoing.OutgoingRunner

From switchboard.py:

    @staticmethod
    def initialize():
        """Initialize the global switchboards for input/output."""
        for conf in config.runner_configs:
            name = conf.name.split('.')[-1]
            ...
            config.switchboards[name] = Switchboard(name, path)

It looks like the name of the runner should be config.switchboards['out'], not ['outgoing']

Barry Warsaw (barry)
Changed in mailman:
status: Incomplete → Confirmed
milestone: none → 3.0.0b1
assignee: nobody → Barry Warsaw (barry)
importance: Undecided → Medium
Barry Warsaw (barry)
Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers