Undisplayed new_member_options bits are reset whenever the General Options page is submitted.

Bug #865825 reported by Mark Sapiro on 2011-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro

Bug Description

The code in Mailman/Gui/General.py for setting new_member_options doesn't take into account the fact that there might be option bits other than 'hide', 'ack', 'notmetoo' and 'nodupes' that are set, and it resets them even if the four displayed options are unchanged. This also affects bin/config_list which cannot set bits other than those 4 unless set via mlist.new_member_options =.

Mark Sapiro (msapiro) on 2011-10-04
Changed in mailman:
status: Confirmed → Fix Committed
Mark Sapiro (msapiro) on 2012-06-15
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers