Getting the roster or configuration of a nonexistent list returns a 500 from REST API.

Bug #837676 reported by Stephen A. Goss on 2011-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Barry Warsaw

Bug Description

The REST API doesn't return a 404 when the roster or configuration is requested for a nonexistent list, instead it returns a 500 due to an uncaught exception.

Stephen A. Goss (postfuturist) wrote :

Here are some tests for correct behavior which fail.

Stephen A. Goss (postfuturist) wrote :

Here is a fix.

Barry Warsaw (barry) wrote :

Nicely done, thanks. I moved the tests to unittests though.

Changed in mailman:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
milestone: none → 3.0.0a8
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-09-25
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers