Test failing: test_accepted_message_gets_posted

Bug #832404 reported by Stephen A. Goss on 2011-08-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNU Mailman
High
Barry Warsaw

Bug Description

This test seems to be failing on both Ubuntu 11.04 with Python 2.7.1 and Centos 6 with Python 2.6.5:

Failure in test test_accepted_message_gets_posted (mailman.app.tests.test_moderation.TestModeration)
Traceback (most recent call last):
  File "/usr/lib/python2.7/unittest/case.py", line 321, in run
    testMethod()
  File "/home/sgoss/launchpad/mailman/src/mailman/app/tests/test_moderation.py", line 99, in test_accepted_message_gets_posted
    """)
  File "/usr/lib/python2.7/unittest/case.py", line 503, in assertEqual
    assertion_func(first, second, msg=msg)
  File "/usr/lib/python2.7/unittest/case.py", line 496, in _baseAssertEqual
    raise self.failureException(msg)
AssertionError: 'From: <email address hidden>\nTo: <email address hidden>\nMessage-ID: <alpha>\nX-Mailman-Approved-At: Mon, 01 Aug 2005 07:49:23 -0700\nSubject: [Test] hold me\nX-BeenThere: <email address hidden>\nPrecedence: list\nList-Id: <test.example.com>\nX-Message-ID-Hash: XZ3DGG4V37BZTTLXNUX4NABB4DNQHTCP\nList-Post: <mailto:<email address hidden>>\nList-Subscribe: <http://<email address hidden>>,\n <mailto:<email address hidden>>\nArchived-At: http://lists.example.com/archives/XZ3DGG4V37BZTTLXNUX4NABB4DNQHTCP\nList-Unsubscribe: <http://<email address hidden>>,\n <mailto:<email address hidden>>\nList-Archive: <http://<email address hidden>>\nList-Help: <mailto:<email address hidden>?subject=help>\nX-MailFrom: <email address hidden>\nX-RcptTo: <email address hidden>\n\n' != u'From: <email address hidden>\nTo: <email address hidden>\nMessage-ID: <alpha>\nX-Mailman-Approved-At: Mon, 01 Aug 2005 07:49:23 -0400\nSubject: [Test] hold me\nX-BeenThere: <email address hidden>\nPrecedence: list\nList-Id: <test.example.com>\nX-Message-ID-Hash: XZ3DGG4V37BZTTLXNUX4NABB4DNQHTCP\nList-Post: <mailto:<email address hidden>>\nList-Subscribe: <http://<email address hidden>>,\n\t<mailto:<email address hidden>>\nArchived-At: http://lists.example.com/archives/XZ3DGG4V37BZTTLXNUX4NABB4DNQHTCP\nList-Unsubscribe: <http://<email address hidden>>,\n\t<mailto:<email address hidden>>\nList-Archive: <http://<email address hidden>>\nList-Help: <mailto:<email address hidden>?subject=help>\nX-MailFrom: <email address hidden>\nX-RcptTo: <email address hidden>\n\n'

tags: added: mailman3
Barry Warsaw (barry) wrote :

Although it's difficult to see (Python 2.7 will make it easier), the problem is that the timezone in X-Mailman-Approved-At doesn't match. D'oh!

Changed in mailman:
milestone: none → 3.0.0a8
assignee: nobody → Barry Warsaw (barry)
importance: Undecided → High
status: New → Confirmed
Barry Warsaw (barry) on 2011-08-24
Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-09-25
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers