Invalid roster upon initial list creation

Bug #778687 reported by Richard Wackerbarth
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Barry Warsaw

Bug Description

GNU Mailman 3.0.0a7+ (Where's My Thing?) -- bzr=7005

When executing bin/mailman create -domain=True <email address hidden>, the example-owner get populated with an entry

INSERT INTO "address" VALUES(1,'main=true','main=True','',NULL,'2005-08-01 07:49:23',1,2);

The roster should be empty.

Revision history for this message
Richard Wackerbarth (wacky) wrote :

This is caused by my bad command line.

However, it does bring up the issue that we should not accept invalid email addresses into the database.
Also, the creation date is wrong.

Barry Warsaw (barry)
Changed in mailman:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Barry Warsaw (barry)
milestone: none → 3.0.0a8
Revision history for this message
Barry Warsaw (barry) wrote :

r7020

Changed in mailman:
status: In Progress → Fix Committed
Barry Warsaw (barry)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers