REST qrunner sometimes does not exit after tests exception

Bug #770328 reported by Barry Warsaw on 2011-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Unassigned

Bug Description

When the test suite gets an exception in the REST qrunner, it sometimes prevents the qrunner from exiting. The symptom of this is that the next time you try to run the test suite, you'll get an Address In Use error early on. This is because the test suite will try to start a new REST qrunner, which wants to bind to port 9001, but that's already in use by the "zombie" qrunner.

The workaround is fairly simple. Just kill -HUP the zombie from the shell. Once it exits, the port gets freed up and the test suite will work again.

Barry Warsaw (barry) on 2011-04-28
Changed in mailman:
status: New → Confirmed
importance: Undecided → Low
Barry Warsaw (barry) on 2011-08-16
Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-08-16
Changed in mailman:
milestone: none → 3.0.0a8
Barry Warsaw (barry) on 2011-09-25
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers