Typo in add_member() prevents subscribing an email already linked to an existing user

Bug #710182 reported by Florian Fuchs
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Barry Warsaw

Bug Description

Subscribing to more than one mailing list with the same email address via the REST API raises an AssertionError in app/membership.py and and subsequently returns a 500 HTTP status code.

System Info:
Ubuntu 10.10
Python 2.6.6
Mailman 3.0.0a7 (Rev. 6976)

I added a patch file containing a test for multiple list subscriptions and a possible fix.

Cheers
Florian

Revision history for this message
Florian Fuchs (flo-fuchs) wrote :
Revision history for this message
Barry Warsaw (barry) wrote :

Confirmed, and thanks for the patch Florian. I'm going to do the test a little differently though because this is a bug in the lower level API, specifically mailman.app.membership.add_member(). It affects more than the REST API so I'm going to create a new unittest in mailman/app.

Changed in mailman:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
milestone: none → 3.0.0a7
summary: - REST API: Subribing to more then one list raises AssertionError /
- returns HTTP 500
+ Typo in add_member() prevents subscribing an email already linked to an
+ existing user
Revision history for this message
Barry Warsaw (barry) wrote :

r6977

Changed in mailman:
status: Confirmed → Fix Committed
tags: removed: rest-api
Barry Warsaw (barry)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers