mailman scan_message exception

Reported by FreqMod on 2010-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
High
Barry Warsaw

Bug Description

scan_message in mailman/app/bounces.py causes exception becuase:

    for detector_class in find_components('mailman.bouncers', IBounceDetector):
        addresses = detector().process(msg)

is not:

    for detector_class in find_components('mailman.bouncers', IBounceDetector):
        addresses = detector_class().process(msg)

I'am working around it by reimplementing the function in my code, but I would be happy if I don't need to, because it touches more internal interfaces than neccesarry.

Barry Warsaw (barry) on 2010-09-23
Changed in mailman:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
milestone: none → 3.0.0a7
tags: added: mailman3
Barry Warsaw (barry) wrote :

Thanks so much for testing Mailman 3! This bug is fixed in r6954.

Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2011-04-29
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers