list_members --fullnames kills umlauts in names

Bug #581518 reported by Jakob Unterwurzacher
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Wishlist
Unassigned

Bug Description

Running
   list_members --fullnames testlist
should output this, as seen correctly in the web interface:
   Jürgen <...@gmx.de>

Actually, it outputs:
   J?rgen <...@gmx.de>
with the umlaut ü replaced by a question mark.

description: updated
Mark Sapiro (msapiro)
Changed in mailman:
status: New → Invalid
Revision history for this message
Mark Sapiro (msapiro) wrote :

This is not a bug in list_members. list_members encodes the full names for output in the default encoding of the Python installation. If you want this to be, e.g., iso-8859-1 or utf-8 as opposed to ascii which is the normal Python default, you have to add, e.g., sys.setdefaultencoding('utf-8') to a sitecustomize.py module. See <http://docs.python.org/library/sys.html#sys.setdefaultencoding>.

For example, if you want utf-8 encoding as the Python default, you could create /usr/lib/pythonv.v/site-packages/sitecustomize.py containing the two lines:

import sys
sys.setdefaultencoding('utf-8')

Revision history for this message
Jakob Unterwurzacher (jakobunt) wrote :

Thanks, that worked!

Nice-to-have would be if list_members used the LANG setting (f.x. I have LANG=de_DE.UTF-8) to determine the output encoding to use.

Revision history for this message
Mark Sapiro (msapiro) wrote :

This is really still a Python request, but I changed it back to New->Wishlist per comment #2.

Changed in mailman:
importance: Undecided → Wishlist
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers