Mistakes in mailman strings.

Reported by Chuck Short on 2009-09-09
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Undecided
Mark Sapiro
mailman (Ubuntu)
Low
Unassigned

Bug Description

Hi,

This was recently reported in launchpad. If you have any questions please let me know.

http://bugs.launchpad.net/bugs/61939

    _('''You have regular list members but non-digestified mail is
    turned off. They will receive mail until you fix this
    problem.'''), tag=_('Warning: '))
That doesn't sound like a problem. Missing "not"?

    Label(_('Send welcome messages to new subscribees?')),
I haven't found "subscribee" in any dictionary, but I think it means "publisher", or in the context of mailman "list owner". This message should say "subscribers".

    _('Sender discarded message via web.'))
Missing "the"

    doc.AddItem(Header(3,_("Can't have empty html page.")))
Missing "an", "html" not in capitals.

    table.AddRow([_("""This page allows you as the list owner, to permanent
    remove this mailing list from the system. <strong>This action is not
s/permanent/permanently/

    'You can access your personal options via the following url:')
"url" not in capitals.

    _('''An introductory description - a few paragraphs - about the
    list. It will be included, as html, at the top of the listinfo
    page. Carriage returns will end a paragraph - see the details
    for more info.'''),
"html" not in capitals.

    _("""When a new member is subscribed to this list, their initial
    set of options is taken from the this variable's setting.""")),
"the this"?

    <p>When personalization is enabled, a few more expansion
    variables that can be included in the <a
    href="?VARHELP=nondigest/msg_header">message header</a> and
    <a href="?VARHELP=nondigest/msg_footer">message footer</a>.
extra "that"

    <li><b>user_optionsurl</b> - The url to the user's option
"url" not in capitals.

    _("""When a message is posted to the list, a series of
    moderation steps are take to decide whether the a moderator must
    first approve the message or not. This section contains the
    controls for moderation of both member and non-member postings.
"are take" should be "are taken". "the a" should be "a"

    If you spell the list name as just `mylist', then the email hostname will be
    taken from DEFAULT_EMAIL_HOST and the url will be taken from DEFAULT_URL (as
    defined in your Defaults.py file or overridden by settings in mm_cfg.py).
"url" not in capitals.

Related branches

Download full text (4.8 KiB)

Chuck Short wrote:
>
>This was recently reported in launchpad. If you have any questions
>please let me know.
>
>http://bugs.launchpad.net/bugs/61939
>
> _('''You have regular list members but non-digestified mail is
> turned off. They will receive mail until you fix this
> problem.'''), tag=_('Warning: '))
>That doesn't sound like a problem. Missing "not"?

Confirmed. Will fix.

> Label(_('Send welcome messages to new subscribees?')),
>I haven't found "subscribee" in any dictionary, but I think it means "publisher", or in the context of mailman "list owner". This message should say "subscribers".

Actually, I think this usage is correct. See for example
<http://dictionary.reference.com/browse/-ee>. For a transitive verb in
English, (verb)-er refers to the subject of the verb and (verb)-ee
refers to the object. In this case - admin Mass Subscribe - the admin
is the subscriber and the people being subscribed are the subscribees.

> _('Sender discarded message via web.'))
>Missing "the"

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2.

> doc.AddItem(Header(3,_("Can't have empty html page.")))
>Missing "an", "html" not in capitals.

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2.

> table.AddRow([_("""This page allows you as the list owner, to permanent
> remove this mailing list from the system. <strong>This action is not
>s/permanent/permanently/

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2.

> 'You can access your personal options via the following url:')
>"url" not in capitals.

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2.

> _('''An introductory description - a few paragraphs - about the
> list. It will be included, as html, at the top of the listinfo
> page. Carriage returns will end a paragraph - see the details
> for more info.'''),
>"html" not in capitals.

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2.

> _("""When a new member is subscribed to this list, their initial
> set of options is taken from the this variable's setting.""")),
>"the this"?

Will fix

> <p>When personalization is enabled, a few more expansion
> variables that can be included in the <a
> href="?VARHELP=nondigest/msg_header">message header</a> and
> <a href="?VARHELP=nondigest/msg_footer">message footer</a>.
>extra "that"

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2. (Note that the
translated string in this case is 5 paragraphs long and removing this
one word breaks the entire translation.)

> <li><b>user_optionsurl</b> - The url to the user's option
>"url" not in capitals.

True, but I don't think the change is significant enough to warrant
breaking translations. I'll consider for Mailman 2.2. Also see remark
above, at least for the first o...

Read more...

Mark Sapiro (msapiro) on 2009-09-10
Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
status: New → In Progress
Dave Walker (davewalker) wrote :

Hi, I just wondered if there was any progress with this issue?

Thanks.

Mark Sapiro (msapiro) wrote :

I have done nothing further. It is on my ToDo list, for at least the two items I commented 'Will fix', but upon re-reading, the first of these Is not missing "not". The message is badly worded, but it is the message that is issued when a list with regular members is set to nondigestable = No (meaning one must subscribe in digest mode). It is trying to say the the existing regular members will continue to receive individual messages, so although badly worded, it isn't really wrong.

However, since writing comment #1, I have found that the "fuzzy matching" of msgmerge can allow minor corrections without totally breaking the translation, so I may yet do more on this.

Mathias Gug (mathiaz) on 2010-08-12
Changed in mailman (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Mark Sapiro (msapiro) on 2010-09-10
Changed in mailman:
milestone: none → 2.1.14
Mark Sapiro (msapiro) wrote :
Download full text (3.9 KiB)

I have made some changes and ignored others for the 2.1.14 release. Here's a summary.

--------------------------------------------
 _('''You have regular list members but non-digestified mail is
 turned off. They will receive mail until you fix this
 problem.'''), tag=_('Warning: '))

changed to

 _('''You have regular list members but non-digestified mail is
 turned off. They will receive non-digestified mail until you
 fix this problem.'''), tag=_('Warning: '))
--------------------------------------------
 Label(_('Send welcome messages to new subscribees?')),

not changed per comment #1.
--------------------------------------------
 _('Sender discarded message via web.'))

not changed. It's terse, but OK I think.
--------------------------------------------
 doc.AddItem(Header(3,_("Can't have empty html page.")))

not changed. It's terse, but OK I think.
--------------------------------------------
 table.AddRow([_("""This page allows you as the list owner, to permanent
 remove this mailing list from the system. <strong>This action is not

changed to

 table.AddRow([_("""This page allows you as the list owner, to permanently
 remove this mailing list from the system. <strong>This action is not
--------------------------------------------
 'You can access your personal options via the following url:')

not changed.
--------------------------------------------
 _('''An introductory description - a few paragraphs - about the
 list. It will be included, as html, at the top of the listinfo
 page. Carriage returns will end a paragraph - see the details
 for more info.'''),

not changed.
--------------------------------------------
 _("""When a new member is subscribed to this list, their initial
 set of options is taken from the this variable's setting.""")),

changed to

 _("""When a new member is subscribed to this list, their initial
 set of options is taken from this variable's setting.""")),
--------------------------------------------
 <p>When personalization is enabled, a few more expansion
 variables that can be included in the <a
 href="?VARHELP=nondigest/msg_header">message header</a> and
 <a href="?VARHELP=nondigest/msg_footer">message footer</a>.

changed to

 <p>When personalization is enabled, a few more expansion
 variables can be included in the <a
 href="?VARHELP=nondigest/msg_header">message header</a> and
 <a href="?VARHELP=nondigest/msg_footer">message footer</a>.
--------------------------------------------
 <li><b>user_optionsurl</b> - The url to the user's option

not changed.
--------------------------------------------
 _("""When a message is posted to the list, a series of
 moderation steps are take to decide whether the a moderator must
 first approve the message or not. This section contains the
 controls for moderation of both member and non-member postings.

This was changed to

 _("""When a message is posted to the list, a series of
 moderation steps are taken to decide whether a moderator must
 first approve the message or not. This section contains the
 controls for moderation of both member and non-member postings.

in Mailman 2.1.12 per bug # 309757
--------------------------------------------
 If you spell t...

Read more...

Mark Sapiro (msapiro) on 2010-09-11
Changed in mailman:
status: In Progress → Fix Committed
Barry Warsaw (barry) on 2010-09-21
Changed in mailman:
status: Fix Committed → Fix Released
Thijs Kinkhorst (kink) wrote :

2.1.14

Changed in mailman (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers