Fix to fallback of thread by subject

Bug #266572 reported by Stuartd on 2002-01-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Mark Sapiro

Bug Description

The existing code in HyperDatabase.py looks like it
was intending to fallback to threading by subject if
the In-Reply-To and References headers were missing.

However the implementation it is broken, apparently
an incomplete port of some other module.

This patch fixes the set_location() method, and
getOldestArticle methods to allow subject threading
to once again work.

Note: pipermail.py has an unused database class which
also implements broken versions of these methods. This
patch does not fix those because they were unused.

[http://sourceforge.net/tracker/index.php?func=detail&aid=509269&group_id=103&atid=300103]

Related branches

Thomas Wouters (thomas) wrote :

This patch looks like it still applies, but just looking at
this code makes my hea d go *splat*. Can you confirm that
this is still an issue for Mailman 2.1, and this is still
the correct fix ?

Jean.c.h (slug71) wrote :

Marked this bug as 'Invalid' due to its age and nothing further has been added in a long time. New versions have been released since as well as some underlying stuff in the OS platform itself.

If this bug still affects then please change status back to 'Confirmed'.

Changed in mailman:
status: New → Invalid
Richard Tew (richard-m-tew) wrote :

Oops

Changed in mailman:
status: Invalid → Confirmed
status: Confirmed → Invalid
Mark Sapiro (msapiro) wrote :

This bug is still valid, but the patch is incomplete at best.

Preliminary testing shows that with the patch, rebuilding the archive with bin/arch --wipe works generally as expected, but individual posts without In-Reply-To: headers are still not threaded by Subject if the list has a subject_prefix. This appears to be the case whether or not the prefix is included in the reply as sent. The posts are unthreaded in the archive until the archive is rebuilt with bin/arch --wipe.

Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
milestone: mailman-2.0.x → 2.1-stable
status: Invalid → Triaged
Mark Sapiro (msapiro) wrote :

Fixed at rev 1220 on the 2.1 branch and rev 1093 on the 2.2 branch.

The fix is probably still incomplete. I think there will still be issues when long subjects are folded and unfolded. A possible fix is to remove all white space from 'stripped' subjects or maybe replace all runs of whitespace with a single space.

Changed in mailman:
status: Triaged → Fix Committed
Mark Sapiro (msapiro) on 2010-09-21
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers