Archive indexer control to improve index

Bug #266553 reported by Ppsys
2
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Barry Warsaw

Bug Description

This patch is applicable to Mailman 2.0.6 release and
supercedes ealier patches 401669 and 402422.

This patch should improve the quality of search
results returned by search engines
such as htdig (http://www.htdig.org) where the seach
engine's index builder responds
to strings embedded in the html pages that are the
subject of the indexing. The
changes in this patch:

1. allow strings for enabling and disabling indexing
to be defined in mm_cfg.py.

2. embeds those strings in the pages generated as the
html version of a list's
   archive.

By default nothing in the html changes. To get the
desired effect, you must
define ARCHIVE_INDEXING_ENABLE and
ARCHIVE_INDEXING_DISABLE in mm_cfg.py

You probably want to run this patch as follows:

cd <mailman 2.0.6 untarred and unzipped directory>
patch -p1 < <this patch file>

See also the associated patch for integrating the
htdig search software with mailman's internal archiver
ouput.

[http://sourceforge.net/tracker/index.php?func=detail&aid=444879&group_id=103&atid=300103]

Revision history for this message
Ppsys (ppsys) wrote :
Revision history for this message
Ppsys (ppsys) wrote :

This patch should also apply without problems to MM 2.0.7

Revision history for this message
Ppsys (ppsys) wrote :

This patch should also apply without problems to MM 2.0.8

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1a3-0.1.patch is a revised version of the patch that is
compatible with the code published in
mailman-2.1a3.tgz on sourceforge.

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1cvs-20011217.patch is a revised version of the
patch that is compatible with the code published in mailman
CVS on sourceforge as 11:50 GMT 17 Dec 2001

Revision history for this message
Bug Importer (bug-importer) wrote :

When applying this patch I get an error with Hunk 1 and
Defaults.py is not updated. This happens with the a clean
download of the latest cvs installation (5 Mar 2002). Any
ideas what the problem is?

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1cvs-20020306.patch is a revised version of the patch that is
compatible with the code
published in mailman CVS on sourceforge as 12:30 GMT 6 Mar 2002.

Corrects problem noted or 5 Mar 2002 by nobody

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.9-0.1.patch is a revised version of the patch
that is compatible with MM 2.0.9

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.9-0.1.patch should apply without problems to
MM 2.0.10

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.11-0.1.patch is a revised version of the patch
that is compatible with MM 2.0.11

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.11-0.1.patch should apply without problems to
MM 2.0.12

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.13-0.1.patch is purely cosmetic to get no
mumble application to MM 2.0.13

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1b2-0.1.patch is a revised version of the patch
that is compatible with MM 2.1b2

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.0.13-0.2.patch just adds a GPL notice to the patch

Revision history for this message
Barry Warsaw (barry) wrote :

Looking at the 2.1b2 patch, why does it try to create
HyperArch.py.orig and Defaults.py.in.orig? Are those
included in the patch by mistake?

Revision history for this message
Barry Warsaw (barry) wrote :

Another question: is there no standard (de-facto or
otherwise) for generic markup that tells indexers not to
index a particular section? IOW, for
ARCHIVE_INDEXING_ENABLE and ARCHIVE_INDEXING_DISABLE, is
there some generic value that would instruct most (all?)
indexers to ignore that section? Or does it necessarily
have to be indexer specific?

I'm thinking of the situation where you might have ht://Dig
installed locally, but your archives are still being
spidered by external indexers. It would be good if
something more generic could be added to Defaults.py.in

Revision history for this message
Ppsys (ppsys) wrote :

An error when building the indexing-2.1b2-0.1.patch meant
that copies of the originals of two of the files modified by this
version of the patch were added when the patch was run.
indexing-2.1b2-0.1.patch removes this error. However, the
original error is benign and can be corrected by deleting the
extra files HyperArch.py.orig and Defaults.py.in.orig.

An additional file, README.NOINDEXtags is added that
discusses the issue of what tags to use for controlling various
search engine indexers.

Revision history for this message
Ppsys (ppsys) wrote :

An additional file, README.NOINDEXtags is added to
indexing-2.0.13-0.3.patch version that discusses the issue of
what tags to use for controlling various search engine
indexers.

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1b3-0.1.patch is a revised version of the patch
that is compatible with MM 2.1b3

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1b4-0.1.patch is a revised version of the patch
that is compatible with MM 2.1b4

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1b5-0.1.patch is a revised version of the patch
that is compatible with MM 2.1b5

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1b6-0.1.patch is a revised version of the patch
that is compatible with MM 2.1b6

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1-0.1.patch is a revised version of the patch
that is compatible with MM 2.1.

Before applying this patch to the MM 2.1 source distribution
you must apply patch 661138 (corrects defects in some
HTML templates) to the distribution

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.1-0.1.patch.gz introduces no functional change
but applies without offset warnings to MM 2.1.1

Before applying this patch to the MM 2.1 source distribution
you must apply patch 661138 (corrects defects in some
HTML templates) to the distribution

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.2-0.1.patch.gz is revised for MM 2.1.2
compatibility.

Before applying thisversion of the patch you must also apply
Bug fix patch #728836 to the source distribution

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.2-0.1.patch.gz no longer needs patch #661138
to be applied as that patch was incorporated in the MM 2.1.2
release

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.3-0.1.patch is a MM 2.1.3 compatible version of
the patch

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.4-0.1.patch is a MM 2.1.4 compatible version of the
patch

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.5-0.1.patch.gz is a MM 2.1.5 compatible version of the patch

Revision history for this message
Ppsys (ppsys) wrote : Patch revised for MM 2.1.5 compatibility

Other attachments

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.6-0.1.patch.gz is a MM 2.1.6 compatible version of the patch

Revision history for this message
Ppsys (ppsys) wrote : Patch revised for MM 2.1.7 compatibility

Other attachments

Revision history for this message
Ppsys (ppsys) wrote :

Use indexing-2.1.7-0.1.patch.gz for both MM 2.1.7 and MM 2.1.8

Revision history for this message
Ppsys (ppsys) wrote :

indexing-2.1.9-0.1.patch is a MM 2.1.9 compatible version of the

Revision history for this message
Ppsys (ppsys) wrote :

Originator: YES

File Added: indexing-2.1.10-0.1.patch.gz

Revision history for this message
Jean.c.h (slug71) wrote :

Marked this bug as 'Invalid' due to its age and nothing further has been added in a long time. New versions have been released since as well as some underlying stuff in the OS platform itself.

If this bug still affects then please change status back to 'Confirmed'.

Changed in mailman:
status: Confirmed → Invalid
Revision history for this message
Mark Sapiro (msapiro) wrote :

It's not a bug, it's a patch, and it's still relevant.

Changed in mailman:
status: Invalid → Confirmed
Revision history for this message
Mark Sapiro (msapiro) wrote :

More recent versions of this patch can be found at <http://www.openinfo.co.uk/mm/index.html> and <http://www.msapiro.net/mm/>.

To post a comment you must log in.