respond_to_post_requests is not configurable but should be

Bug #266051 reported by Mixonx on 2004-04-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro
Nominated for 2.1 by Cedders
Nominated for 2.2 by Cedders

Bug Description

One can choose to send mail to poster when their
posting is held for approval. To turn this on/off,
respond_to_post_requests is set or unset.
According to the comments in mailman/Mailman/MailList.py,
respond_to_post_requests is configurable (as list
default in Defaults.py as well as in mm_cfg.py), but it
isn't.

<--- snip
288 # This stuff is configurable
289 self.respond_to_post_requests = 1
---> snap

See attached patches to fix this.

Using Mailman version 2.1.4 from Debian Backport
2.1.4-1.backports.org.1
But this appears in the latest 2.x CVS-tree, too.

Thank you for mailman development.

[http://sourceforge.net/tracker/index.php?func=detail&aid=930055&group_id=103&atid=100103]

Mixonx (mixonx) wrote :
Cedders (cedric-gn) wrote :

I want to bump this - the patch was apparently never applied in 2.1 or 2.2.

I also suggest that once DEFAULT_RESPOND_TO_POST_REQUESTS is implemented, the entry in Defaults.py is actually
  DEFAULT_RESPOND_TO_POST_REQUESTS = No

because GNU Mailman is currently blamed for backscatter and the value of the response to the poster is questioned. See for example:
http://mail-archives.apache.org/mod_mbox/spamassassin-users/200906.mbox/browser

Cedders (cedric-gn) wrote :

That reference wasn't the most helpful - I meant http://www.nabble.com/Re%3A-Dealing-with-backscatter-p24138669.html

Mark Sapiro (msapiro) wrote :

We are painfully aware of the backscatter issues with Mailman. This will be addressed in Mailman 2.2, but probably not in 2.1.

Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
status: New → Confirmed
Mark Sapiro (msapiro) on 2011-02-07
Changed in mailman:
milestone: 2.1-stable → 2.1.15
status: Confirmed → In Progress
Mark Sapiro (msapiro) on 2011-02-07
Changed in mailman:
status: In Progress → Fix Committed
Mark Sapiro (msapiro) on 2012-06-15
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers