virtual-mailman is missing domain entry

Bug #266043 reported by Bytemaster
2
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Unassigned

Bug Description

I've configured mailman-2.1.1-5 (RH9 RPM) according to
README.POSTFIX.

Support for a Postfix-style virtual domain in general
looks like:
virtual.domain anything (right-hand content
does not matter)
<email address hidden> address1
<email address hidden> address2, address3
...

But Mailman is not adding the domain entry at the start
of the virtual-mailman file, which is required for
Postfix-style virtual domains.
This means that mm is configuring a sendmail-style
domain. That's not what we want. I had to add the
virtual.domain line by myself, because otherwise
Postfix does not accept mails sent to virtual.domain.
Is there already a fix? I assume that mm will always
overwrite my edited virtual-mailman when a new list is
added.

[http://sourceforge.net/tracker/index.php?func=detail&aid=915075&group_id=103&atid=100103]

Revision history for this message
Bytemaster (bytemaster) wrote :

Since genaliases in fact owerwrites always the entire file,
Postfix-style virtual domains are really broken in mailman 2.1.1

Revision history for this message
Mark Sapiro (msapiro) wrote :

Current Postfix allows specification of the domain in virtual_alias_domains so the "domain anything" line is not needed in virtual-mailman.

Changed in mailman:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers