Text and link colors in web interface

Bug #265627 reported by Hramrach-users on 2002-04-08
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro

Bug Description

It seems there is background color set to white but no
text or link color is specified in the CGI output. I
encountered this on several MailMan pages and the admin
I contacted told me it is default setup.
So imagine completely legal browser setup where default
colors are white on blue. If you change that blue, you
should chnange the white as well or your pages arent
readable.

[http://sourceforge.net/tracker/index.php?func=detail&aid=541049&group_id=103&atid=100103]

Barry Warsaw (barry) wrote :

The colors aren't easily configured in MM2.0.x, but that has
been fixed for MM2.1

Mihai Capotă (mihaic) wrote :

Barry Warsaw wrote on 2002-04-10:
>The colors aren't easily configured in MM2.0.x, but that has
>been fixed for MM2.1
What has been fixed for MM2.1? The default colors or the reconfigurability?
I can still see this problem in 2009 on many sites. Are the default colors fixed in the latest version of Mailman?

qubodup (qubodup) wrote :

Please fix this.

The solution is simple:

- <BODY BGCOLOR="#ffffff">
+ <BODY BGCOLOR="#ffffff" COLOR="#000000">

I only do not know what file.

Mark Sapiro (msapiro) wrote :

The BODY tag has no COLOR attribute. The relevant attributes are TEXT, LINK, ALINK and VLINK.

The existing BODY tags are generated by htmlformat.py for generated pages and also coded in the following templates for pages built from those templates.

admlogin.html
archidxhead.html
archtoc.html
archtocnombox.html
article.html
emptyarchive.html
listinfo.html
options.html
private.html
roster.html
subscribe.html

The question is what to do to fix this.

Clearly, There should be a WEB_TEXT_COLOR setting in Defaults.py and code in htmlformat.py to process it, but is just making the default "black" and unconditionally adding TEXT= to all the BODY tags the right thing to do?

Current code does not add LINK=, ALINK= or VLINK= attributes to the BODY tag unless they are defined non-empty. Changing this is likely to be disruptive.

Another possible solution is to remove BGCOLOR= from the BODY tags, but this too can be disruptive.

I am interest in receiving feedback on the best way to deal with this.

Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
status: Fix Released → Confirmed

On Thu, Oct 08, 2009 at 08:22:44PM -0000, Mark Sapiro wrote:
> The question is what to do to fix this.

If anything...

> I am interest in receiving feedback on the best way to deal with this.

leave it for MM3? (or, perhaps MM2?)

Perhaps another way may be to allow a config option in mm_cfg.py to
specify a CSS file, (i) for the site, (ii) to enable customization by
listadmins, which, if it (a) is specified, and (b) exists, is
parsed/included by the web-page-generating-scripts. (and perhaps ship
an example CSS file in examples/)

Michal Suchanek (hramrach) wrote :

2009/10/8 Adam McGreggor <email address hidden>:
> On Thu, Oct 08, 2009 at 08:22:44PM -0000, Mark Sapiro wrote:
>> The question is what to do to fix this.
>
> If anything...
>
>> I am interest in receiving feedback on the best way to deal with this.
>
> leave it for MM3? (or, perhaps MM2?)
>
> Perhaps another way may be to allow a config option in mm_cfg.py to
> specify a CSS file, (i) for the site, (ii) to enable customization by
> listadmins, which, if it (a) is specified, and (b) exists, is
> parsed/included by the web-page-generating-scripts. (and perhaps ship
> an example CSS file in examples/)
>
> --
> Text and link colors in web interface
> https://bugs.launchpad.net/bugs/265627
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in GNU Mailman: Confirmed
>
> Bug description:
> It seems there is background color set to white but no
> text or link color is specified in the CGI output. I
> encountered this on several MailMan pages and the admin
> I contacted told me it is default setup.
> So imagine completely legal browser setup where default
> colors are white on blue. If you change that blue, you
> should chnange the white as well or your pages arent
> readable.
>

bgcolor on body is obsolete, it should be dropped. It should resolve
the current problem, too.

For style customization a link to external CSS should be added. A
default (could be even empty) CSS should be installed and site admins
can customize the look by editing this CSS.

Thanks

Slef (slef) wrote :

Michal Suchanek wrote:
> bgcolor on body is obsolete, it should be dropped. It should resolve
> the current problem, too.
>
> For style customization a link to external CSS should be added. A
> default (could be even empty) CSS should be installed and site admins
> can customize the look by editing this CSS.

That would be the best fix, in my opinion.

Thanks for chasing this up!
--
MJR/slef
My Opinion Only: see http://people.debian.org/~mjr/

Michal Suchanek (hramrach) wrote :

This patch should fix the issue with inivisible text.

It does not make the templates any better (eg. valid HTML, styleable, ...)

Mark Sapiro (msapiro) wrote :

The patch at comment #8 addresses only the residual templates that have not yet been removed from the 3.0 development branch against which the patch applies. The web interface is being completely redone for Mailman 3 and these templates almost certainly won't be part of it.

For Mailman 2.1, the patch does not directly apply, does not address those pages not built from templates and ignores the concerns expressed in comment #4.

In short, this will most likely not be fixed in the 2.1 branch. It will be fixed in Mailman 3.

Michal Suchanek (hramrach) wrote :

This is a patch for 2.1 branch.

Michal Suchanek (hramrach) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers