Python 2.7 dependency in Utils.banned_ip()

Bug #1775233 reported by Yasuhito FUTATSUKI at POEM
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Mark Sapiro

Bug Description

Utils.banned_ip() introduced at rev 1762 has Python 2.7 dependency.

The feature allows to ommit positional argument specifiers of str.format() appeared in Python 2.7.

Related branches

Revision history for this message
Yasuhito FUTATSUKI at POEM (futatuki) wrote :
Revision history for this message
Mark Sapiro (msapiro) wrote :

I would really like to answer this by saying Python 2.7 is required, but since I have another change to this code in progress, I'll fix it.

Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
importance: Undecided → Low
milestone: none → 2.1.27
status: New → In Progress
Mark Sapiro (msapiro)
Changed in mailman:
status: In Progress → Fix Committed
Mark Sapiro (msapiro)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers