Mailman 2.1.22+ requires Python 2.7

Bug #1740543 reported by Mark Sapiro
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Low
Mark Sapiro

Bug Description

While we have been strongly recommending Python 2.7 for some time, it has not been listed as a requirement. Mailman 2.1.22 introduced a call to re.sub() with a flags= argument that requires Python 2.7. The code in question will only be executed when archiving a message with no Date: header containing a valid date and no X-List-Received-Date: header containing a valid date which will almost certainly only occur when bin/arch is processing a mbox containing such a message, so this is of minor importance, but is easily fixed so I'll fix it.

Related branches

Mark Sapiro (msapiro)
description: updated
Changed in mailman:
status: In Progress → Fix Committed
Mark Sapiro (msapiro)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers