A bounced probe can throw AttributeError

Bug #1482940 reported by Mark Sapiro
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro

Bug Description

If the site has set 'VERP_PROBES = Yes', when a user's bounce score reaches threshold, that user's score is reset and a probe message with a confirmation token is sent to the user. If the probe bounces, the user's delivery is disabled by bounce.

The issue is if the probe bounces, but for some reason, the bounce is not returned within bounce_info_stale_after days, the user's bounce_info can be deleted before the probe bounce is returned. Then the probe processing gets the user's bounce_info which is None and attempts to disable the member's delivery with bounce_info = None, and disableBouncingMember attempts to get the cookie attribute from None resulting in

AttributeError: 'NoneType' object has no attribute 'cookie'

Related branches

Mark Sapiro (msapiro)
Changed in mailman:
status: In Progress → Fix Committed
Mark Sapiro (msapiro)
Changed in mailman:
milestone: 2.1.21 → 2.1.21rc1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers