GetLive config should use mode=200810

Bug #297774 reported by Adolfo González Blázquez on 2008-11-13
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mail Notification
Undecided
Unassigned

Bug Description

Because Hotmail has changed its web recently, GetLive has made some changes in the code to support this. So mail-notification should use mode=200810 in the GetLive config file it creates to support new hotmail interface.

pvdeynse (vandeynse) wrote :

this is correct the mail-notification GetLive interface does not support the added parameter "mode = 200810" needed for the recent changes made by hotmail. In the main time I solved the problem by changing line 82 in the GetLive (Rev 1.46)
         change from:
                           my $Mode = "200809";

         change to:
                          my $Mode = "200810";

If you don't have GetLive (Rev 1.46) for example users of Ubuntu 8.10 the getlive package 0.57-1 still uses getlive (Rev 1.43) then you can find the perl script here:
                                   http://getlive.cvs.sourceforge.net/viewvc/getlive/GetLive/
download "GetLive.pl" (Rev 1.46) and overwrite your /usr/bin/GetLive

Wolter Hellmund (wolterh) wrote :

Ah well, its giving problems again. I use it from mail-notification and updating the Live Mail account returns an unhandled exception.

pvdeynse (vandeynse) wrote :

I have no problems, I'm using GetLive (Rev 1.48) together with Mail-Notification 5.4 and Ubuntu 9.04

Also don't forget to add/modify "/usr/bin/GetLive" script with:
            my $Mode = "200902";

my ".getliverc" file is:

    UserName = xxxxxxxx
    Password = xxxxxxxx
    Domain = hotmail.com
    FetchOnlyUnread = Yes
    RetryLimit = 3
    Processor = /bin/cat - >> FetchedMail
    MarkRead = No
    Mode = 200902

Wolter Hellmund (wolterh) wrote :

How did you install your getlive? I don't have any .getliverc files at home.

Wolter Hellmund (wolterh) wrote :

Nevermind, I edited my GetLive script as you said, and added a .getliverc file at home. Now it all works. The only thing is that I--nor nobody I can think of--want to keep a file in my home dir with my hotmail password and all.

pvdeynse (vandeynse) wrote :

sorry, my mistake, you don't need ".getliverc" when using mail-notification, mail-notification is handling login and password. All you need is to make sure you have:
                   - getlive (Rev 1.48)
                   - make sure you have a file "/usr/bin/GetLive" because thats what mail-notification is looking for !
                   - make sure you modify "/usr/bin/GetLive" to read:
                                                                            my $Mode = "200902";

Wolter Hellmund (wolterh) wrote :

Ok, perfect. Yes, I just deleted my .getliverc file and everything works perfect also.

raul (deuiadra) wrote :

I've trying to get it right but it seems that doesn't work for me. I hope somebody could help me.

I've Ubuntu 9.04, mail-notification 5.4 and that's what I've tried:

- installed getlive package from Synaptic Package Manager version 0.58~cvs20081219-1
- replaced the file /usr/bin/GetLive 1.46 for the 1.48
- modified $Mode 200809 for 200902

Then, when I try to set a new hotmail account I get:

unhandled Windows Live Hotmail mailbox (cannot execute "GetLive": Failed to execute child process "GetLive" (Permission denied))

What am I doing wrong? Any recommendation?

pvdeynse (vandeynse) wrote :

you need to set proper permission rights for file "/usr/bin/GetLive"

here is what i have on my system :
-rwxr-xr-x 1 root root 59980 2009-02-19 00:31 /usr/bin/GetLive

raul (deuiadra) wrote :

now it's working! thanks!

caiooiac (caiobalu) wrote :

Hello guys, I have the exact same problem as raul. I did the same things but I didn't understand is I should I how to set the permission.
I don't even know were I can find the place to change it...

I someone knows how to help me, I would appreciate.

Thanks a lot

billybag (dpshfbfb) wrote :

I get "unhandled Windows Live Hotmail mailbox (unknown GetLive failure)

I followed everyone's advice. Installed GetLive, Replaced with 1.48. hanged 809 to 902. set permissions.

...

Donald Broatch (donaldbroatch) wrote :

There's conflicting information here.

Do I use 1.46 or 1.48? $Mode = "200810" or $Mode = "200902"?

I can't seem to get mail-notification to work with Hotmail using any combination.

(Ubuntu 9.10)

pvdeynse (vandeynse) wrote :

I'm currently using Ubuntu 9.10 with getlive (Rev 1.49) together with modification
                 $Mode = "200909"

I see that getlive is currently at (Rev 1.51)
     http://getlive.cvs.sourceforge.net/viewvc/getlive/GetLive/

Donald Broatch (donaldbroatch) wrote :

$Mode = "200909" works for me!

I have the 1.51 script.

Where does this $Mode number come from? MS must be changing it from time to time- where can we find the current setting if GetLive fails to work again the next time $Mode changes?

pvdeynse (vandeynse) wrote :

all requests,bugs,status, follow-up,forum,mailing list,patches can be found at the official GetLive develop web-site:

                               http://sourceforge.net/projects/getlive/develop/

glerinand (glerinand) wrote :

Hi, now i've working mail-notification and GetLive ...How?

I don't need ~/.getliverc
I change /usr/bin/getlive on line 84: my $Mode = "200902"

and...

I do:
# ln /usr/bin/getlive /usr/bin/GetLive

Because my error message say: " ...GetLive... " and my file was " getlive "

I hope to help you and I hope understand my horrible english.

glerinand (glerinand) on 2009-12-13
Changed in mail-notification:
status: New → In Progress
guisardo (ubuntu-lucasmrancez) wrote :

Hi all. In the last version of getlive (rev 1.55) I can see that you can configure the Mode from the --config-file. So now is up to mail-notification to use the appropriate one. Be aware that, looking the revision date, new modes appear very often. At this time the working mode for version 1.55 is 201003.

And for all the newbies like myself that don't know where to get the last mode number... is inside the GetLive.pl, in the foot notes, which are the revision note. See the newest revision description.
Regards

acidrums4 (acidrums4) wrote :

I am trying to get working mail-notification and Getlive, but it fails. I change the mode to 201003 and tried also with 201002, but the result is the same.

I ran 'mail-notification -i' from a terminal and here is the output:

< GetLive died with message: 'Page doesn't contain FormStart as expected. at /usr/bin/GetLive line 617.'.

Any ideas?

acidrums4 (acidrums4) wrote :

Also I'm getting this:

< GetLive died with message: 'Could not correctly parse the messages table. at /usr/bin/GetLive line 1192.'.

guisardo (ubuntu-lucasmrancez) wrote :

I'm still using version 1.55 (mode="201003") and seems to work just fine....
Make sure that you have the last file version. You can get it from here:
http://getlive.cvs.sourceforge.net/viewvc/getlive/GetLive/

Regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers