evolution 2.23.5 crashes on startup

Reported by Götz Waschk on 2008-07-23
138
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Mail Notification
High
Unassigned
mail-notification (Mandriva)
Fix Released
Undecided
Unassigned
mail-notification (Ubuntu)
High
Unassigned
Nominated for Intrepid by Hew McLachlan

Bug Description

This is on Mandriva Cooker i586 with mail-notification 5.4 built against evolution-data-server 2.23.5. and evolution 2.23.5. Evolution crashes on startup with the following backtrace:
#0 camel_message_info_uint32 (mi=0x8b5ee80, id=5)
    at camel-folder-summary.c:4228
#1 0xb2e7f26e in ?? ()
   from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
#2 0x08b5ee80 in ?? ()
#3 0x00000005 in ?? ()
#4 0x08e06a48 in ?? ()
#5 0xb768a0bc in IA__g_type_value_table_peek (type=68) at gtype.c:3893
#6 0xb2e8059c in ?? ()
   from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
#7 0x00000044 in ?? ()
#8 0x08c4ed60 in ?? ()
#9 0x08e2fd10 in ?? ()
#10 0x00000000 in ?? ()

SRU STATEMENT:
mail-notification 5.4.dfsg.1-1build1 in Intrepid causes Evolution to crash. This bug has been fixed in mail-notification 5.4.dfsg.1-1ubuntu1, which is a relatively small patch.

TEST CASE:
Run mail-notification 5.4.dfsg.1-1build1, then open Evolution and observe the crash. When using mail-notification 5.4.dfsg.1-1ubuntu1, this crash does not occur.

Götz Waschk (waschk-mandriva) wrote :

Here's a better backtrace:
Program received signal SIGSEGV, Segmentation fault.
camel_message_info_uint32 (mi=0x9d98ff8, id=5) at camel-folder-summary.c:4228
4228 return ((CamelFolderSummaryClass *)((CamelObject *)mi->summary)->klass)->info_uint32(mi, id);
(gdb) bt
#0 camel_message_info_uint32 (mi=0x9d98ff8, id=5)
    at camel-folder-summary.c:4228
#1 0xb36131e7 in ?? ()
   from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
#2 0xb3613519 in dbus_glib_marshal_mn_evolution_server_BOOLEAN__STRING_POINTER_POINTER ()
   from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
#3 0xb685566c in ?? () from /usr/lib/libdbus-glib-1.so.2
#4 0xb6dcec8e in ?? () from /lib/libdbus-1.so.3
#5 0xb6dc0234 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
#6 0xb685207d in ?? () from /usr/lib/libdbus-glib-1.so.2
#7 0xb756e79a in IA__g_main_context_dispatch (context=0x9d32118)
    at gmain.c:2068
#8 0xb7571eb8 in g_main_context_iterate (context=0x9d32118, block=1,
    dispatch=1, self=0x9d0a2b8) at gmain.c:2701
#9 0xb75723cb in IA__g_main_loop_run (loop=0x9dbe8d8) at gmain.c:2924
#10 0xb7999590 in IA__gtk_dialog_run (dialog=0x9d6cbe0) at gtkdialog.c:1067
#11 0x0805c530 in idle_cb (uris=0x0) at main.c:340
#12 0xb756c7d0 in g_idle_dispatch (source=0x9dc0ea8, callback=0x36333031,
    user_data=0x0) at gmain.c:4173
#13 0xb756e79a in IA__g_main_context_dispatch (context=0x9d32118)
    at gmain.c:2068
#14 0xb7571eb8 in g_main_context_iterate (context=0x9d32118, block=1,
    dispatch=1, self=0x9d0a2b8) at gmain.c:2701
#15 0xb75723cb in IA__g_main_loop_run (loop=0x9d5b000) at gmain.c:2924
#16 0xb7de9ae0 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#17 0x0805c8c5 in main (argc=Cannot access memory at address 0x5
) at main.c:783

Erik van Pienbroek (openftd) wrote :

After being bit by this bug myself, I decided to search for the cause.

In Subversion commit 9125 of evolution-data-server, the behaviour of the function camel_folder_summary_array (which is called by the function camel_folder_get_summary) has changed.

Instead of a GPtrArray containing CamelMessageInfo pointers, the function now returns a GPtrArray containing uid's (char*). This can be seen in detail at http://svn.gnome.org/viewvc/evolution-data-server/trunk/camel/camel-folder-summary.c?view=diff&r1=9124&r2=9125 (search for 'camel_folder_summary_array').

I've created a patch which should solve this problem, but as mail-notification requires a newer version of gob2 (which isn't released yet) I can't test out this patch, so I don't know exactly if this really solves the problem.

Hopefully this will be enough information for Jean-Yves Lefort to really solve this problem.

Jean-Yves Lefort (jylefort) wrote :

This is more than enough, thanks.

Changed in mail-notification:
importance: Undecided → High
status: New → Confirmed
Erik van Pienbroek (openftd) wrote :

I manually injected my patch in mn-evolution-server.c during compilation and can confirm that evolution 2.23.5 doesn't crash anymore.

Erik van Pienbroek (openftd) wrote :

So, what's the current state of this issue?

Götz Waschk (waschk-mandriva) wrote :

It is fixed on the Mandriva package by manually patching mn-evolution-server.c.

This bug is still present in current Intrepid - and making the combined use of Mail-Notification and Evolution impossible.

After manually patching the Ubuntu/Debian package, Evolution stops crashing and Mail-Notification starts working.

Jonathan Steinhart (jsteinhart) wrote :

Just curious -- how did you get the patched version to build without gob2 2.0.16? Did you patch the source for gob2 2.0.15 with patches from the gob2 mailing list? If so, which one(s)?

I didn't use gob at all - i just replaced the

CamelMessageInfo *info = summary->pdata[i];

line with

char *uid = summary->pdata[i];
CamelMessageInfo *info = camel_folder_get_message_info(folder, uid);

in the .c and touched the .stamp then build it.

So, how does a mere mortal with Intrepid, like myself, fix this issue? Since I upgraded to Intrepid this plugin has stopped working altogether. If I start the plugin manually from a terminal it immediately kills the Evolution (if it was running, of course) and if it is started prior to running Evolution then the Evolution won't start.

I'm not good at "building" or "touching" anything, to me those two words represent more labor than what I'm willing to "commit" to in front of a computer. Joking aside, if someone wouldn't mind coming up with a patch script that I can easily apply I would appreciate that very much. For now I'm forced to use the standard mail notification in the systray, but I'd like this one better because it shows (at least it used to) in my Awn Notification area of the Avant Window Navigator 3.1.

Croatian

I have a patched (unofficial, untested) version of this in my PPA, which have been working fine for me. My only change was the minor fix suggested by Rotbart on 10/31. You can download and install these packages manually from here:

http://ppa.launchpad.net/jsteinhart/ubuntu/pool/main/m/mail-notification/

(Not sure if you only need one or both of mail-notification and mail-notification-evolution -- might as well grab both debs for your architecture) Alternatively, you can add these two lines to your /etc/apt/sources.list and do an update/upgrade:

deb http://ppa.launchpad.net/jsteinhart/ubuntu intrepid main universe multiverse restricted
deb-src http://ppa.launchpad.net/jsteinhart/ubuntu intrepid main universe multiverse restricted

The first way is probably better, since you won't clutter your APT sources and potentially complicate further troubleshooting of this or any other software which is duplicated in my PPA. When the new, official mail-notification pkgs are released, they will replace mine on your system.

Klaus Doblmann (moviemaniac) wrote :

Confirming versions mail-notification_5.4.dfsg.1-1build2~ppa1_i386.deb and mail-notification-evolution_5.4.dfsg.1-1build2~ppa1_i386.deb to work over here, thanks very much for the .debs, jsteinhart and thanks to everyone who contributed to making mail-notification work again!

Klaus Doblmann (moviemaniac) wrote :

Setting this to "fix committed" (see post by jsteinman for updated packages)

Changed in mail-notification:
status: New → Fix Committed
status: Confirmed → Fix Committed
Klaus Doblmann (moviemaniac) wrote :

my bad, this is not fixed upstream as of yet...

Changed in mail-notification:
status: Fix Committed → Confirmed

Hi Folks.

I can confirm that the fix in the ppa mentioned above works on amd64 here too.

jsteinhart,

Excellent work, I very much appreciate that. It worked fine, except that I rushed a little and didn't check first if I left the old copy of mail-notification running at the time of the installation of the new build. That caused it (I think) to show an error message as soon as it finished installing mail-notification package in which it tells me to run 'sudo apt-get install -f' in a terminal window. I ran than and it went fine. Then I ran the mail-notification-evolution and that showed no errors.

So, to conclude, I too can now run the app on my i386 Intrepid.

Thanks a bunch! ;-)

--Croatian

bgruber (bsg4+ubuntu052006) wrote :

though a fixed package is available in a ppa (http://ppa.launchpad.net/jsteinhart/ubuntu/pool/main/m/mail-notification/) it has not been committed to ubuntu

Changed in mail-notification:
status: Fix Committed → Confirmed
tp42 (45-spamex) wrote :

Hi jsteinhart,
the patch worked perfect for me. Now, Evolution 2.24.x on my Ubutnu 8.10 with evo-mail notifier works without crashing.
Thanks a lot!
Best regards,
Thomas

The patch (and debs) now work perfectly for me (Ubuntu 8.10). Thanks a
bunch to who worked on this!

Mikael Sennerholm (mikannet) wrote :

The ppa build works for me to (Ubuntu 8.10). Thanks a lot.

Fabien Tassin (fta) on 2008-11-28
Changed in mail-notification:
assignee: nobody → fta
Fabien Tassin (fta) wrote :

This bug has been ignored for too long so I went ahead and fixed it in Jaunty.

Changed in mail-notification:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mail-notification - 5.4.dfsg.1-1ubuntu1

---------------
mail-notification (5.4.dfsg.1-1ubuntu1) jaunty; urgency=low

  * [debian/patches/02-fix_evolution_crash_on_startup.diff]:
    Fix crash of evolution on startup. (LP: #251031)
    Thanks to Erik van Pienbroek for the initial patch.
    Unfortunately, patching a ".gob" file means re-running gob2 but
    mail-notification requires gob2 2.0.16, which does not exist as of today.
    Patch the generated file too, and touch the corresponding
    stamp file so gob2 is not needed.

 -- Fabien Tassin <email address hidden> Fri, 28 Nov 2008 21:55:16 +0100

Changed in mail-notification:
status: Fix Committed → Fix Released
bench (tklee08) wrote :

Had the same problem on Ibex and tried jsteinhart's ppa version,
 but it works only partially. I have two mail accounts and works fine with one
 account but not with the other.
When the Inbox on the problematic account is added to the Mailbox list on
"Mail Notification Properties" window in Gnome, Evolution dies and
an error message on the
"Mail Notification Properties" window appears
with "unhandled Evolution mailbox(unable to contact Evolution)."
Any help? Thanks

Fabien Tassin (fta) wrote :

bench, please note that I've fixed this bug only in Jaunty, not in Intrepid/Hardy/...

Archangelwu (archangelwu) wrote :

always report on evolution 2.24 crashes on startup

please help ...

mail-notification-evolution
version : 5.4.dfsg.1-1 build 1

mail-notification
version : 5.4.dfsg.1-1 build 1

2008-12-04

Nicolas da Luz Duque (hot-boy) wrote :

This is a critical bug (totally prevents evolution from working, if you've dist-upgraded and don't know where it comes from). Shouldn't it be commited in interpid-update ?

For now I'll use the debs in jsteinhart's ppa, but it shouldn't be regarded as a fix. More like a temporary quickfix. Jaunty isn't due for another few months so I don't think it is sufficient to fix it there only.

Changed in mail-notification:
status: New → Fix Released
Hew McLachlan (hew) on 2008-12-20
Changed in mail-notification:
importance: Undecided → High
Hew McLachlan (hew) wrote :

Nominated for Intrepid and subscribed motu-sru. This is a severe regression, causing Evolution to be unusable for mail-notification users.

description: updated
Archangelwu (archangelwu) wrote :

2008/12/20 Hew McLachlan <email address hidden>

> Nominated for Intrepid and subscribed motu-sru. This is a severe
> regression, causing Evolution to be unusable for mail-notification
> users.
>
> ** Description changed:
>
> This is on Mandriva Cooker i586 with mail-notification 5.4 built against
> evolution-data-server 2.23.5. and evolution 2.23.5. Evolution crashes on
> startup with the following backtrace:
> #0 camel_message_info_uint32 (mi=0x8b5ee80, id=5)
> at camel-folder-summary.c:4228
> #1 0xb2e7f26e in ?? ()
> from
> /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
> #2 0x08b5ee80 in ?? ()
> #3 0x00000005 in ?? ()
> #4 0x08e06a48 in ?? ()
> #5 0xb768a0bc in IA__g_type_value_table_peek (type=68) at gtype.c:3893
> #6 0xb2e8059c in ?? ()
> from
> /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
> #7 0x00000044 in ?? ()
> #8 0x08c4ed60 in ?? ()
> #9 0x08e2fd10 in ?? ()
> #10 0x00000000 in ?? ()
> +
> + SRU STATEMENT:
> + mail-notification 5.4.dfsg.1-1build1 in Intrepid causes Evolution to
> crash. This bug has been fixed in mail-notification
> 5.4.dfsg.1-1ubuntu1, which is a relatively small patch.
> +
> + TEST CASE:
> + Run mail-notification 5.4.dfsg.1-1build1, then open Evolution and observe
> the crash. When using mail-notification 5.4.dfsg.1-1ubuntu1, this crash does
> not occur.
>
> --
> evolution 2.23.5 crashes on startup
> https://bugs.launchpad.net/bugs/251031
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mail Notification: Confirmed
> Status in "mail-notification" source package in Ubuntu: Fix Released
> Status in "mail-notification" source package in Mandriva: Fix Released
>
> Bug description:
> This is on Mandriva Cooker i586 with mail-notification 5.4 built against
> evolution-data-server 2.23.5. and evolution 2.23.5. Evolution crashes on
> startup with the following backtrace:
> #0 camel_message_info_uint32 (mi=0x8b5ee80, id=5)
> at camel-folder-summary.c:4228
> #1 0xb2e7f26e in ?? ()
> from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
> #2 0x08b5ee80 in ?? ()
> #3 0x00000005 in ?? ()
> #4 0x08e06a48 in ?? ()
> #5 0xb768a0bc in IA__g_type_value_table_peek (type=68) at gtype.c:3893
> #6 0xb2e8059c in ?? ()
> from /usr/lib/evolution/2.24/plugins/liborg-jylefort-mail-notification.so
> #7 0x00000044 in ?? ()
> #8 0x08c4ed60 in ?? ()
> #9 0x08e2fd10 in ?? ()
> #10 0x00000000 in ?? ()
>
> SRU STATEMENT:
> mail-notification 5.4.dfsg.1-1build1 in Intrepid causes Evolution to crash.
> This bug has been fixed in mail-notification 5.4.dfsg.1-1ubuntu1,
> which is a relatively small patch.
>
> TEST CASE:
> Run mail-notification 5.4.dfsg.1-1build1, then open Evolution and observe
> the crash. When using mail-notification 5.4.dfsg.1-1ubuntu1, this crash does
> not occur.

Please Upgrate this TEST CASE to
Run mail-notification 5.4.dfsg.1-1build1 in Intrepid causes Evolution 2.24.2
to crash.
linux kernel 2.6.27-9

Hew McLachlan (hew) wrote :

I don't use Evolution (or Intrepid) so I have not experienced the bug myself. If I have misunderstood the problem and the test case is not accurate, please read https://wiki.ubuntu.com/StableReleaseUpdates#Procedure and correct the test case. Thanks.

mgoetz (mgoetz01) on 2009-12-02
Changed in mail-notification (Mandriva):
status: Fix Released → Confirmed
Sense Egbert Hofstede (sense) wrote :

mgoetz: When changing the status of a bug people often clarify why they made the change. What made you change the bug from Fix Released to Confirmed again almost a year after the bug was closed?
If you still experience a similar bug it's most likely a new one since the code has been changed a lot since the now old version 2.23.5.

Mitch Towner (kermiac) wrote :

changed the upstream task to null & invalid as this was incorrectly set.

affects: evolution → null
Changed in null:
status: New → Invalid
Fabien Tassin (fta) on 2010-02-12
Changed in mail-notification (Ubuntu):
assignee: Fabien Tassin (fta) → nobody
Changed in mail-notification (Mandriva):
status: Confirmed → Fix Released
Changed in mail-notification:
status: Confirmed → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers