Auth plugins have lots of duplicated code

Bug #904065 reported by François Marier on 2011-12-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Unassigned

Bug Description

Core authentication plugins (e.g. XMLRPC, SAML and LDAP) have a significant amount of duplicated code which could lead to certain checks not being performed correctly.

We should look at refactoring some of it to make these plugins more robust and easier to maintain. It will also make it much easier for contrib plugins that have to extend the same API.

Changed in mahara:
milestone: 1.5.0 → none
Ruslan Kabalin (rkabalin) wrote :

There are also some duplicates in the core auth lib I have spotted.

Son Nguyen (ngson2000) wrote :

The tool PMD/CPD (http://pmd.sourceforge.net/cpd.html) to detect code duplicates is quite helpful

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers